aboutsummaryrefslogtreecommitdiff
path: root/misc/kdeedu4/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
commit0f583d87000061087521fb77c44c9055d122d787 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /misc/kdeedu4/Makefile
parent558a51279c03199a7a20966174a8f0a1f33dc9b2 (diff)
downloadports-0f583d87000061087521fb77c44c9055d122d787.tar.gz
ports-0f583d87000061087521fb77c44c9055d122d787.zip
Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks and
Plasma5 ports At the moment KDE ports use bsd.kde4.mk to handle their dependencies. When working on the ports for KDE Frameworks and Plasma5 it seemed to be more reasonable to create a new kde.mk instead of adding an bsd.kde5.mk. The kde.mk in this review is a stripped down version of the one we are using in the KDE Test repositories plasma5 branch [1] to only contain the parts relevant to the current KDE4 ports in the portstree [2]. Changes to the KDE Ports needed by this: Replace USE_KDE4 by USE_KDE [3] Add USES=kde:4 [4] [1] http://src.mouf.net/area51/view/branches/plasma5/KDE/Mk/Uses/kde.mk [2] The version in the plasma5 branch also handles frameworks/plasma5 and handles MASTER_SITES via a KDE_DIST variable similar to bsd.qt.mk for Qt Ports -- I chose to leave this out for now, as the diff is already large enough. [3] I chose USE_KDE instead of USE_KDE4, USE_KDE5, USE_KDEX as the version we want is already specified as argument to kde:<arg> [4] For KDE Frameworks and Plasma5 ports this would be kde:5 PR: 210667 Approved by: portmgr, mat (mentor), rakuco (mentor) Reviewed by: mat, rakuco Differential Revision: https://reviews.freebsd.org/D6961
Notes
Notes: svn path=/head/; revision=420774
Diffstat (limited to 'misc/kdeedu4/Makefile')
-rw-r--r--misc/kdeedu4/Makefile47
1 files changed, 23 insertions, 24 deletions
diff --git a/misc/kdeedu4/Makefile b/misc/kdeedu4/Makefile
index e6aed3885a61..dab34195a725 100644
--- a/misc/kdeedu4/Makefile
+++ b/misc/kdeedu4/Makefile
@@ -8,8 +8,7 @@ CATEGORIES= misc kde
MAINTAINER= kde@FreeBSD.org
COMMENT= Entertaining and educational programs for KDE 4 (meta port)
-USE_KDE4= # blank, needed to get KDE4_VERSION
-USES= metaport
+USES= kde:4 metaport
OPTIONS_DEFINE= ARTIKULATE BLINKEN CANTOR KALGEBRA KALZIUM KANAGRAM KBRUCH KGEOGRAPHY \
KHANGMAN KIG KITEN KLETTRES KMPLOT KSTARS KTOUCH KTURTLE \
@@ -17,69 +16,69 @@ OPTIONS_DEFINE= ARTIKULATE BLINKEN CANTOR KALGEBRA KALZIUM KANAGRAM KBRUCH KGEOG
OPTIONS_DEFAULT= ${OPTIONS_DEFINE:NARTIKULATE}
ARTIKULATE_DESC= Pronunciation trainer
-ARTIKULATE_RUN_DEPENDS= ${KDE4_PREFIX}/bin/artikulate:misc/artikulate
+ARTIKULATE_RUN_DEPENDS= ${KDE_PREFIX}/bin/artikulate:misc/artikulate
BLINKEN_DESC= Memory enhancement game
-BLINKEN_RUN_DEPENDS= ${KDE4_PREFIX}/bin/blinken:games/blinken
+BLINKEN_RUN_DEPENDS= ${KDE_PREFIX}/bin/blinken:games/blinken
CANTOR_DESC= Frontend to mathematical software
-CANTOR_RUN_DEPENDS= ${KDE4_PREFIX}/bin/cantor:math/cantor
+CANTOR_RUN_DEPENDS= ${KDE_PREFIX}/bin/cantor:math/cantor
KALGEBRA_DESC= Graph calculator
-KALGEBRA_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kalgebra:math/kalgebra
+KALGEBRA_RUN_DEPENDS= ${KDE_PREFIX}/bin/kalgebra:math/kalgebra
KALZIUM_DESC= Periodic table of elements
-KALZIUM_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kalzium:science/kalzium
+KALZIUM_RUN_DEPENDS= ${KDE_PREFIX}/bin/kalzium:science/kalzium
KANAGRAM_DESC= Letter order game
-KANAGRAM_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kanagram:games/kanagram
+KANAGRAM_RUN_DEPENDS= ${KDE_PREFIX}/bin/kanagram:games/kanagram
KBRUCH_DESC= Application to exercise fractions
-KBRUCH_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kbruch:math/kbruch
+KBRUCH_RUN_DEPENDS= ${KDE_PREFIX}/bin/kbruch:math/kbruch
KGEOGRAPHY_DESC= Geography trainer
-KGEOGRAPHY_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kgeography:misc/kgeography
+KGEOGRAPHY_RUN_DEPENDS= ${KDE_PREFIX}/bin/kgeography:misc/kgeography
KHANGMAN_DESC= Hangman game
-KHANGMAN_RUN_DEPENDS= ${KDE4_PREFIX}/bin/khangman:games/khangman
+KHANGMAN_RUN_DEPENDS= ${KDE_PREFIX}/bin/khangman:games/khangman
KIG_DESC= Interactive geometry application
-KIG_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kig:math/kig
+KIG_RUN_DEPENDS= ${KDE_PREFIX}/bin/kig:math/kig
KITEN_DESC= Japanese reference/study tool
-KITEN_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kiten:japanese/kiten
+KITEN_RUN_DEPENDS= ${KDE_PREFIX}/bin/kiten:japanese/kiten
KLETTRES_DESC= Alphabet learning tool
-KLETTRES_RUN_DEPENDS= ${KDE4_PREFIX}/bin/klettres:misc/klettres
+KLETTRES_RUN_DEPENDS= ${KDE_PREFIX}/bin/klettres:misc/klettres
KMPLOT_DESC= Mathematical function plotter
-KMPLOT_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kmplot:math/kmplot
+KMPLOT_RUN_DEPENDS= ${KDE_PREFIX}/bin/kmplot:math/kmplot
KSTARS_DESC= Desktop planetarium
-KSTARS_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kstars:astro/kstars
+KSTARS_RUN_DEPENDS= ${KDE_PREFIX}/bin/kstars:astro/kstars
KTOUCH_DESC= Touch typing tutor
-KTOUCH_RUN_DEPENDS= ${KDE4_PREFIX}/bin/ktouch:misc/ktouch
+KTOUCH_RUN_DEPENDS= ${KDE_PREFIX}/bin/ktouch:misc/ktouch
KTURTLE_DESC= Educational programming environment
-KTURTLE_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kturtle:lang/kturtle
+KTURTLE_RUN_DEPENDS= ${KDE_PREFIX}/bin/kturtle:lang/kturtle
KWORDQUIZ_DESC= Flash card trainer
-KWORDQUIZ_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kwordquiz:misc/kwordquiz
+KWORDQUIZ_RUN_DEPENDS= ${KDE_PREFIX}/bin/kwordquiz:misc/kwordquiz
MARBLE_DESC= Virtual globe and world atlas
-MARBLE_USE= KDE4=marble_run
+MARBLE_USE= KDE=marble_run
PAIRS_DESC= Memory and pairs game
-PAIRS_RUN_DEPENDS= ${KDE4_PREFIX}/bin/pairs:games/pairs
+PAIRS_RUN_DEPENDS= ${KDE_PREFIX}/bin/pairs:games/pairs
PARLEY_DESC= Vocabulary trainer
-PARLEY_RUN_DEPENDS= ${KDE4_PREFIX}/bin/parley:misc/parley
+PARLEY_RUN_DEPENDS= ${KDE_PREFIX}/bin/parley:misc/parley
ROCS_DESC= Graph teory IDE
-ROCS_RUN_DEPENDS= ${KDE4_PREFIX}/bin/rocs:math/rocs
+ROCS_RUN_DEPENDS= ${KDE_PREFIX}/bin/rocs:math/rocs
STEP_DESC= Interactive physics simulator
-STEP_RUN_DEPENDS= ${KDE4_PREFIX}/bin/step:science/step
+STEP_RUN_DEPENDS= ${KDE_PREFIX}/bin/step:science/step
.include <bsd.port.mk>