aboutsummaryrefslogtreecommitdiff
path: root/misc/kenny
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-01-02 23:22:26 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-01-02 23:22:26 +0000
commit69ac3135908c5fb2494970596a4df49d17f61283 (patch)
tree2b310b39dab9c7901adc6cc8c9f676d0dbd7dee1 /misc/kenny
parent6ee266f6fe133510c1ac7ab9d50dd05c091b152f (diff)
downloadports-69ac3135908c5fb2494970596a4df49d17f61283.tar.gz
ports-69ac3135908c5fb2494970596a4df49d17f61283.zip
New port kenny version 1.6: Translate text both to and from KennySpeak
PR: 33171 Submitted by: Alan Eldridge <ports@geeksrus.net>
Notes
Notes: svn path=/head/; revision=52514
Diffstat (limited to 'misc/kenny')
-rw-r--r--misc/kenny/Makefile51
-rw-r--r--misc/kenny/distinfo1
-rw-r--r--misc/kenny/pkg-comment1
-rw-r--r--misc/kenny/pkg-descr10
-rw-r--r--misc/kenny/pkg-plist1
5 files changed, 64 insertions, 0 deletions
diff --git a/misc/kenny/Makefile b/misc/kenny/Makefile
new file mode 100644
index 000000000000..4b5d87ac59c4
--- /dev/null
+++ b/misc/kenny/Makefile
@@ -0,0 +1,51 @@
+# ex:ts=8
+#
+# New ports collection makefile for: kenny
+# Date created: 2001/12/25
+# Whom: Alan E ports@geeksrus.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= kenny
+PORTVERSION= 1.6
+CATEGORIES= misc perl5
+MASTER_SITES= http://www.h.shuttle.de/mitch/stuff/
+DISTNAME= kenny.pl-${PORTVERSION}
+EXTRACT_SUFX= .gz
+EXTRACT_ONLY=
+
+MAINTAINER= ports@geeksrus.net
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+MAN1= kenny.1
+
+program= kenny
+manpage= kenny.1
+
+.if exists(/usr/bin/pod2man)
+POD2MAN= /usr/bin/pod2man
+.elif exists(${LOCALBASE}/bin/pod2man)
+POD2MAN= ${LOCALBASE}/bin/pod2man
+.else
+POD2MAN= pod2man
+.endif
+
+post-extract:
+ @${GUNZIP_CMD} -c ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} \
+ > ${WRKDIR}/${program}
+ @${POD2MAN} ${WRKDIR}/${program} > ${WRKDIR}/${manpage}
+
+post-patch:
+ @${PERL} -pi -e "s|/usr/bin/perl|${PERL}|" ${WRKDIR}/${program}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKDIR}/${program} ${PREFIX}/bin/${program}
+ @${INSTALL_MAN} ${WRKDIR}/${manpage} ${MANPREFIX}/man/man1/${manpage}
+
+.include <bsd.port.mk>
+
+#
+#EOF
diff --git a/misc/kenny/distinfo b/misc/kenny/distinfo
new file mode 100644
index 000000000000..ea00a6cb56a3
--- /dev/null
+++ b/misc/kenny/distinfo
@@ -0,0 +1 @@
+MD5 (kenny.pl-1.6.gz) = 49c51ed4a33cd475cb4add69acfc46bf
diff --git a/misc/kenny/pkg-comment b/misc/kenny/pkg-comment
new file mode 100644
index 000000000000..7ecc783371ab
--- /dev/null
+++ b/misc/kenny/pkg-comment
@@ -0,0 +1 @@
+Translate text both to and from KennySpeak
diff --git a/misc/kenny/pkg-descr b/misc/kenny/pkg-descr
new file mode 100644
index 000000000000..8cb3ae881364
--- /dev/null
+++ b/misc/kenny/pkg-descr
@@ -0,0 +1,10 @@
+kenny.pl translates a given text from or to KennySpeak.
+KennySpeak looks like this:
+
+ "Ppfmfp ppmffm mfmppfmpm, fmpmfpmppffm'fpmmpp
+ pmpmffpmfpmfmppmpm Pmpmppppppppffm!"
+
+KennySpeak was invented by Kohan Ikin. kenny.pl was written by
+Christian Garbs.
+
+WWW: http://www.h.shuttle.de/mitch/kenny.en.html
diff --git a/misc/kenny/pkg-plist b/misc/kenny/pkg-plist
new file mode 100644
index 000000000000..668813c6d001
--- /dev/null
+++ b/misc/kenny/pkg-plist
@@ -0,0 +1 @@
+bin/kenny