aboutsummaryrefslogtreecommitdiff
path: root/misc/kenny
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
commit7c47779cb9cc1f12908949c26b831e944047ed17 (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /misc/kenny
parentb4c4d6656e7b913544a3cbd1bea7f40f7cad2e74 (diff)
downloadports-7c47779cb9cc1f12908949c26b831e944047ed17.tar.gz
ports-7c47779cb9cc1f12908949c26b831e944047ed17.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=403913
Diffstat (limited to 'misc/kenny')
-rw-r--r--misc/kenny/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/misc/kenny/Makefile b/misc/kenny/Makefile
index 32fd136ef934..2c0cb55a9862 100644
--- a/misc/kenny/Makefile
+++ b/misc/kenny/Makefile
@@ -17,13 +17,13 @@ LICENSE= ART10
CONFLICTS= filters-*
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= extract build run
+SHEBANG_FILES= ${PORTNAME}
EXTRACT_CMD= ${GZCAT}
EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= > ${WRKSRC}/${PORTNAME}
NO_ARCH= yes
-NO_BUILD= yes
NO_WRKSUBDIR= yes
PLIST_FILES= bin/kenny \
@@ -31,8 +31,7 @@ PLIST_FILES= bin/kenny \
POD2MAN?= ${LOCALBASE}/bin/pod2man
-post-extract:
- @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/${PORTNAME}
+do-build:
@${POD2MAN} ${WRKSRC}/${PORTNAME} > ${WRKSRC}/${PORTNAME}.1
do-install: