aboutsummaryrefslogtreecommitdiff
path: root/misc/konq-plugins/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-19 07:35:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-19 07:35:53 +0000
commit251f96e95b43aa936354f3fd149b332d21c52077 (patch)
tree01aff7e4f93f55cf9e463341e0d333d09b4920cd /misc/konq-plugins/Makefile
parentd6becc577ccc460afcde0ecc651d2ff3bfc0f979 (diff)
downloadports-251f96e95b43aa936354f3fd149b332d21c52077.tar.gz
ports-251f96e95b43aa936354f3fd149b332d21c52077.zip
Notes
Diffstat (limited to 'misc/konq-plugins/Makefile')
-rw-r--r--misc/konq-plugins/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/misc/konq-plugins/Makefile b/misc/konq-plugins/Makefile
index c3b55996632f..6212e46ede62 100644
--- a/misc/konq-plugins/Makefile
+++ b/misc/konq-plugins/Makefile
@@ -1,23 +1,25 @@
-# New ports collection makefile for: konq-plugins
-# Date created: 11 February 2004
+# New ports collection makefile for: atlantikdesigner
+# Date created: 11 Febrary 2004
# Whom: Michael Nottebrock <lofi@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= ${KONQPLUGINS_PORTNAME}
-PORTVERSION= ${KONQPLUGINS_PORTVERSION}
-PORTREVISION= 1
-CATEGORIES= misc kde
+PORTNAME= ${ATLANTIKDESIGNER_PORTNAME}
+PORTVERSION= ${ATLANTIKDESIGNER_PORTVERSION}
+PORTREVISION= ${ATLANTIKDESIGNER_PORTREVISION}
+CATEGORIES= games kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
-COMMENT= Additonal plugins and features for Konqueror
+COMMENT= Editor for Atlantik
-KDE_SPLIT= ${KONQPLUGINS_PORTNAME:S/${KDE_SPLIT_DIST}-//}
-USE_KDEBASE_VER=3
+LIB_DEPENDS= atlantic:${PORTSDIR}/games/kdegames3
+
+KDE_SPLIT= ${ATLANTIKDESIGNER_PORTNAME:S/${KDE_SPLIT_DIST}-//}
+KDE_DOC_SPLIT= # none
USE_KDELIBS_VER=3
USE_BZIP2= yes
@@ -28,6 +30,9 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib/kde3
+PLIST_SUB+= KDE_VER="${KDE_VERSION}"
+
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include "${.CURDIR}/../../misc/kdeaddons3/Makefile.split"
+
.include <bsd.port.mk>