aboutsummaryrefslogtreecommitdiff
path: root/misc/lazyread
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-08-22 16:33:59 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-08-22 16:33:59 +0000
commitfcc5a766083f8a995807351dd30601c55af45f1d (patch)
tree108a1e4e860e7c6188c7975aa3a580d080a45098 /misc/lazyread
parent155eb4d28c4c4b2899b105249a4b0f75103fe8ab (diff)
downloadports-fcc5a766083f8a995807351dd30601c55af45f1d.tar.gz
ports-fcc5a766083f8a995807351dd30601c55af45f1d.zip
- Rename misc/lr to misc/lazyread to reflect upstream name and avoid conflicts with sysutils/lr
- Simplify and fix lesspipe.sh handling (add missing argument, and assume it always exists) - Cleanup and simplify the port PR: 221206 Approved by: maintainer timeout (mich, 2 weeks)
Notes
Notes: svn path=/head/; revision=448545
Diffstat (limited to 'misc/lazyread')
-rw-r--r--misc/lazyread/Makefile31
-rw-r--r--misc/lazyread/distinfo3
-rw-r--r--misc/lazyread/files/patch-lazyread.c11
-rw-r--r--misc/lazyread/pkg-descr8
4 files changed, 53 insertions, 0 deletions
diff --git a/misc/lazyread/Makefile b/misc/lazyread/Makefile
new file mode 100644
index 000000000000..042296f6aff2
--- /dev/null
+++ b/misc/lazyread/Makefile
@@ -0,0 +1,31 @@
+# Created by: Michael L. Hostbaek (mich@freebsdcluster.org)
+# $FreeBSD$
+
+PORTNAME= lazyread
+PORTVERSION= 2.0
+CATEGORIES= misc
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
+
+MAINTAINER= mich@FreeBSD.org
+COMMENT= Lazyread can auto-scroll files on your screen in movie credit fashion
+
+USES= ncurses
+
+LDFLAGS+= -lncurses
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -o ${PORTNAME} lazyread.c ${LDFLAGS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/misc/lazyread/distinfo b/misc/lazyread/distinfo
new file mode 100644
index 000000000000..ec57cb62057a
--- /dev/null
+++ b/misc/lazyread/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1501778211
+SHA256 (lazyread-2.0.tar.gz) = 7e462c5c9fe104d69e410c537336af838a30a030699dd9320f75fe85a20746a1
+SIZE (lazyread-2.0.tar.gz) = 12583
diff --git a/misc/lazyread/files/patch-lazyread.c b/misc/lazyread/files/patch-lazyread.c
new file mode 100644
index 000000000000..6351571b7bed
--- /dev/null
+++ b/misc/lazyread/files/patch-lazyread.c
@@ -0,0 +1,11 @@
+--- lazyread.c.orig 2003-02-02 13:28:15 UTC
++++ lazyread.c
+@@ -377,7 +377,7 @@ char qfilename[BUFMAX]; /* quoted filena
+
+ printf("Loading..\n");
+ /* $LESSOPEN will look like: |/usr/bin/lesspipe.sh %s */
+- lesspipe = getenv("LESSOPEN");
++ lesspipe = "|/usr/bin/lesspipe.sh %s";
+ if (lesspipe) {
+ /* strip off the leading | */
+ if ((c = strchr(lesspipe, '|'))) {
diff --git a/misc/lazyread/pkg-descr b/misc/lazyread/pkg-descr
new file mode 100644
index 000000000000..2d2597e74e1f
--- /dev/null
+++ b/misc/lazyread/pkg-descr
@@ -0,0 +1,8 @@
+Lazyread is a C program that auto-scrolls files on your screen
+in movie credit fashion. It allows the user to read without having
+to manually scroll down to see new pages. There are lots of
+features, such as being able to choose the speed at which it
+scrolls, pause, dynamic speed up, the ability to highlight lines
+that contain a specified string, and much more.
+
+WWW: http://lazyread.sourceforge.net/