aboutsummaryrefslogtreecommitdiff
path: root/misc/libsolv
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-09-20 04:51:43 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-09-20 04:51:43 +0000
commit21f22e77f186f782702d9507acb3149b326649ca (patch)
treece2942ca2cabfb793d548f70da38a019da7f2938 /misc/libsolv
parent3cf1bacd9b9a5b9949a94c18f43773d0ccf4a705 (diff)
Notes
Diffstat (limited to 'misc/libsolv')
-rw-r--r--misc/libsolv/Makefile19
-rw-r--r--misc/libsolv/distinfo3
-rw-r--r--misc/libsolv/files/patch-CMakeLists.txt11
-rw-r--r--misc/libsolv/pkg-descr15
-rw-r--r--misc/libsolv/pkg-plist54
5 files changed, 102 insertions, 0 deletions
diff --git a/misc/libsolv/Makefile b/misc/libsolv/Makefile
new file mode 100644
index 000000000000..2e7b7cb6eb5d
--- /dev/null
+++ b/misc/libsolv/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= libsolv
+DISTVERSION= 0.7.4
+CATEGORIES= misc
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Package dependency solver using a satisfiability algorithm
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.BSD
+
+USES= cmake
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= rpm-software-management
+
+.include <bsd.port.mk>
diff --git a/misc/libsolv/distinfo b/misc/libsolv/distinfo
new file mode 100644
index 000000000000..4272cf4a559e
--- /dev/null
+++ b/misc/libsolv/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1600576582
+SHA256 (rpm-software-management-libsolv-0.7.4_GH0.tar.gz) = 725b598075c5c44a90cbda5594fd29417144ff8acb9762996162e7b68f94c8c4
+SIZE (rpm-software-management-libsolv-0.7.4_GH0.tar.gz) = 662383
diff --git a/misc/libsolv/files/patch-CMakeLists.txt b/misc/libsolv/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..13118c05060d
--- /dev/null
+++ b/misc/libsolv/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2020-09-20 04:37:26 UTC
++++ CMakeLists.txt
+@@ -44,7 +44,7 @@ IF (DEFINED LIB)
+ SET (LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/${LIB}")
+ ELSE (DEFINED LIB)
+ IF (CMAKE_SIZEOF_VOID_P MATCHES "8")
+- SET (LIB_SUFFIX "64")
++ SET (LIB_SUFFIX "")
+ ENDIF (CMAKE_SIZEOF_VOID_P MATCHES "8")
+ SET (LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}")
+ ENDIF (DEFINED LIB)
diff --git a/misc/libsolv/pkg-descr b/misc/libsolv/pkg-descr
new file mode 100644
index 000000000000..1b202ac59ba8
--- /dev/null
+++ b/misc/libsolv/pkg-descr
@@ -0,0 +1,15 @@
+This is libsolv, a free package dependency solver using a satisfiability
+algorithm.
+
+The code is based on two major, but independent, blocks:
+1. Using a dictionary approach to store and retrieve package and dependency
+ information in a fast and space efficient manner.
+2. Using satisfiability, a well known and researched topic, for resolving
+ package dependencies.
+
+The sat-solver code has been written to aim for the newest packages, record the
+decision tree to provide introspection, and also allows to provide the user with
+suggestions on how to deal with unsolvable problems. It also takes advantage of
+the repository storage to minimize memory usage.
+
+WWW: https://github.com/rpm-software-management/libsolv
diff --git a/misc/libsolv/pkg-plist b/misc/libsolv/pkg-plist
new file mode 100644
index 000000000000..02d071a3c7f1
--- /dev/null
+++ b/misc/libsolv/pkg-plist
@@ -0,0 +1,54 @@
+bin/dumpsolv
+bin/installcheck
+bin/mergesolv
+bin/repo2solv
+bin/testsolv
+include/solv/bitmap.h
+include/solv/chksum.h
+include/solv/dataiterator.h
+include/solv/dirpool.h
+include/solv/evr.h
+include/solv/hash.h
+include/solv/knownid.h
+include/solv/policy.h
+include/solv/pool.h
+include/solv/poolarch.h
+include/solv/poolid.h
+include/solv/pooltypes.h
+include/solv/poolvendor.h
+include/solv/problems.h
+include/solv/queue.h
+include/solv/repo.h
+include/solv/repo_solv.h
+include/solv/repo_write.h
+include/solv/repodata.h
+include/solv/rules.h
+include/solv/selection.h
+include/solv/solv_xfopen.h
+include/solv/solvable.h
+include/solv/solver.h
+include/solv/solverdebug.h
+include/solv/solvversion.h
+include/solv/strpool.h
+include/solv/testcase.h
+include/solv/tools_util.h
+include/solv/transaction.h
+include/solv/util.h
+lib/libsolv.so
+lib/libsolv.so.1
+lib/libsolvext.so
+lib/libsolvext.so.1
+libdata/pkgconfig/libsolv.pc
+libdata/pkgconfig/libsolvext.pc
+share/cmake/Modules/FindLibSolv.cmake
+share/man/man1/dumpsolv.1.gz
+share/man/man1/installcheck.1.gz
+share/man/man1/mergesolv.1.gz
+share/man/man1/repo2solv.1.gz
+share/man/man1/solv.1.gz
+share/man/man1/testsolv.1.gz
+share/man/man3/libsolv-bindings.3.gz
+share/man/man3/libsolv-constantids.3.gz
+share/man/man3/libsolv-history.3.gz
+share/man/man3/libsolv-pool.3.gz
+share/man/man3/libsolv.3.gz