aboutsummaryrefslogtreecommitdiff
path: root/misc/libsupertone
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2012-06-26 11:11:02 +0000
committerMax Khon <fjoe@FreeBSD.org>2012-06-26 11:11:02 +0000
commit5c6ac40423e69bf45819353e5e16a54505c7452e (patch)
tree7bcb5990b3b16ca9c05f4811bd0594b970536071 /misc/libsupertone
parent7de0c44242a2ba197952d7de54119fd9bc618f77 (diff)
downloadports-5c6ac40423e69bf45819353e5e16a54505c7452e.tar.gz
ports-5c6ac40423e69bf45819353e5e16a54505c7452e.zip
New port: libsupertone
This library is designed to support supervisory tone generation and detection for all parts of the world. WWW: http://www.soft-switch.org/
Notes
Notes: svn path=/head/; revision=300002
Diffstat (limited to 'misc/libsupertone')
-rw-r--r--misc/libsupertone/Makefile25
-rw-r--r--misc/libsupertone/distinfo2
-rw-r--r--misc/libsupertone/files/patch-supertone.c10
-rw-r--r--misc/libsupertone/files/patch-supertone_tests.c10
-rw-r--r--misc/libsupertone/pkg-descr4
-rw-r--r--misc/libsupertone/pkg-plist8
6 files changed, 59 insertions, 0 deletions
diff --git a/misc/libsupertone/Makefile b/misc/libsupertone/Makefile
new file mode 100644
index 000000000000..b89879c50ab7
--- /dev/null
+++ b/misc/libsupertone/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: libsupertone
+# Date created: 26 Jun 2012
+# Whom: Max Khon <fjoe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsupertone
+PORTVERSION= 0.0.2
+CATEGORIES= misc
+MASTER_SITES= http://www.soft-switch.org/downloads/unicall/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= fjoe@FreeBSD.org
+COMMENT= A library for supervisory tone generation and detection
+
+LIB_DEPENDS= spandsp.2:${PORTSDIR}/comms/spandsp-devel
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"\
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_LDCONFIG= yes
+LICENSE= LGPL21
+
+.include <bsd.port.mk>
diff --git a/misc/libsupertone/distinfo b/misc/libsupertone/distinfo
new file mode 100644
index 000000000000..2093662f38c3
--- /dev/null
+++ b/misc/libsupertone/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libsupertone-0.0.2.tgz) = 4b8aee1967a13b019ace4c1c29d283a9c325a28c194ec480fa827afc85d3ed6b
+SIZE (libsupertone-0.0.2.tgz) = 347866
diff --git a/misc/libsupertone/files/patch-supertone.c b/misc/libsupertone/files/patch-supertone.c
new file mode 100644
index 000000000000..50e884bf7e56
--- /dev/null
+++ b/misc/libsupertone/files/patch-supertone.c
@@ -0,0 +1,10 @@
+--- supertone.c.orig 2012-06-26 18:01:41.000000000 +0700
++++ supertone.c 2012-06-26 18:01:54.000000000 +0700
+@@ -53,6 +53,7 @@
+ #include <libxml/xinclude.h>
+
+ #include <spandsp.h>
++#include <spandsp/expose.h>
+
+ #include "supertone.h"
+ #include "libsupertone.h"
diff --git a/misc/libsupertone/files/patch-supertone_tests.c b/misc/libsupertone/files/patch-supertone_tests.c
new file mode 100644
index 000000000000..b7f858577ae5
--- /dev/null
+++ b/misc/libsupertone/files/patch-supertone_tests.c
@@ -0,0 +1,10 @@
+--- supertone_tests.c.orig 2012-06-26 18:03:25.000000000 +0700
++++ supertone_tests.c 2012-06-26 18:03:38.000000000 +0700
+@@ -50,6 +50,7 @@
+ #include <audiofile.h>
+ #endif
+ #include <spandsp.h>
++#include <spandsp/expose.h>
+
+ #include "libsupertone.h"
+
diff --git a/misc/libsupertone/pkg-descr b/misc/libsupertone/pkg-descr
new file mode 100644
index 000000000000..1d546570f1f8
--- /dev/null
+++ b/misc/libsupertone/pkg-descr
@@ -0,0 +1,4 @@
+This library is designed to support supervisory tone generation and detection
+for all parts of the world.
+
+WWW: http://www.soft-switch.org/
diff --git a/misc/libsupertone/pkg-plist b/misc/libsupertone/pkg-plist
new file mode 100644
index 000000000000..5141c808d951
--- /dev/null
+++ b/misc/libsupertone/pkg-plist
@@ -0,0 +1,8 @@
+include/libsupertone.h
+lib/libsupertone.a
+lib/libsupertone.la
+lib/libsupertone.so
+lib/libsupertone.so.0
+share/supertone/global-tones.xml
+share/supertone/tones.dtd
+@dirrm share/supertone