aboutsummaryrefslogtreecommitdiff
path: root/misc/lifelines
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-10-23 13:09:10 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-10-23 13:09:10 +0000
commit2be1162ae85407b035478bca8c9b80c81aa000fb (patch)
tree94690c740743fac80558f7e95ba6c6a8c65a3e62 /misc/lifelines
parent8af0f84cbe164398a7c88ab6211c4d9c603f4e9d (diff)
downloadports-2be1162ae85407b035478bca8c9b80c81aa000fb.tar.gz
ports-2be1162ae85407b035478bca8c9b80c81aa000fb.zip
- Improve wide character (UTF-8) support, define LICENSE (MIT)
- Convert to option helpers and thus cleanup Makefile; running `make package OPTIONS_UNSET=DOCS -DBATCH' will produce a docless package without any pre-staging-era hacks in the Makefile PR: 203098 Submitted by: dhw Approved by: maintainer
Notes
Notes: svn path=/head/; revision=400022
Diffstat (limited to 'misc/lifelines')
-rw-r--r--misc/lifelines/Makefile22
-rw-r--r--misc/lifelines/files/patch-src_stdlib_icvt.c11
2 files changed, 18 insertions, 15 deletions
diff --git a/misc/lifelines/Makefile b/misc/lifelines/Makefile
index eb08c95e547a..429648b2a555 100644
--- a/misc/lifelines/Makefile
+++ b/misc/lifelines/Makefile
@@ -3,34 +3,26 @@
PORTNAME= lifelines
PORTVERSION= 3.0.62
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
MAINTAINER= matt@gsicomp.on.ca
COMMENT= Advanced genealogical system
-GNU_CONFIGURE= yes
+LICENSE= MIT
+
USES= bison iconv tar:bzip2
+GNU_CONFIGURE= yes
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-.else
-CONFIGURE_ARGS+=--disable-nls
-.endif
+NLS_USES= gettext
+NLS_CONFIGURE_OFF= --disable-nls
post-patch:
- @${REINPLACE_CMD} -e 's,ncursesw/curses.h,curses.h,' \
+ @${REINPLACE_CMD} -e 's,ncursesw/curses\.h,curses.h,' \
${WRKSRC}/src/hdrs/mycurses.h
-.if ! ${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} -e 's,install-data-am: install-docDATA,install-data-am:,' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's,install-data-am: install-dist_pkgdataDATA install-docDATA install-man,install-data-am: install-dist_pkgdataDATA,' \
- ${WRKSRC}/docs/Makefile.in
-.endif
.include <bsd.port.mk>
diff --git a/misc/lifelines/files/patch-src_stdlib_icvt.c b/misc/lifelines/files/patch-src_stdlib_icvt.c
new file mode 100644
index 000000000000..82cc5e19c103
--- /dev/null
+++ b/misc/lifelines/files/patch-src_stdlib_icvt.c
@@ -0,0 +1,11 @@
+--- src/stdlib/icvt.c.orig 2006-04-08 02:50:46 UTC
++++ src/stdlib/icvt.c
+@@ -84,7 +84,7 @@ iconv_trans (CNSTRING src, CNSTRING dest
+ /* assume MS-Windows makenarrow call */
+ inlen = 2 * wcslen((const wchar_t *)sin);
+ }
+- if (!strncmp(src, "UCS-2", strlen("UCS-2"))) {
++ if (!strncmp(src, "UCS-4", strlen("UCS-4"))) {
+ /* assume UNIX makenarrow call */
+ inlen = 4 * wcslen((const wchar_t *)sin);
+ }