aboutsummaryrefslogtreecommitdiff
path: root/misc/lifelines
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2016-03-26 10:33:14 +0000
committerThomas Zander <riggs@FreeBSD.org>2016-03-26 10:33:14 +0000
commit6735fd6ff9a6e341c5c8c8ecbe9e462509d0c1f8 (patch)
tree0047f104880bcbeb8612acff9c73311e3efe3420 /misc/lifelines
parent5fb12fd47b69130cf5d7d5820c4028727a4801d6 (diff)
downloadports-6735fd6ff9a6e341c5c8c8ecbe9e462509d0c1f8.tar.gz
ports-6735fd6ff9a6e341c5c8c8ecbe9e462509d0c1f8.zip
Update to upstream version 3.1.1
Changeset includes: - Fix to UTF-8 string handling (handling in upstream version 3.1.1) - Move from SF to GH - MAKE_JOBS_UNSAFE=yes (parallel builds are not reliable at the moment) - Comments on special DOCS handling for this port PR: 208090 Submitted by: matt@gsicomp.on.ca (maintainer)
Notes
Notes: svn path=/head/; revision=411920
Diffstat (limited to 'misc/lifelines')
-rw-r--r--misc/lifelines/Makefile43
-rw-r--r--misc/lifelines/distinfo4
-rw-r--r--misc/lifelines/files/patch-intl__Makefile.in6
-rw-r--r--misc/lifelines/files/patch-src_stdlib_icvt.c11
-rw-r--r--misc/lifelines/pkg-descr2
-rw-r--r--misc/lifelines/pkg-plist110
6 files changed, 103 insertions, 73 deletions
diff --git a/misc/lifelines/Makefile b/misc/lifelines/Makefile
index f8bad8afcc46..8b6dc97b9c71 100644
--- a/misc/lifelines/Makefile
+++ b/misc/lifelines/Makefile
@@ -2,27 +2,50 @@
# $FreeBSD$
PORTNAME= lifelines
-PORTVERSION= 3.0.62
-PORTREVISION= 1
+PORTVERSION= 3.1.1
CATEGORIES= misc
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
+MASTER_SITES= http://github.com/MarcNo/lifelines/releases/download/${PORTVERSION}/
MAINTAINER= matt@gsicomp.on.ca
COMMENT= Advanced genealogical system
LICENSE= MIT
-USES= bison iconv ncurses tar:bzip2
GNU_CONFIGURE= yes
+USES= autoreconf bison gmake iconv
-OPTIONS_DEFINE= DOCS NLS
-OPTIONS_SUB= yes
+MAKE_JOBS_UNSAFE=yes
-NLS_USES= gettext
-NLS_CONFIGURE_OFF= --disable-nls
+# Lifelines always installs documenatation. This is contrary to the FreeBSD
+# norm which uses --with-docs (aka DOCS) to do so. We patch the Makefiles
+# below in pre-patch.
+# Lifelines uses --with-docs to indicate that the full XML docbook toolcahin
+# needs to be installed to build the docs. We use BUILDDOCS for that purpose.
-post-patch:
- @${REINPLACE_CMD} -e 's,ncursesw/curses\.h,curses.h,' \
+OPTIONS_DEFINE= BUILDDOCS DOCS NLS
+OPTIONS_SUB= yes
+OPTIONS_DEFAULT= DOCS NLS
+BUILDDOCS_DESC= Build documentation (requires docbook toolchain)
+DOCS_DESC= Install documentation
+NLS_DESC= Build with NLS support
+
+BUILDDOCS_CONFIGURE_WITH= docs
+BUILDDOCS_BUILD_DEPENDS= xmlto:${PORTSDIR}/textproc/xmlto \
+ dblatex:${PORTSDIR}/textproc/dblatex
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+.include <bsd.port.options.mk>
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's,ncursesw/curses.h,curses.h,' \
${WRKSRC}/src/hdrs/mycurses.h
+.if ! ${PORT_OPTIONS:MDOCS}
+ @${REINPLACE_CMD} -e 's,^doc_DATA.*,doc_DATA = .linesrc lines.cfg,' \
+ ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e 's,^doc_DATA.*,doc_DATA=,' \
+ ${WRKSRC}/docs/manual/Makefile.am
+.endif
.include <bsd.port.mk>
diff --git a/misc/lifelines/distinfo b/misc/lifelines/distinfo
index 7ae27d35fddc..e4ae83d146bb 100644
--- a/misc/lifelines/distinfo
+++ b/misc/lifelines/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lifelines-3.0.62.tar.bz2) = 1c279958748e0f80b399bd8ea29f4030aa6db93059785d68abccf98b59c41e05
-SIZE (lifelines-3.0.62.tar.bz2) = 2289866
+SHA256 (lifelines-3.1.1.tar.gz) = 083007f81e406fce15931e5a29a7ba0380ef0b3b9c61d5eb5228ad378c7f332d
+SIZE (lifelines-3.1.1.tar.gz) = 3559382
diff --git a/misc/lifelines/files/patch-intl__Makefile.in b/misc/lifelines/files/patch-intl__Makefile.in
index 81b39df5fe0a..6790415d8117 100644
--- a/misc/lifelines/files/patch-intl__Makefile.in
+++ b/misc/lifelines/files/patch-intl__Makefile.in
@@ -1,6 +1,6 @@
---- intl/Makefile.in.orig Fri Oct 14 00:36:21 2005
-+++ intl/Makefile.in Fri Oct 14 00:38:03 2005
-@@ -152,35 +152,6 @@
+--- intl/Makefile.in.orig 2015-12-22 22:00:40 UTC
++++ intl/Makefile.in
+@@ -152,35 +152,6 @@ install-exec: all
else \
: ; \
fi
diff --git a/misc/lifelines/files/patch-src_stdlib_icvt.c b/misc/lifelines/files/patch-src_stdlib_icvt.c
deleted file mode 100644
index 82cc5e19c103..000000000000
--- a/misc/lifelines/files/patch-src_stdlib_icvt.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/stdlib/icvt.c.orig 2006-04-08 02:50:46 UTC
-+++ src/stdlib/icvt.c
-@@ -84,7 +84,7 @@ iconv_trans (CNSTRING src, CNSTRING dest
- /* assume MS-Windows makenarrow call */
- inlen = 2 * wcslen((const wchar_t *)sin);
- }
-- if (!strncmp(src, "UCS-2", strlen("UCS-2"))) {
-+ if (!strncmp(src, "UCS-4", strlen("UCS-4"))) {
- /* assume UNIX makenarrow call */
- inlen = 4 * wcslen((const wchar_t *)sin);
- }
diff --git a/misc/lifelines/pkg-descr b/misc/lifelines/pkg-descr
index 63687b1a1431..28bcdd37c1f8 100644
--- a/misc/lifelines/pkg-descr
+++ b/misc/lifelines/pkg-descr
@@ -11,4 +11,4 @@ programs that are written in a report programming language.
Because of its flexibility and programmability, LifeLines is frequently
used for genealogy applications on the World Wide Web.
-WWW: http://lifelines.sourceforge.net/
+WWW: http://marcno.github.io/lifelines/
diff --git a/misc/lifelines/pkg-plist b/misc/lifelines/pkg-plist
index a4cb97938c72..fb76a1c8ec2b 100644
--- a/misc/lifelines/pkg-plist
+++ b/misc/lifelines/pkg-plist
@@ -7,36 +7,30 @@ man/man1/dbverify.1.gz
man/man1/llexec.1.gz
man/man1/llines.1.gz
%%PORTDOCS%%%%DOCSDIR%%/.linesrc
-%%PORTDOCS%%%%DOCSDIR%%/ABOUT-NLS
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README.AUTOCONF
-%%PORTDOCS%%%%DOCSDIR%%/README.DEVELOPERS
-%%PORTDOCS%%%%DOCSDIR%%/README.INTERNATIONAL
-%%PORTDOCS%%%%DOCSDIR%%/README.LAYOUT
-%%PORTDOCS%%%%DOCSDIR%%/README.MAINTAINERS
-%%PORTDOCS%%%%DOCSDIR%%/README.MAINTAINERS.rpm
-%%PORTDOCS%%%%DOCSDIR%%/README.MAINTAINERS.win32
%%PORTDOCS%%%%DOCSDIR%%/lines.cfg
-%%PORTDOCS%%%%DOCSDIR%%/lines.cfg.input
+%%PORTDOCS%%%%DOCSDIR%%/lines.cfg.m4
+%%PORTDOCS%%%%DOCSDIR%%/listops.jpg
%%PORTDOCS%%%%DOCSDIR%%/ll-devguide.html
-%%PORTDOCS%%%%DOCSDIR%%/ll-devguide.xml
+%%PORTDOCS%%%%DOCSDIR%%/ll-devguide.pdf
+%%PORTDOCS%%%%DOCSDIR%%/ll-devguide.txt
%%PORTDOCS%%%%DOCSDIR%%/ll-index.html
%%PORTDOCS%%%%DOCSDIR%%/ll-index.sv.html
%%PORTDOCS%%%%DOCSDIR%%/ll-reportmanual.html
%%PORTDOCS%%%%DOCSDIR%%/ll-reportmanual.pdf
%%PORTDOCS%%%%DOCSDIR%%/ll-reportmanual.sv.html
+%%PORTDOCS%%%%DOCSDIR%%/ll-reportmanual.sv.pdf
%%PORTDOCS%%%%DOCSDIR%%/ll-reportmanual.txt
-%%PORTDOCS%%%%DOCSDIR%%/ll-reportmanual.xml
%%PORTDOCS%%%%DOCSDIR%%/ll-userguide.html
%%PORTDOCS%%%%DOCSDIR%%/ll-userguide.pdf
%%PORTDOCS%%%%DOCSDIR%%/ll-userguide.sv.html
+%%PORTDOCS%%%%DOCSDIR%%/ll-userguide.sv.pdf
%%PORTDOCS%%%%DOCSDIR%%/ll-userguide.txt
-%%PORTDOCS%%%%DOCSDIR%%/ll-userguide.xml
%%DATADIR%%/2ppage.ll
%%DATADIR%%/4gen1.ll
%%DATADIR%%/6gen1.ll
@@ -46,6 +40,7 @@ man/man1/llines.1.gz
%%DATADIR%%/README
%%DATADIR%%/addsour.ll
%%DATADIR%%/af-import.ll
+%%DATADIR%%/afg.ll
%%DATADIR%%/afn_match.ll
%%DATADIR%%/ahnenliste.ll
%%DATADIR%%/ahnentafel.ll
@@ -89,19 +84,14 @@ man/man1/llines.1.gz
%%DATADIR%%/descged.ll
%%DATADIR%%/divorce.li
%%DATADIR%%/drep2.ll
-%%DATADIR%%/drsetup.tex
-%%DATADIR%%/drtree.tex
%%DATADIR%%/dump-ances.ll
%%DATADIR%%/dump_html.ll
%%DATADIR%%/dump_html_sd.ll
%%DATADIR%%/eol.ll
%%DATADIR%%/est_life_span.ll
-%%DATADIR%%/ex1.tex
%%DATADIR%%/extract_gedcom.ll
%%DATADIR%%/extract_html.ll
%%DATADIR%%/extract_set.li
-%%DATADIR%%/extree1.tex
-%%DATADIR%%/extree2.tex
%%DATADIR%%/fam10c.ll
%%DATADIR%%/fam16rn1.ll
%%DATADIR%%/fam_ged.ll
@@ -154,17 +144,6 @@ man/man1/llines.1.gz
%%DATADIR%%/ldsgedcom.li
%%DATADIR%%/line.ll
%%DATADIR%%/listsour.ll
-%%DATADIR%%/ll-devguide.html
-%%DATADIR%%/ll-index.html
-%%DATADIR%%/ll-index.sv.html
-%%DATADIR%%/ll-reportmanual.html
-%%DATADIR%%/ll-reportmanual.pdf
-%%DATADIR%%/ll-reportmanual.sv.html
-%%DATADIR%%/ll-reportmanual.txt
-%%DATADIR%%/ll-userguide.html
-%%DATADIR%%/ll-userguide.pdf
-%%DATADIR%%/ll-userguide.sv.html
-%%DATADIR%%/ll-userguide.txt
%%DATADIR%%/ll.png
%%DATADIR%%/ll2html.ll
%%DATADIR%%/ll2visio.ll
@@ -174,16 +153,12 @@ man/man1/llines.1.gz
%%DATADIR%%/marriages.ll
%%DATADIR%%/marriages1.ll
%%DATADIR%%/menu.ll
-%%DATADIR%%/mysetup.tex
%%DATADIR%%/name2html.ll
%%DATADIR%%/namefreq.ll
%%DATADIR%%/names_freq.ll
%%DATADIR%%/namesformat1.ll
%%DATADIR%%/net-ped.ll
%%DATADIR%%/nonpatronymics.ll
-%%DATADIR%%/novel.README
-%%DATADIR%%/novel.intro
-%%DATADIR%%/novel.ll
%%DATADIR%%/outsources.li
%%DATADIR%%/paf-export.ll
%%DATADIR%%/paf-import.ll
@@ -195,24 +170,13 @@ man/man1/llines.1.gz
%%DATADIR%%/pedigree_html.ll
%%DATADIR%%/pedigreel.ll
%%DATADIR%%/pedigreelhs.ll
-%%DATADIR%%/pedtex.ll
-%%DATADIR%%/pedtex.readme
%%DATADIR%%/places.ll
%%DATADIR%%/pointers.ll
-%%DATADIR%%/poster.doc
-%%DATADIR%%/poster.tex
-%%DATADIR%%/poster1.tex
-%%DATADIR%%/poster2.tex
%%DATADIR%%/prompt.li
%%DATADIR%%/ps-anc.ll
%%DATADIR%%/ps-circle.ll
-%%DATADIR%%/ps-fan.ll
-%%DATADIR%%/ps-fan.ps
%%DATADIR%%/ps-pedigree.ll
%%DATADIR%%/ps-pedigree.ps
-%%DATADIR%%/pstricks.con
-%%DATADIR%%/pstricks.pro
-%%DATADIR%%/pstricks.tex
%%DATADIR%%/refn.ll
%%DATADIR%%/reg_html.ll
%%DATADIR%%/register-rtf.ll
@@ -232,7 +196,6 @@ man/man1/llines.1.gz
%%DATADIR%%/sealing_line.ll
%%DATADIR%%/search_source.ll
%%DATADIR%%/select.ll
-%%DATADIR%%/setup.tex
%%DATADIR%%/sgsgen.ll
%%DATADIR%%/shorten.li
%%DATADIR%%/showlines1.ll
@@ -249,7 +212,6 @@ man/man1/llines.1.gz
%%DATADIR%%/ssdi-import.ll
%%DATADIR%%/ssdi-search-list.ll
%%DATADIR%%/ssdi_aid.ll
-%%DATADIR%%/st_all.ll
%%DATADIR%%/stats.ll
%%DATADIR%%/surname1.ll
%%DATADIR%%/tinytafel1.ll
@@ -263,6 +225,62 @@ man/man1/llines.1.gz
%%DATADIR%%/xml-dtd.ll
%%DATADIR%%/xmlize.ll
%%DATADIR%%/zombies.ll
+%%DATADIR%%/desc-tex2/README
+%%DATADIR%%/desc-tex2/desc-tex.ll
+%%DATADIR%%/desc-tex2/desc-tex2.ll
+%%DATADIR%%/desc-tex2/drsetup.tex
+%%DATADIR%%/desc-tex2/drtree.tex
+%%DATADIR%%/desc-tex2/ex1.tex
+%%DATADIR%%/desc-tex2/extree1.tex
+%%DATADIR%%/desc-tex2/extree2.tex
+%%DATADIR%%/desc-tex2/mysetup.tex
+%%DATADIR%%/desc-tex2/poster.doc
+%%DATADIR%%/desc-tex2/poster.tex
+%%DATADIR%%/desc-tex2/poster1.tex
+%%DATADIR%%/desc-tex2/poster2.tex
+%%DATADIR%%/desc-tex2/pstricks.con
+%%DATADIR%%/desc-tex2/pstricks.pro
+%%DATADIR%%/desc-tex2/pstricks.tex
+%%DATADIR%%/desc-tex2/setup.tex
+%%DATADIR%%/desc-tex2/tree.tex
+%%DATADIR%%/novel/novel.README
+%%DATADIR%%/novel/novel.intro
+%%DATADIR%%/novel/novel.ll
+%%DATADIR%%/pedtex/pedtex.ll
+%%DATADIR%%/pedtex/pedtex.readme
+%%DATADIR%%/pedtex/setup.tex
+%%DATADIR%%/pedtex/tree.tex
+%%DATADIR%%/ps-fan/ps-fan.ll
+%%DATADIR%%/ps-fan/ps-fan.ps
+%%DATADIR%%/st/st_all.ll
+%%DATADIR%%/st/st_all.ref
+%%DATADIR%%/st/st_all_stdout.ref
+%%DATADIR%%/st/st_aux.li
+%%DATADIR%%/st/st_collate.li
+%%DATADIR%%/st/st_collate_8859-1.li
+%%DATADIR%%/st/st_collate_UTF-8.li
+%%DATADIR%%/st/st_convert.li
+%%DATADIR%%/st/st_date.li
+%%DATADIR%%/st/st_db.li
+%%DATADIR%%/st/st_list.li
+%%DATADIR%%/st/st_name.li
+%%DATADIR%%/st/st_number.li
+%%DATADIR%%/st/st_string.li
+%%DATADIR%%/st/st_string_UTF-8.li
+%%DATADIR%%/st/st_table.li
+%%DATADIR%%/st/test_fam_it.ll
+%%DATADIR%%/st/test_fam_it.ref
+%%DATADIR%%/st/test_forfam.ll
+%%DATADIR%%/st/test_forfam.ref
+%%DATADIR%%/st/test_forindi.ll
+%%DATADIR%%/st/test_forindi.ref
+%%DATADIR%%/st/test_indi_it.ll
+%%DATADIR%%/st/test_indi_it.ref
+%%DATADIR%%/st/test_othr_it.ll
+%%DATADIR%%/st/test_othr_it.ref
+%%DATADIR%%/st/ti.ged
+%%DATADIR%%/st/trigtest.ll
+%%DATADIR%%/st/trigtest.ref
%%NLS%%share/locale/da/LC_MESSAGES/lifelines.mo
%%NLS%%share/locale/de/LC_MESSAGES/lifelines.mo
%%NLS%%share/locale/el/LC_MESSAGES/lifelines.mo