aboutsummaryrefslogtreecommitdiff
path: root/misc/logsurfer
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2014-03-07 08:30:32 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2014-03-07 08:30:32 +0000
commitd8f70ad258b802e71ed371264d8f7a09e0365431 (patch)
tree8a995dfefeb767a43ee5e5c20f73892e374751b3 /misc/logsurfer
parent427ccff18a9563be362ce6f6942bad8c7e096786 (diff)
downloadports-d8f70ad258b802e71ed371264d8f7a09e0365431.tar.gz
ports-d8f70ad258b802e71ed371264d8f7a09e0365431.zip
- Update to 1.8
- Rename port - Convert to staging - Add rc script PR: ports/186266 Submitted by: me Aproved by: zi@ (maintainer)
Notes
Notes: svn path=/head/; revision=347342
Diffstat (limited to 'misc/logsurfer')
-rw-r--r--misc/logsurfer/Makefile30
-rw-r--r--misc/logsurfer/distinfo2
-rw-r--r--misc/logsurfer/files/logsurfer.in45
-rw-r--r--misc/logsurfer/pkg-descr14
-rw-r--r--misc/logsurfer/pkg-plist6
5 files changed, 97 insertions, 0 deletions
diff --git a/misc/logsurfer/Makefile b/misc/logsurfer/Makefile
new file mode 100644
index 000000000000..9040c36c2ab3
--- /dev/null
+++ b/misc/logsurfer/Makefile
@@ -0,0 +1,30 @@
+# Created by: shanee@augusta.de
+# $FreeBSD$
+
+PORTNAME= logsurfer
+PORTVERSION= 1.8
+CATEGORIES= misc
+MASTER_SITES= http://www.crypt.gen.nz/logsurfer/ \
+ http://mirrors.rit.edu/zi/
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= Process logfiles and conditionally perform certain actions
+
+LICENSE= BSD
+
+GNU_CONFIGURE= YES
+CONFIGURE_ARGS+=--with-etcdir=${ETCDIR}
+USES= desthack
+USE_RC_SUBR= logsurfer
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for doc in ChangeLog README
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/logsurfer/distinfo b/misc/logsurfer/distinfo
new file mode 100644
index 000000000000..9453cb7cb215
--- /dev/null
+++ b/misc/logsurfer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (logsurfer-1.8.tar.gz) = 74a36e8530a884031b4ae2344a46b9aaa07a1ee36d143802f6b64f817c5bd1af
+SIZE (logsurfer-1.8.tar.gz) = 197507
diff --git a/misc/logsurfer/files/logsurfer.in b/misc/logsurfer/files/logsurfer.in
new file mode 100644
index 000000000000..08e19493d81c
--- /dev/null
+++ b/misc/logsurfer/files/logsurfer.in
@@ -0,0 +1,45 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: logsurfer
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf to enable logsurfer:
+#
+# logsurfer_enable (bool): Set it to "YES" to enable logsurfer
+# Default to "NO"
+#
+# logsurfer_config (string): Configuration file,
+# Default /usr/local/etc/logsurfer/logsurfer.conf
+#
+# logsurfer_user, logsurfer_group (string): User logsurfer will run as
+# Default logsurfer
+#
+# logsurfer_logfile (string): Log file logsurfer will monitor
+# Default /var/log/messages
+#
+# logsurfer_pid (string): Location of pid file
+# Default /var/run/logsurfer.pid
+#
+
+. /etc/rc.subr
+
+name=logsurfer
+rcvar=logsurfer_enable
+
+load_rc_config ${name}
+
+: ${logsurfer_enable:=NO}
+: ${logsurfer_config:=%%ETCDIR%%/logsurfer.conf}
+: ${logsurfer_user:=logsurfer}
+: ${logsurfer_group:=logsurfer}
+: ${logsurfer_logfile:=/var/log/messages}
+
+pidfile=${logsurfer_pidfile:="/var/run/logsurfer.pid"}
+command=%%PREFIX%%/bin/logsurfer
+command_args="-D -p ${pidfile} -c ${logsurfer_config} -F -s -e ${logsurfer_logfile}"
+required_files=${logsurfer_config} ${logsurfer_logfile}
+
+run_rc_command "$1"
diff --git a/misc/logsurfer/pkg-descr b/misc/logsurfer/pkg-descr
new file mode 100644
index 000000000000..41a4ff0a4c6a
--- /dev/null
+++ b/misc/logsurfer/pkg-descr
@@ -0,0 +1,14 @@
+Logsurfer is a program for monitoring system logs in real-time,
+and reporting on the occurrence of events. It is similar to the
+well-known swatch program on which it is based, but offers a
+number of advanced features which swatch does not support.
+
+Logsurfer is capable of grouping related log entries
+together - for instance, when a system boots it usually creates
+a high number of log messages. In this case, logsurfer can be
+setup to group boot-time messages together and forward them in
+a single Email message to the system administrator under the
+subject line "Host xxx has just booted".
+Swatch just couldn't do this properly.
+
+WWW: http://www.crypt.gen.nz/logsurfer/
diff --git a/misc/logsurfer/pkg-plist b/misc/logsurfer/pkg-plist
new file mode 100644
index 000000000000..c65a4317086a
--- /dev/null
+++ b/misc/logsurfer/pkg-plist
@@ -0,0 +1,6 @@
+bin/logsurfer
+man/man1/logsurfer.1.gz
+man/man4/logsurfer.conf.4.gz
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%