aboutsummaryrefslogtreecommitdiff
path: root/misc/lxi-tools
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-01-09 19:10:45 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-01-09 19:10:45 +0000
commit2e83fc02b9fc548c0865230ad4fe13e070909124 (patch)
treeacefedc351d9899a7514f052b400050ba73f2df3 /misc/lxi-tools
parentb89c1e03a1bd956cfd9f612c1a7e126d533c05e8 (diff)
downloadports-2e83fc02b9fc548c0865230ad4fe13e070909124.tar.gz
ports-2e83fc02b9fc548c0865230ad4fe13e070909124.zip
New port: misc/lxi-tools
lxi-tools is a collection of open source software tools that enables control of LXI compatible instruments such as modern oscilloscopes, power supplies, spectrum analyzers etc. All features are consolidated in the 'lxi' application which provides a simple commandline interface to discover LXI instruments, send SCPI commands, and capture screenshots from supported LXI instruments. lxi-tools rely on liblxi for all communication. WWW: https://lxi-tools.github.io/ PR: 224714, D13686 Submitted by: Dmitri Goutnik <dg@syrec.org>
Notes
Notes: svn path=/head/; revision=458560
Diffstat (limited to 'misc/lxi-tools')
-rw-r--r--misc/lxi-tools/Makefile37
-rw-r--r--misc/lxi-tools/distinfo3
-rw-r--r--misc/lxi-tools/pkg-descr11
3 files changed, 51 insertions, 0 deletions
diff --git a/misc/lxi-tools/Makefile b/misc/lxi-tools/Makefile
new file mode 100644
index 000000000000..05dde0a91aa1
--- /dev/null
+++ b/misc/lxi-tools/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= lxi-tools
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.16
+CATEGORIES= misc
+
+MAINTAINER= dg@syrec.org
+COMMENT= Collection of tools that enables control of LXI compatible instruments
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= liblxi.so:misc/liblxi
+
+USES= autoreconf localbase readline
+USE_GITHUB= yes
+GH_ACCOUNT= lxi-tools
+
+GNU_CONFIGURE= yes
+CFLAGS+= -D_WITH_GETLINE # enable getline(3) prototype
+
+PORTDOCS= README
+
+PLIST_FILES= bin/lxi \
+ man/man1/lxi.1.gz
+
+OPTIONS_DEFINE= BASH DOCS
+
+BASH_CONFIGURE_WITH= bash-completion-dir=${PREFIX}/etc/bash_completion.d
+BASH_PLIST_FILES= ${PREFIX}/etc/bash_completion.d/lxi
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/misc/lxi-tools/distinfo b/misc/lxi-tools/distinfo
new file mode 100644
index 000000000000..0b631dcf04f9
--- /dev/null
+++ b/misc/lxi-tools/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1514577395
+SHA256 (lxi-tools-lxi-tools-v1.16_GH0.tar.gz) = bd75d92421e9cb0962a019ec26f154da84711949e5ea9cbd96c7de6467f89869
+SIZE (lxi-tools-lxi-tools-v1.16_GH0.tar.gz) = 20459
diff --git a/misc/lxi-tools/pkg-descr b/misc/lxi-tools/pkg-descr
new file mode 100644
index 000000000000..18c0ad9c09b8
--- /dev/null
+++ b/misc/lxi-tools/pkg-descr
@@ -0,0 +1,11 @@
+lxi-tools is a collection of open source software tools that enables control
+of LXI compatible instruments such as modern oscilloscopes, power supplies,
+spectrum analyzers etc.
+
+All features are consolidated in the 'lxi' application which provides a
+simple commandline interface to discover LXI instruments, send SCPI
+commands, and capture screenshots from supported LXI instruments.
+
+lxi-tools rely on liblxi for all communication.
+
+WWW: https://lxi-tools.github.io/