aboutsummaryrefslogtreecommitdiff
path: root/misc/mbuffer/Makefile
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-03-14 13:42:25 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-03-14 13:42:25 +0000
commit9405221dafdb31d72cf6245b620da670af86065b (patch)
tree2d3b98783f08a1c607a14a541a117af14f2f450d /misc/mbuffer/Makefile
parent4b8fcfc036bb45a02fa72f7b46aa5c281d43d3fd (diff)
downloadports-9405221dafdb31d72cf6245b620da670af86065b.tar.gz
ports-9405221dafdb31d72cf6245b620da670af86065b.zip
Notes
Diffstat (limited to 'misc/mbuffer/Makefile')
-rw-r--r--misc/mbuffer/Makefile40
1 files changed, 16 insertions, 24 deletions
diff --git a/misc/mbuffer/Makefile b/misc/mbuffer/Makefile
index a6cc7e2f8211..271ac8c730c3 100644
--- a/misc/mbuffer/Makefile
+++ b/misc/mbuffer/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mbuffer
-PORTVERSION= 2016.06.13
+PORTVERSION= 2017.10.11
CATEGORIES= misc
MASTER_SITES= http://www.maier-komor.de/software/mbuffer/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
@@ -13,37 +13,29 @@ COMMENT= Tool for buffering data streams
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= gmake tar:tgz
+USES= gmake localbase ssl tar:tgz
GNU_CONFIGURE= yes
-MAKE_ARGS= SHELL=${SH}
-
-PLIST_FILES= bin/mbuffer man/man1/mbuffer.1.gz
+# Prevent sendfile() from being detected by configure and rejected
+# by mbuffer.c due to being "unable to send from buffers".
+CONFIGURE_ARGS= ac_cv_search_sendfile=no
+MAKE_ARGS= SHELL=/bin/sh
OPTIONS_DEFINE= MHASH
-MHASH_DESC= Use mhash for hash generation
-
OPTIONS_DEFAULT= MHASH
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMHASH}
-LIB_DEPENDS+= libmhash.so:security/mhash
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-.else
-CONFIGURE_ARGS+=ac_cv_search_mhash_init=no
-USES+= ssl
-.endif
-
-# Prevent sendfile() from being detected by configure and rejected
-# by mbuffer.c due to being "unable to send from buffers".
-CONFIGURE_ARGS+=ac_cv_search_sendfile=no
+MHASH_DESC= Use mhash for hash generation
-.include <bsd.port.pre.mk>
+MHASH_LIB_DEPENDS= libmhash.so:security/mhash
+MHASH_CONFIGURE_OFF= ac_cv_search_mhash_init=no
post-configure:
# Rename variables to make sure they aren't redefined through mhash.h
@${REINPLACE_CMD} -E -e 's@(PACKAGE|VERSION)@MBUFFER_\1@' \
- ${WRKSRC}/config.h ${WRKSRC}/mbuffer.c
+ ${WRKSRC}/config.h ${WRKSRC}/settings.c
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/mbuffer
+ ${MV} ${STAGEDIR}${PREFIX}/etc/mbuffer.rc \
+ ${STAGEDIR}${PREFIX}/etc/mbuffer.rc.sample
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>