aboutsummaryrefslogtreecommitdiff
path: root/misc/metalink-tools
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2008-08-10 10:13:37 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2008-08-10 10:13:37 +0000
commit755cb7803ca442e06f47c516f49e27cfc28a4852 (patch)
tree0bf67f08290c6d2f6f90cae53ee248be6e4ca023 /misc/metalink-tools
parent2d1bef7d82025a36fcbd4bf0dbb274f41ebb277e (diff)
downloadports-755cb7803ca442e06f47c516f49e27cfc28a4852.tar.gz
ports-755cb7803ca442e06f47c516f49e27cfc28a4852.zip
New port metalink-tools version 0.3.3: Metalink generation tool
Notes
Notes: svn path=/head/; revision=218325
Diffstat (limited to 'misc/metalink-tools')
-rw-r--r--misc/metalink-tools/Makefile48
-rw-r--r--misc/metalink-tools/distinfo3
-rw-r--r--misc/metalink-tools/files/patch-configure11
-rw-r--r--misc/metalink-tools/pkg-descr16
4 files changed, 78 insertions, 0 deletions
diff --git a/misc/metalink-tools/Makefile b/misc/metalink-tools/Makefile
new file mode 100644
index 000000000000..f91172f0185b
--- /dev/null
+++ b/misc/metalink-tools/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: Metalink tools
+# Date created: Sun 10 Aug 2008 04:22:51 UTC
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= metalink
+PORTVERSION= 0.3.3
+CATEGORIES= misc
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= metalinks
+PKGNAMESUFFIX?= -tools
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Metalink generation tool
+
+LIB_DEPENDS= gcrypt.15:${PORTSDIR}/security/libgcrypt \
+ boost_filesystem.4:${PORTSDIR}/devel/boost \
+ boost_program_options.4:${PORTSDIR}/devel/boost \
+ boost_regex.4:${PORTSDIR}/devel/boost
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= AWK="${AWK}" \
+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+
+# Documents to install
+DOC_FILES= \
+ README
+
+.ifndef(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+# docs
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/misc/metalink-tools/distinfo b/misc/metalink-tools/distinfo
new file mode 100644
index 000000000000..9270ec584d4d
--- /dev/null
+++ b/misc/metalink-tools/distinfo
@@ -0,0 +1,3 @@
+MD5 (metalink-0.3.3.tar.gz) = f1a92f1707a10195fefb00caaf3ace18
+SHA256 (metalink-0.3.3.tar.gz) = db9d2431268e848da763ecaa4e64278531f25ab6ee326702a14e21f2e1c8facb
+SIZE (metalink-0.3.3.tar.gz) = 1377914
diff --git a/misc/metalink-tools/files/patch-configure b/misc/metalink-tools/files/patch-configure
new file mode 100644
index 000000000000..3e257fc4d600
--- /dev/null
+++ b/misc/metalink-tools/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2008-08-10 05:57:49.000000000 -0300
++++ configure 2008-08-10 05:57:55.000000000 -0300
+@@ -1905,7 +1905,7 @@
+ do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+- for ac_prog in mkdir gmkdir; do
++ for ac_prog in mkdir; do
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ { test -f "$as_dir/$ac_prog$ac_exec_ext" && $as_test_x "$as_dir/$ac_prog$ac_exec_ext"; } || continue
+ case `"$as_dir/$ac_prog$ac_exec_ext" --version 2>&1` in #(
diff --git a/misc/metalink-tools/pkg-descr b/misc/metalink-tools/pkg-descr
new file mode 100644
index 000000000000..8d06f7243fb7
--- /dev/null
+++ b/misc/metalink-tools/pkg-descr
@@ -0,0 +1,16 @@
+[ excerpt from developer's web site ]
+
+Metalink is the main Metalink generation tool. It combines a list
+of mirrors (from stdin) and a number of files into one Metalink
+record (stdout). It can also be used to transform a MD5SUMS file
+into a metalink.
+
+Features currently include:
+
+- Hashing algorithms: md4 md5 sha1 sha256 sha384 sha512 rmd160 tiger
+ crc32 ed2k gnunet
+- Generation of Metalink files from MD5SUMS lists
+
+WWW: http://www.metalinker.org/
+
+-- lioux@FreeBSD.org