aboutsummaryrefslogtreecommitdiff
path: root/misc/mmv
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-10-04 10:02:08 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-10-04 10:02:08 +0000
commitbe2b7e1e947f9bca3fe529064d4e84443213ba3b (patch)
treef28dc5d0297db737149c0885d2aabbfa96acba41 /misc/mmv
parentd4ee02d332e8a64b27b98198c6c1f776f952f994 (diff)
downloadports-be2b7e1e947f9bca3fe529064d4e84443213ba3b.tar.gz
ports-be2b7e1e947f9bca3fe529064d4e84443213ba3b.zip
- Update to 1.01b.14
- Pass maintainership to submitter PR: ports/102869 Submitted by: Simon Olofsson <simon at olofsson.de> Approved by: Martin Tournoij <carpetsmoker at gmail.com>
Notes
Notes: svn path=/head/; revision=174443
Diffstat (limited to 'misc/mmv')
-rw-r--r--misc/mmv/Makefile42
-rw-r--r--misc/mmv/distinfo9
-rw-r--r--misc/mmv/files/patch-aa125
-rw-r--r--misc/mmv/pkg-descr17
4 files changed, 29 insertions, 164 deletions
diff --git a/misc/mmv/Makefile b/misc/mmv/Makefile
index e8ef68af2a8a..69d89c85fdbc 100644
--- a/misc/mmv/Makefile
+++ b/misc/mmv/Makefile
@@ -6,37 +6,29 @@
#
PORTNAME= mmv
-PORTVERSION= 1.01b
+PORTVERSION= 1.01b.14
CATEGORIES= misc
-MASTER_SITES= http://www.xs4all.nl/~tournoij/distfiles/ \
- ftp://ftp.unicamp.br/pub/unix-c/file-mgmt/ \
- http://carpetsmoker.xs4all.nl/distfiles/
-DISTNAME= mmv
-EXTRACT_SUFX= .tar.Z
+MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
+DISTNAME= ${PORTNAME}_1.01b.orig
-MAINTAINER= carpetsmoker@gmail.com
-COMMENT= Move/copy/append/link multiple files with sophisticated wildcard matching
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= ${PORTNAME}_1.01b-14.diff.gz
+PATCH_DIST_STRIP= -p1
-RESTRICTED= No modification or redistribution for charge
-CFLAGS+= -DDIRENT
-MAKE_FLAGS= -e
+MAINTAINER= simon@olofsson.de
+COMMENT= Move/Copy/Append/Link multiple files
+
+CFLAGS+= -DHAS_DIRENT
MAN1= mmv.1
-PLIST_FILES= bin/mad \
- bin/mcp \
- bin/mln \
- bin/mmv
+PLIST_FILES= bin/mmv
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.01b.orig
-post-extract:
- (cd ${WRKSRC} ; \
- ${CAT} mmv.c.? >mmv.c ; \
- ${PATCH} mmv.c < mmv.patch1 ; )
+do-build:
+ @(cd ${WRKSRC} ; \
+ ${CC} ${CFLAGS} -o ${PORTNAME} ${PORTNAME}.c ; )
do-install:
- (cd ${PREFIX}/bin ; ${RM} -f mmv mad mcp mln ; \
- ${INSTALL_PROGRAM} ${WRKSRC}/mmv ${PREFIX}/bin ; \
- ${LN} -fs ${PREFIX}/bin/mmv ${PREFIX}/bin/mad ; \
- ${LN} -fs ${PREFIX}/bin/mmv ${PREFIX}/bin/mcp ; \
- ${LN} -fs ${PREFIX}/bin/mmv ${PREFIX}/bin/mln ; \
- ${INSTALL_MAN} ${WRKSRC}/mmv.1 ${PREFIX}/man/man1 ; )
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ @${INSTALL_MAN} ${WRKSRC}/mmv.1 ${PREFIX}/man/man1/mmv.1
.include <bsd.port.mk>
diff --git a/misc/mmv/distinfo b/misc/mmv/distinfo
index fcfc145cbf5d..434c4951df27 100644
--- a/misc/mmv/distinfo
+++ b/misc/mmv/distinfo
@@ -1,3 +1,6 @@
-MD5 (mmv.tar.Z) = bc6dd229efc513140ec4d1caa364cab1
-SHA256 (mmv.tar.Z) = c933f27d4826435d20468abc1aa0d2c8bd6860863daaf61f020643d75934cffd
-SIZE (mmv.tar.Z) = 44773
+MD5 (mmv_1.01b.orig.tar.gz) = 1b2135ab2f17bdfa9e08debbb3c46ad8
+SHA256 (mmv_1.01b.orig.tar.gz) = 0399c027ea1e51fd607266c1e33573866d4db89f64a74be8b4a1d2d1ff1fdeef
+SIZE (mmv_1.01b.orig.tar.gz) = 25656
+MD5 (mmv_1.01b-14.diff.gz) = a69eff7501e63c0bd1fcd231bf6949f1
+SHA256 (mmv_1.01b-14.diff.gz) = 4f0d5dbd101b925dfcfd34eb7e5d0f3ea1b508d215f449b0afff8676aa985757
+SIZE (mmv_1.01b-14.diff.gz) = 6702
diff --git a/misc/mmv/files/patch-aa b/misc/mmv/files/patch-aa
deleted file mode 100644
index e521e9c107bb..000000000000
--- a/misc/mmv/files/patch-aa
+++ /dev/null
@@ -1,125 +0,0 @@
-*** mmv.c.old Wed Mar 1 05:23:56 1995
---- mmv.c Thu Jun 13 13:34:25 2002
-***************
-*** 88,94 ****
- #endif
-
- #include <stdio.h>
-- #include <ctype.h>
-
- #ifdef MSDOS
- /* for MS-DOS (under Turbo C 1.5)*/
---- 88,93 ----
-***************
-*** 126,132 ****
- #include <sys/file.h>
-
- extern char *getenv();
-- extern long lseek();
- extern char *malloc();
-
- #ifdef DIRENT
---- 125,130 ----
-***************
-*** 176,182 ****
-
- #else
- /* for System V and BSD */
-- #include <string.h>
- #include <sys/signal.h>
- #include <fcntl.h>
- #endif
---- 174,179 ----
-***************
-*** 370,376 ****
- static int snap(/* REP *first, REP *p */);
- static void showdone(/* REP *fin */);
- static void breakout(/* */);
-! static int breakrep(/* */);
- static void breakstat(/* */);
- static void quit(/* */);
- static int copymove(/* REP *p */);
---- 367,373 ----
- static int snap(/* REP *first, REP *p */);
- static void showdone(/* REP *fin */);
- static void breakout(/* */);
-! static void breakrep(/* */);
- static void breakstat(/* */);
- static void quit(/* */);
- static int copymove(/* REP *p */);
-***************
-*** 389,395 ****
- static int getstat(/* char *full, FILEINFO *f */);
- static int dwritable(/* HANDLE *h */);
- static int fwritable(/* char *hname, FILEINFO *f */);
-- static void memmove(/* void *to, void *from, int k */);
- #endif
- #ifndef RENAME
- static int rename(/* char *from, char *to */);
---- 386,391 ----
-***************
-*** 410,416 ****
- static SLICER slicer[2] = {{NULL, NULL, 0}, {NULL, NULL, 0}};
-
- static int badreps = 0, paterr = 0, direrr, failed = 0, gotsig = 0, repbad;
-! static FILE *outfile = stdout;
-
- static char IDF[] = "$$mmvdid.";
- static char TEMP[] = "$$mmvtmp.";
---- 406,412 ----
- static SLICER slicer[2] = {{NULL, NULL, 0}, {NULL, NULL, 0}};
-
- static int badreps = 0, paterr = 0, direrr, failed = 0, gotsig = 0, repbad;
-! static FILE *outfile;
-
- static char IDF[] = "$$mmvdid.";
- static char TEMP[] = "$$mmvtmp.";
-***************
-*** 471,476 ****
---- 467,473 ----
- {
- char *frompat, *topat;
-
-+ outfile = stdout;
- init();
- procargs(argc, argv, &frompat, &topat);
- domatch(frompat, topat);
-***************
-*** 2550,2559 ****
- }
-
-
-! static int breakrep()
- {
- gotsig = 1;
-- return(1);
- }
-
-
---- 2547,2555 ----
- }
-
-
-! static void breakrep()
- {
- gotsig = 1;
- }
-
-
-***************
-*** 2832,2838 ****
- }
-
-
-! #ifndef MSDOS
- static void memmove(to, from, k)
- char *to, *from;
- unsigned k;
---- 2828,2834 ----
- }
-
-
-! #if 0
- static void memmove(to, from, k)
- char *to, *from;
- unsigned k;
diff --git a/misc/mmv/pkg-descr b/misc/mmv/pkg-descr
index 45c14e846abd..e553e04f90a4 100644
--- a/misc/mmv/pkg-descr
+++ b/misc/mmv/pkg-descr
@@ -1,12 +1,7 @@
-This is mmv, a program to move/copy/append/link multiple files
-according to a set of wildcard patterns. The wildcard matches
-can be reused in forming the target names. You can i.e. move
-all *.c.or? files to or?.new.*.c by saying 'mmv "*.c.or?" or=2.new.=1.c'
+mmv is a program to move/copy/append/link multiple files according to a set
+of wildcard patterns. This multiple action is performed safely, i.e. without
+any unexpected deletion of files due to collisions of target names with
+existing filenames or with other target names.
-The multiple action is performed safely, i.e. without any unexpected
-deletion of files due to collisions of target names with existing
-filenames or with other target names. Furthermore, before doing
-anything, mmv attempts to detect any errors that would result from the
-entire set of actions specified and gives the user the choice of
-either aborting before beginning, or proceeding by avoiding the
-offending parts.
+Author: Vladimir Lanin <vlad@brm.com>
+WWW: http://packages.debian.org/unstable/utils/mmv