aboutsummaryrefslogtreecommitdiff
path: root/misc/mnn
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-12-29 18:52:47 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-12-29 18:52:47 +0000
commit300df2ccd6a8a342792e6bfdc45e87beb1d48169 (patch)
tree70376a23ca8a3d761705261674c55d893b186c4d /misc/mnn
parentfbeb2a4fcd35bebf4b182ab2c26b4336eead0bcf (diff)
downloadports-300df2ccd6a8a342792e6bfdc45e87beb1d48169.tar.gz
ports-300df2ccd6a8a342792e6bfdc45e87beb1d48169.zip
New port: misc/mnn: Lightweight deep neural network inference engine
Notes
Notes: svn path=/head/; revision=521406
Diffstat (limited to 'misc/mnn')
-rw-r--r--misc/mnn/Makefile30
-rw-r--r--misc/mnn/distinfo3
-rw-r--r--misc/mnn/pkg-descr4
-rw-r--r--misc/mnn/pkg-plist17
4 files changed, 54 insertions, 0 deletions
diff --git a/misc/mnn/Makefile b/misc/mnn/Makefile
new file mode 100644
index 000000000000..f9020ec59c70
--- /dev/null
+++ b/misc/mnn/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= mnn
+DISTVERSION= 0.2.1.5
+CATEGORIES= misc # machine-learning
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Lightweight deep neural network inference engine
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= bash:shells/bash
+
+USES= cmake shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= alibaba
+GH_PROJECT= MNN
+SHEBANG_GLOB= *.sh
+USE_LDCONFIG= yes
+
+CXXFLAGS+= -pthread
+LDFLAGS+= -pthread
+
+do-test:
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DMNN_BUILD_TEST:BOOL=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ (cd ${BUILD_WRKSRC} && ./run_test.out)
+
+.include <bsd.port.mk>
diff --git a/misc/mnn/distinfo b/misc/mnn/distinfo
new file mode 100644
index 000000000000..99f561cf1a51
--- /dev/null
+++ b/misc/mnn/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1577642007
+SHA256 (alibaba-MNN-0.2.1.5_GH0.tar.gz) = bc8cb1356533d60b10c8dc14cb9b332ac16e95e41c215cc1dcff00d7731f7513
+SIZE (alibaba-MNN-0.2.1.5_GH0.tar.gz) = 6853015
diff --git a/misc/mnn/pkg-descr b/misc/mnn/pkg-descr
new file mode 100644
index 000000000000..8db3d6986e54
--- /dev/null
+++ b/misc/mnn/pkg-descr
@@ -0,0 +1,4 @@
+MNN is a lightweight deep neural network inference engine. It loads models and
+do inference on devices.
+
+WWW: https://github.com/alibaba/MNN
diff --git a/misc/mnn/pkg-plist b/misc/mnn/pkg-plist
new file mode 100644
index 000000000000..c91c03f82699
--- /dev/null
+++ b/misc/mnn/pkg-plist
@@ -0,0 +1,17 @@
+include/AutoTime.hpp
+include/ErrorCode.hpp
+include/Expr.hpp
+include/ExprCreator.hpp
+include/HalideRuntime.h
+include/ImageProcess.hpp
+include/Interpreter.hpp
+include/MNNDefine.h
+include/MNNForwardType.h
+include/MathOp.hpp
+include/Matrix.h
+include/NeuralNetWorkOp.hpp
+include/Optimizer.hpp
+include/Rect.h
+include/Tensor.hpp
+lib/libMNN.so
+lib/libMNN_Express.so