aboutsummaryrefslogtreecommitdiff
path: root/misc/molequeue
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-16 22:07:52 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-16 22:07:52 +0000
commitdbdfd6e45604f41d98b75072db58e1b34522e807 (patch)
tree79304853407001d7578fb7fa970da91db55bf9ce /misc/molequeue
parent10a86f5ddbc5f35706a526bac2fd1363010ce2d6 (diff)
downloadports-dbdfd6e45604f41d98b75072db58e1b34522e807.tar.gz
ports-dbdfd6e45604f41d98b75072db58e1b34522e807.zip
New port: misc/molequeue: Desktop integration of high performance computing resources
Notes
Notes: svn path=/head/; revision=482261
Diffstat (limited to 'misc/molequeue')
-rw-r--r--misc/molequeue/Makefile21
-rw-r--r--misc/molequeue/distinfo3
-rw-r--r--misc/molequeue/pkg-descr17
-rw-r--r--misc/molequeue/pkg-plist21
4 files changed, 62 insertions, 0 deletions
diff --git a/misc/molequeue/Makefile b/misc/molequeue/Makefile
new file mode 100644
index 000000000000..556c2f8fc2c4
--- /dev/null
+++ b/misc/molequeue/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= molequeue
+DISTVERSION= 0.9.0
+CATEGORIES= misc
+MASTER_SITES= https://github.com/openchemistry/molequeue/releases/download/${DISTVERSION}/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Desktop integration of high performance computing resources
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake:outsource compiler:c++11-lang qt:5
+USE_QT= core gui network widgets buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+post-install:
+ @${RM} -r ${STAGEDIR}${PREFIX}/share/doc
+
+.include <bsd.port.mk>
diff --git a/misc/molequeue/distinfo b/misc/molequeue/distinfo
new file mode 100644
index 000000000000..d384fa42ce15
--- /dev/null
+++ b/misc/molequeue/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539726091
+SHA256 (molequeue-0.9.0.tar.gz) = df036dbca090db4348443cf3d09be35fdf877a37075b4cb427b1130f005ef6e5
+SIZE (molequeue-0.9.0.tar.gz) = 620286
diff --git a/misc/molequeue/pkg-descr b/misc/molequeue/pkg-descr
new file mode 100644
index 000000000000..5a9b09b330b2
--- /dev/null
+++ b/misc/molequeue/pkg-descr
@@ -0,0 +1,17 @@
+MoleQueue is an open-source, cross-platform, system-tray resident desktop
+application for abstracting, managing, and coordinating the execution of tasks
+both locally and on remote computational resources. It is built and tested on
+Linux, Mac OS X, and Windows, with nightly binaries currently available for Mac
+OS X and Windows. Users can set up local and remote queues that describe where
+the task will be executed. Each queue can have programs, with templates to
+facilitate the execution of the program. Input files can be staged, and output
+files collected using a standard interface.
+
+The MoleQueue application is written in C++ using the Qt framework. It can
+execute programs directly on the local machine, and uses SSH to communicate with
+remote batch scheduling systems with support for Open Grid Scheduler (formerly
+Sun Grid Engine) and PBS. The backend communication is abstracted, and support
+is currently being added for UIT (a SOAP protocol for communicating with
+military HPC resources using ezHPC).
+
+WWW: https://www.openchemistry.org/projects/molequeue
diff --git a/misc/molequeue/pkg-plist b/misc/molequeue/pkg-plist
new file mode 100644
index 000000000000..732112fee66f
--- /dev/null
+++ b/misc/molequeue/pkg-plist
@@ -0,0 +1,21 @@
+bin/molequeue
+include/molequeue/client/client.h
+include/molequeue/client/jobobject.h
+include/molequeue/client/jsonrpcclient.h
+include/molequeue/client/molequeueclientexport.h
+include/molequeue/servercore/connection.h
+include/molequeue/servercore/connectionlistener.h
+include/molequeue/servercore/connectionlistenerfactory.h
+include/molequeue/servercore/jsonrpc.h
+include/molequeue/servercore/localsocketconnection.h
+include/molequeue/servercore/localsocketconnectionlistener.h
+include/molequeue/servercore/message.h
+include/molequeue/servercore/molequeueservercoreexport.h
+include/molequeue/servercore/servercoreglobal.h
+lib/cmake/molequeue/MoleQueueConfig.cmake
+lib/cmake/molequeue/MoleQueueConfigVersion.cmake
+lib/cmake/molequeue/MoleQueueTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/molequeue/MoleQueueTargets.cmake
+lib/libMoleQueueClient.so
+lib/libMoleQueueServerCore.so
+lib/molequeue/plugins/LocalSocketServer.so