aboutsummaryrefslogtreecommitdiff
path: root/misc/mtx
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-06-05 01:42:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-06-05 01:42:05 +0000
commitf6d7fd99c40ffef042340725fa29333be0aa7ac2 (patch)
tree18558f0ad93565fbf03df724c1b972e379efb847 /misc/mtx
parentcf22ecb48debf1d46a50034c77d1226e8be341bc (diff)
downloadports-f6d7fd99c40ffef042340725fa29333be0aa7ac2.tar.gz
ports-f6d7fd99c40ffef042340725fa29333be0aa7ac2.zip
- Stage support
PR: 190533 Submitted by: maintaine
Notes
Notes: svn path=/head/; revision=356567
Diffstat (limited to 'misc/mtx')
-rw-r--r--misc/mtx/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/misc/mtx/Makefile b/misc/mtx/Makefile
index fdc7eb2cc595..e0a8098d3abb 100644
--- a/misc/mtx/Makefile
+++ b/misc/mtx/Makefile
@@ -3,16 +3,25 @@
PORTNAME= mtx
PORTVERSION= 1.3.12
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-stable/${PORTVERSION}
MAINTAINER= 5u623l20@gmail.com
COMMENT= Control SCSI media changer devices
+LICENSE= GPLv2
+
USES= gmake
GNU_CONFIGURE= yes
-MAN1= loaderinfo.1 mtx.1 tapeinfo.1 scsitape.1 scsieject.1
-PLIST_FILES= sbin/mtx sbin/tapeinfo sbin/loaderinfo sbin/scsitape sbin/scsieject
+PLIST_FILES= sbin/mtx sbin/tapeinfo sbin/loaderinfo sbin/scsitape sbin/scsieject \
+ man/man1/loaderinfo.1.gz man/man1/mtx.1.gz man/man1/tapeinfo.1.gz \
+ man/man1/scsitape.1.gz man/man1/scsieject.1.gz
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|@prefix@|${STAGEDIR}${PREFIX}|g' \
+ ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e 's|@mandir@|${STAGEDIR}${PREFIX}/man|g' \
+ ${WRKSRC}/Makefile.in
-NO_STAGE= yes
.include <bsd.port.mk>