aboutsummaryrefslogtreecommitdiff
path: root/misc/najitool
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-19 14:50:15 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-19 14:50:15 +0000
commitb9133e7fcbca67f116dc2e86aa976bcae1dbea99 (patch)
treee9fc1bc0e7d585448e2966738639086ff7673055 /misc/najitool
parent3c638910d82bc2975f123983115d71a757333774 (diff)
downloadports-b9133e7fcbca67f116dc2e86aa976bcae1dbea99.tar.gz
ports-b9133e7fcbca67f116dc2e86aa976bcae1dbea99.zip
najitool generates and/or makes altered copies of files in the patterns you
specify or shows to the screen. najitool is being developed in the ANSI C standard so it should work and compile on any system that supports ANSI C, which should be every system. PR: ports/81204 Submitted by: <cokyazici@yahoo.co.uk>
Notes
Notes: svn path=/head/; revision=135616
Diffstat (limited to 'misc/najitool')
-rw-r--r--misc/najitool/Makefile31
-rw-r--r--misc/najitool/distinfo2
-rw-r--r--misc/najitool/pkg-descr9
-rw-r--r--misc/najitool/pkg-plist1
4 files changed, 43 insertions, 0 deletions
diff --git a/misc/najitool/Makefile b/misc/najitool/Makefile
new file mode 100644
index 000000000000..b4f26faa0112
--- /dev/null
+++ b/misc/najitool/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: najitool
+# Date created: 18 May 2005
+# Whom: NECDET COKYAZICI <cokyazici@yahoo.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= najitool
+PORTVERSION= 0.5.0
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= najitool
+
+MAINTAINER= cokyazici@yahoo.co.uk
+COMMENT= A tool that generates, converts, and filters files
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnaji.a:${PORTSDIR}/devel/libnaji
+
+USE_REINPLACE= yes
+
+MAKEFILE= makefile
+
+DISTVERSIONSUFFIX= .src
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|cflags =|cflags = -I${LOCALBASE}/include|; s|libnaji.a|${LOCALBASE}/lib/libnaji.a|' ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/najitool ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/misc/najitool/distinfo b/misc/najitool/distinfo
new file mode 100644
index 000000000000..faeb64821bbf
--- /dev/null
+++ b/misc/najitool/distinfo
@@ -0,0 +1,2 @@
+MD5 (najitool-0.5.0.src.tar.gz) = a12389cfee3104f142ed02f41fb60626
+SIZE (najitool-0.5.0.src.tar.gz) = 10092
diff --git a/misc/najitool/pkg-descr b/misc/najitool/pkg-descr
new file mode 100644
index 000000000000..58964f6ed3b5
--- /dev/null
+++ b/misc/najitool/pkg-descr
@@ -0,0 +1,9 @@
+najitool generates and/or makes altered copies of files in the patterns
+you specify or shows to the screen. najitool is being developed in the
+ANSI C standard so it should work and compile on any system that supports
+ANSI C, which should be every system.
+
+ WWW: http://najitool.sf.net/
+
+ - NECDET COKYAZICI
+ cokyazici@yahoo.co.uk
diff --git a/misc/najitool/pkg-plist b/misc/najitool/pkg-plist
new file mode 100644
index 000000000000..3f4df484b3fa
--- /dev/null
+++ b/misc/najitool/pkg-plist
@@ -0,0 +1 @@
+bin/najitool