aboutsummaryrefslogtreecommitdiff
path: root/misc/ompl
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-10-13 03:34:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-10-13 03:34:37 +0000
commita16ed29fc88a23d96dcf91e47b68668ffe3ec499 (patch)
tree954f81178f59bd05e0e6b98ae6fabb4d8fcd6302 /misc/ompl
parentdaf034f74158895d245803474cc0ce5cb027f92f (diff)
downloadports-a16ed29fc88a23d96dcf91e47b68668ffe3ec499.tar.gz
ports-a16ed29fc88a23d96dcf91e47b68668ffe3ec499.zip
misc/ompl: Update 1.4.2 -> 1.5.0
Also update WWW.
Notes
Notes: svn path=/head/; revision=552178
Diffstat (limited to 'misc/ompl')
-rw-r--r--misc/ompl/Makefile13
-rw-r--r--misc/ompl/distinfo6
-rw-r--r--misc/ompl/files/patch-CMakeLists.txt23
-rw-r--r--misc/ompl/files/patch-CMakeModules_CompilerSettings.cmake23
-rw-r--r--misc/ompl/pkg-descr2
-rw-r--r--misc/ompl/pkg-plist60
6 files changed, 61 insertions, 66 deletions
diff --git a/misc/ompl/Makefile b/misc/ompl/Makefile
index 331a4a9ab5d3..9f49cdd0392f 100644
--- a/misc/ompl/Makefile
+++ b/misc/ompl/Makefile
@@ -1,11 +1,8 @@
# $FreeBSD$
PORTNAME= ompl
-DISTVERSION= 1.4.2
-DISTVERSIONSUFFIX= -Source
-PORTREVISION= 3
+DISTVERSION= 1.5.0
CATEGORIES= misc comms
-MASTER_SITES= http://cdn.bitbucket.org/${PORTNAME}/${PORTNAME}/downloads/
MAINTAINER= yuri@FreeBSD.org
COMMENT= Open Motion Planning Library
@@ -15,10 +12,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libboost_system.so:devel/boost-libs
-USES= cmake compiler:c++11-lang eigen:3 pkgconfig zip
+USES= cmake compiler:c++11-lang eigen:3 pkgconfig
+USE_GITHUB= yes
USE_LDCONFIG= yes
-CMAKE_OFF= OMPL_REGISTRATION OMPL_BUILD_TESTS OMPL_BUILD_DEMOS
+CMAKE_OFF= OMPL_REGISTRATION OMPL_BUILD_TESTS OMPL_BUILD_DEMOS OMPL_VERSIONED_INSTALL
OPTIONS_DEFINE= FLANN MORSE OPENDE SPOT TRIANGLE PLANNERARENA
OPTIONS_DEFAULT= FLANN MORSE OPENDE TRIANGLE
@@ -53,9 +51,6 @@ post-patch-${o}-off:
post-patch-PLANNERARENA-off:
@${REINPLACE_CMD} 's|find_program(R_EXEC|#&|' ${WRKSRC}/CMakeLists.txt
-post-patch-SPOT-on:
- @${REINPLACE_CMD} 's|-std=c++11|-std=c++14|' ${WRKSRC}/CMakeModules/CompilerSettings.cmake
-
post-configure:
@${REINPLACE_CMD} 's|/usr/bin/morse|${LOCALBASE}/bin/morse|' ${BUILD_WRKSRC}/CMakeCache.txt
diff --git a/misc/ompl/distinfo b/misc/ompl/distinfo
index 03c2c3406638..1a2e2af0a6f9 100644
--- a/misc/ompl/distinfo
+++ b/misc/ompl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1557120365
-SHA256 (ompl-1.4.2-Source.zip) = 25ea88a89981a15896214d0896aa31e034dcd7368b29826679ab766ff5d10ef1
-SIZE (ompl-1.4.2-Source.zip) = 23592084
+TIMESTAMP = 1602556395
+SHA256 (ompl-ompl-1.5.0_GH0.tar.gz) = a7df8611b7823ef44c731f02897571adfc23551e85c6618d926e7720004267a5
+SIZE (ompl-ompl-1.5.0_GH0.tar.gz) = 23081668
diff --git a/misc/ompl/files/patch-CMakeLists.txt b/misc/ompl/files/patch-CMakeLists.txt
index 9e3cd9e97f0c..d79de93c2746 100644
--- a/misc/ompl/files/patch-CMakeLists.txt
+++ b/misc/ompl/files/patch-CMakeLists.txt
@@ -1,25 +1,8 @@
---- CMakeLists.txt.orig 2018-06-24 21:58:25 UTC
+--- CMakeLists.txt.orig 2020-06-02 18:39:48 UTC
+++ CMakeLists.txt
-@@ -97,8 +97,8 @@ enable_testing()
- set_package_properties(Python PROPERTIES
- URL "http://python.org"
- PURPOSE "Used for python bindings.")
--find_package(Python QUIET)
--find_boost_python()
-+find_package(Python QUIET)
-+find_boost_python()
-
- if(PYTHON_FOUND)
- set_package_properties(pypy PROPERTIES
-@@ -171,12 +171,12 @@ if(PYTHON_FOUND AND NOT Boost_VERSION VE
- endif()
-
- # R is needed for running Planner Arena locally
--find_program(R_EXEC R)
-+find_program(R_EXEC R)
-
- add_subdirectory(py-bindings)
+@@ -179,7 +179,7 @@ find_program(R_EXEC R)
add_subdirectory(src)
+ add_subdirectory(py-bindings)
add_subdirectory(tests)
-add_subdirectory(demos)
+#add_subdirectory(demos)
diff --git a/misc/ompl/files/patch-CMakeModules_CompilerSettings.cmake b/misc/ompl/files/patch-CMakeModules_CompilerSettings.cmake
index 3ade08453ab2..0f416eb5b492 100644
--- a/misc/ompl/files/patch-CMakeModules_CompilerSettings.cmake
+++ b/misc/ompl/files/patch-CMakeModules_CompilerSettings.cmake
@@ -1,26 +1,17 @@
---- CMakeModules/CompilerSettings.cmake.orig 2018-08-04 19:52:03 UTC
+--- CMakeModules/CompilerSettings.cmake.orig 2020-06-02 18:39:48 UTC
+++ CMakeModules/CompilerSettings.cmake
-@@ -21,12 +21,12 @@ if(CMAKE_COMPILER_IS_GNUCXX)
- -Wno-noexcept-type
- -Wno-deprecated-declarations)
+@@ -5,12 +5,12 @@ set(CMAKE_CXX_EXTENSIONS OFF)
+ if(CMAKE_COMPILER_IS_GNUCXX)
+ add_definitions(-W -Wall -Wextra -Wno-system-headers)
# prepend optimizion flag (in case the default setting doesn't include one)
- set(CMAKE_CXX_FLAGS_RELEASE "-O3 ${CMAKE_CXX_FLAGS_RELEASE}")
+ set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE}")
endif(CMAKE_COMPILER_IS_GNUCXX)
- if(CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
- add_definitions(-W -Wall -Wextra -Wno-missing-field-initializers -Wno-unused -Wno-unused-parameter -Wno-delete-non-virtual-dtor -Wno-overloaded-virtual -Wno-unknown-pragmas -Qunused-arguments -Wno-deprecated-register -Wno-mismatched-tags -Wno-deprecated-declarations)
+ if(CMAKE_CXX_COMPILER_ID MATCHES "^(Apple)?Clang$")
+ add_definitions(-W -Wall -Wextra -Wno-system-headers)
# prepend optimizion flag (in case the default setting doesn't include one)
- set(CMAKE_CXX_FLAGS_RELEASE "-O3 ${CMAKE_CXX_FLAGS_RELEASE}")
+ set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE}")
endif()
- if(MSVC OR MSVC90 OR MSVC10)
-@@ -42,7 +42,7 @@ if(IS_ICPC)
- add_definitions(-wd191 -wd411 -wd654 -wd1125 -wd1292 -wd1565 -wd1628 -wd2196)
- set(CMAKE_AR "xiar" CACHE STRING "Intel archiver" FORCE)
- set(CMAKE_CXX_FLAGS "-pthread" CACHE STRING "Default compile flags" FORCE)
-- set(CMAKE_CXX_FLAGS_RELEASE "-O3 -DNDEBUG"
-+ set(CMAKE_CXX_FLAGS_RELEASE "-DNDEBUG"
- CACHE STRING "Flags used by the C++ compiler during release builds." FORCE)
- set(CMAKE_CXX_FLAGS_DEBUG "-O0 -g" CACHE STRING
- "Flags used by the C++ compiler during debug builds." FORCE)
+ if(MSVC)
diff --git a/misc/ompl/pkg-descr b/misc/ompl/pkg-descr
index 7587eadc33d4..e06d91fcd4c0 100644
--- a/misc/ompl/pkg-descr
+++ b/misc/ompl/pkg-descr
@@ -9,4 +9,4 @@ tutorials, demos, and programming assignments are designed to teach students
about sampling-based motion planning. The library is also available for use
through Robot Operating System (ROS).
-WWW: https://bitbucket.org/ompl/ompl/src/default/
+WWW: https://ompl.kavrakilab.org/
diff --git a/misc/ompl/pkg-plist b/misc/ompl/pkg-plist
index 1e8b18aeb673..b645c5e5b1f5 100644
--- a/misc/ompl/pkg-plist
+++ b/misc/ompl/pkg-plist
@@ -34,6 +34,7 @@ include/ompl/base/ValidStateSampler.h
include/ompl/base/goals/GoalLazySamples.h
include/ompl/base/goals/GoalRegion.h
include/ompl/base/goals/GoalSampleableRegion.h
+include/ompl/base/goals/GoalSpace.h
include/ompl/base/goals/GoalState.h
include/ompl/base/goals/GoalStates.h
include/ompl/base/objectives/MaximizeMinClearanceObjective.h
@@ -44,12 +45,16 @@ include/ompl/base/objectives/StateCostIntegralObjective.h
include/ompl/base/objectives/VFMechanicalWorkOptimizationObjective.h
include/ompl/base/objectives/VFUpstreamCriterionOptimizationObjective.h
include/ompl/base/samplers/BridgeTestValidStateSampler.h
+include/ompl/base/samplers/DeterministicStateSampler.h
include/ompl/base/samplers/GaussianValidStateSampler.h
include/ompl/base/samplers/InformedStateSampler.h
include/ompl/base/samplers/MaximizeClearanceValidStateSampler.h
include/ompl/base/samplers/MinimumClearanceValidStateSampler.h
include/ompl/base/samplers/ObstacleBasedValidStateSampler.h
include/ompl/base/samplers/UniformValidStateSampler.h
+include/ompl/base/samplers/deterministic/DeterministicSequence.h
+include/ompl/base/samplers/deterministic/HaltonSequence.h
+include/ompl/base/samplers/deterministic/PrecomputedSequence.h
include/ompl/base/samplers/informed/OrderedInfSampler.h
include/ompl/base/samplers/informed/PathLengthDirectInfSampler.h
include/ompl/base/samplers/informed/RejectionInfSampler.h
@@ -70,6 +75,8 @@ include/ompl/base/spaces/constraint/AtlasStateSpace.h
include/ompl/base/spaces/constraint/ConstrainedStateSpace.h
include/ompl/base/spaces/constraint/ProjectedStateSpace.h
include/ompl/base/spaces/constraint/TangentBundleStateSpace.h
+include/ompl/base/terminationconditions/CostConvergenceTerminationCondition.h
+include/ompl/base/terminationconditions/IterationTerminationCondition.h
include/ompl/config.h
include/ompl/control/Control.h
include/ompl/control/ControlSampler.h
@@ -105,6 +112,7 @@ include/ompl/control/planners/syclop/SyclopEST.h
include/ompl/control/planners/syclop/SyclopRRT.h
include/ompl/control/spaces/DiscreteControlSpace.h
include/ompl/control/spaces/RealVectorControlSpace.h
+include/ompl/datastructures/AdjacencyList.h
include/ompl/datastructures/BinaryHeap.h
include/ompl/datastructures/DynamicSSSP.h
include/ompl/datastructures/GreedyKCenters.h
@@ -129,12 +137,12 @@ include/ompl/extensions/morse/MorseStatePropagator.h
include/ompl/extensions/morse/MorseStateSpace.h
include/ompl/extensions/morse/MorseStateValidityChecker.h
include/ompl/extensions/morse/MorseTerminationCondition.h
-include/ompl/extensions/opende/OpenDEControlSpace.h
-include/ompl/extensions/opende/OpenDEEnvironment.h
-include/ompl/extensions/opende/OpenDESimpleSetup.h
-include/ompl/extensions/opende/OpenDEStatePropagator.h
-include/ompl/extensions/opende/OpenDEStateSpace.h
-include/ompl/extensions/opende/OpenDEStateValidityChecker.h
+include/ompl/extensions/ode/OpenDEControlSpace.h
+include/ompl/extensions/ode/OpenDEEnvironment.h
+include/ompl/extensions/ode/OpenDESimpleSetup.h
+include/ompl/extensions/ode/OpenDEStatePropagator.h
+include/ompl/extensions/ode/OpenDEStateSpace.h
+include/ompl/extensions/ode/OpenDEStateValidityChecker.h
include/ompl/extensions/triangle/PropositionalTriangularDecomposition.h
include/ompl/extensions/triangle/TriangularDecomposition.h
include/ompl/geometric/GeneticSearch.h
@@ -145,13 +153,6 @@ include/ompl/geometric/PathSimplifier.h
include/ompl/geometric/SimpleSetup.h
include/ompl/geometric/planners/AnytimePathShortening.h
include/ompl/geometric/planners/PlannerIncludes.h
-include/ompl/geometric/planners/bitstar/BITstar.h
-include/ompl/geometric/planners/bitstar/datastructures/CostHelper.h
-include/ompl/geometric/planners/bitstar/datastructures/HelperFunctions.h
-include/ompl/geometric/planners/bitstar/datastructures/IdGenerator.h
-include/ompl/geometric/planners/bitstar/datastructures/ImplicitGraph.h
-include/ompl/geometric/planners/bitstar/datastructures/SearchQueue.h
-include/ompl/geometric/planners/bitstar/datastructures/Vertex.h
include/ompl/geometric/planners/cforest/CForest.h
include/ompl/geometric/planners/cforest/CForestStateSampler.h
include/ompl/geometric/planners/cforest/CForestStateSpaceWrapper.h
@@ -162,6 +163,18 @@ include/ompl/geometric/planners/experience/LightningRetrieveRepair.h
include/ompl/geometric/planners/experience/ThunderRetrieveRepair.h
include/ompl/geometric/planners/fmt/BFMT.h
include/ompl/geometric/planners/fmt/FMT.h
+include/ompl/geometric/planners/informedtrees/ABITstar.h
+include/ompl/geometric/planners/informedtrees/AITstar.h
+include/ompl/geometric/planners/informedtrees/BITstar.h
+include/ompl/geometric/planners/informedtrees/aitstar/Edge.h
+include/ompl/geometric/planners/informedtrees/aitstar/ImplicitGraph.h
+include/ompl/geometric/planners/informedtrees/aitstar/Vertex.h
+include/ompl/geometric/planners/informedtrees/bitstar/CostHelper.h
+include/ompl/geometric/planners/informedtrees/bitstar/HelperFunctions.h
+include/ompl/geometric/planners/informedtrees/bitstar/IdGenerator.h
+include/ompl/geometric/planners/informedtrees/bitstar/ImplicitGraph.h
+include/ompl/geometric/planners/informedtrees/bitstar/SearchQueue.h
+include/ompl/geometric/planners/informedtrees/bitstar/Vertex.h
include/ompl/geometric/planners/kpiece/BKPIECE1.h
include/ompl/geometric/planners/kpiece/Discretization.h
include/ompl/geometric/planners/kpiece/KPIECE1.h
@@ -174,6 +187,15 @@ include/ompl/geometric/planners/prm/PRM.h
include/ompl/geometric/planners/prm/PRMstar.h
include/ompl/geometric/planners/prm/SPARS.h
include/ompl/geometric/planners/prm/SPARStwo.h
+include/ompl/geometric/planners/quotientspace/QRRT.h
+include/ompl/geometric/planners/quotientspace/algorithms/MultiQuotient.h
+include/ompl/geometric/planners/quotientspace/algorithms/MultiQuotientImpl.h
+include/ompl/geometric/planners/quotientspace/algorithms/QRRTImpl.h
+include/ompl/geometric/planners/quotientspace/datastructures/PlannerDataVertexAnnotated.h
+include/ompl/geometric/planners/quotientspace/datastructures/QuotientSpace.h
+include/ompl/geometric/planners/quotientspace/datastructures/QuotientSpaceGraph.h
+include/ompl/geometric/planners/rlrt/BiRLRT.h
+include/ompl/geometric/planners/rlrt/RLRT.h
include/ompl/geometric/planners/rrt/BiTRRT.h
include/ompl/geometric/planners/rrt/InformedRRTstar.h
include/ompl/geometric/planners/rrt/LBTRRT.h
@@ -186,12 +208,17 @@ include/ompl/geometric/planners/rrt/RRTsharp.h
include/ompl/geometric/planners/rrt/RRTstar.h
include/ompl/geometric/planners/rrt/SORRTstar.h
include/ompl/geometric/planners/rrt/TRRT.h
+include/ompl/geometric/planners/rrt/TSRRT.h
include/ompl/geometric/planners/rrt/VFRRT.h
include/ompl/geometric/planners/rrt/pRRT.h
include/ompl/geometric/planners/sbl/SBL.h
include/ompl/geometric/planners/sbl/pSBL.h
include/ompl/geometric/planners/sst/SST.h
include/ompl/geometric/planners/stride/STRIDE.h
+include/ompl/geometric/planners/xxl/XXL.h
+include/ompl/geometric/planners/xxl/XXLDecomposition.h
+include/ompl/geometric/planners/xxl/XXLPlanarDecomposition.h
+include/ompl/geometric/planners/xxl/XXLPositionDecomposition.h
include/ompl/tools/benchmark/Benchmark.h
include/ompl/tools/benchmark/MachineSpecs.h
include/ompl/tools/config/MagicConstants.h
@@ -209,7 +236,6 @@ include/ompl/tools/thunder/Thunder.h
include/ompl/tools/thunder/ThunderDB.h
include/ompl/util/ClassForward.h
include/ompl/util/Console.h
-include/ompl/util/Deprecation.h
include/ompl/util/DisableCompilerWarning.h
include/ompl/util/Exception.h
include/ompl/util/GeometricEquations.h
@@ -220,14 +246,14 @@ include/ompl/util/RandomNumbers.h
include/ompl/util/String.h
include/ompl/util/Time.h
lib/libompl.so
-lib/libompl.so.1.4.2
-lib/libompl.so.15
+lib/libompl.so.1.5.0
+lib/libompl.so.16
libdata/pkgconfig/ompl.pc
man/man1/ompl_benchmark_statistics.1.gz
%%PLANNERARENA%%man/man1/plannerarena.1.gz
%%DATADIR%%/cmake/omplConfig.cmake
%%DATADIR%%/cmake/omplConfigVersion.cmake
-%%DATADIR%%/ompl.conf
+%%DATADIR%%/package.xml
%%PLANNERARENA%%%%DATADIR%%/plannerarena/global.R
%%PLANNERARENA%%%%DATADIR%%/plannerarena/plannerarena
%%PLANNERARENA%%%%DATADIR%%/plannerarena/server.R