aboutsummaryrefslogtreecommitdiff
path: root/misc/opencyc/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-04-20 15:02:55 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-04-20 15:02:55 +0000
commit8f23691806899fa00b7cc4239535a5c0e6cdea53 (patch)
tree6773f425cdba71ab06171f9b2bfc207be792e59c /misc/opencyc/Makefile
parent925d7cf2dd87ddf9ba9c9378d16aadd2035728c9 (diff)
downloadports-8f23691806899fa00b7cc4239535a5c0e6cdea53.tar.gz
ports-8f23691806899fa00b7cc4239535a5c0e6cdea53.zip
Notes
Diffstat (limited to 'misc/opencyc/Makefile')
-rw-r--r--misc/opencyc/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/misc/opencyc/Makefile b/misc/opencyc/Makefile
new file mode 100644
index 000000000000..a30a262f384a
--- /dev/null
+++ b/misc/opencyc/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: opencyc
+# Date created: Apr 19 2003
+# Whom: Alex Semenyaka <alex@rinet.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= opencyc
+PORTVERSION= 0.7.0
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= alexs@snark.rinet.ru
+COMMENT= General knowledge base and commonsense reasoning engine
+
+NO_BUILD= yes
+USE_LINUX= yes
+
+BRANDELF= /usr/bin/brandelf
+
+pre-patch:
+ @${BRANDELF} -t Linux ${WRKSRC}/run/bin/latest.bin
+ @${RM} ${WRKSRC}/doc/.#*
+
+do-install:
+ @${CP} -PRpf ${WRKSRC} ${PREFIX}
+
+.include <bsd.port.mk>