aboutsummaryrefslogtreecommitdiff
path: root/misc/opennn
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-05-28 01:29:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-05-28 01:29:59 +0000
commit11c94fb1ad555829bc8e82bfecaaa6e94a53245c (patch)
tree2718aa376f7cfed63a3df17c73c92f2fa32c2b76 /misc/opennn
parent5472cf7764f5943542a313b88562b4b384535165 (diff)
downloadports-11c94fb1ad555829bc8e82bfecaaa6e94a53245c.tar.gz
ports-11c94fb1ad555829bc8e82bfecaaa6e94a53245c.zip
misc/opennn: Update 0.1-86 -> 4.0
The GitHub project for some reason has a version 0.1, and SF has 4.0
Notes
Notes: svn path=/head/; revision=536733
Diffstat (limited to 'misc/opennn')
-rw-r--r--misc/opennn/Makefile13
-rw-r--r--misc/opennn/distinfo6
-rw-r--r--misc/opennn/files/patch-CMakeLists.txt13
-rw-r--r--misc/opennn/files/patch-opennn_CMakeLists.txt6
-rw-r--r--misc/opennn/pkg-plist40
5 files changed, 29 insertions, 49 deletions
diff --git a/misc/opennn/Makefile b/misc/opennn/Makefile
index f37988d9f17f..9e66c6223b82 100644
--- a/misc/opennn/Makefile
+++ b/misc/opennn/Makefile
@@ -1,10 +1,10 @@
# $FreeBSD$
PORTNAME= opennn
-DISTVERSION= 0.1-86
-DISTVERSIONSUFFIX= -g449b346
-PORTREVISION= 2
+DISTVERSION= 4.0
CATEGORIES= misc # machine-learning
+MASTER_SITES= SF/${PORTNAME}/
+DISTNAME= ${PORTNAME}_${DISTVERSION}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Open neural networks library
@@ -12,11 +12,8 @@ COMMENT= Open neural networks library
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= cmake compiler dos2unix
-DOS2UNIX_FILES= CMakeLists.txt
-USE_GITHUB= yes
-GH_ACCOUNT= Artelnics
-GH_PROJECT= OpenNN
+USES= cmake compiler dos2unix zip
+DOS2UNIX_FILES= opennn/CMakeLists.txt
USE_LDCONFIG= yes
CMAKE_OFF= OpenNN_BUILD_EXAMPLES OpenNN_BUILD_TESTS
diff --git a/misc/opennn/distinfo b/misc/opennn/distinfo
index 945a50dd4f6c..8c4104f956b2 100644
--- a/misc/opennn/distinfo
+++ b/misc/opennn/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1574568515
-SHA256 (Artelnics-OpenNN-0.1-86-g449b346_GH0.tar.gz) = 1277637d5593bbe652ef0499d762aa54c1085e4dac2fc4b01ba7e304878f2352
-SIZE (Artelnics-OpenNN-0.1-86-g449b346_GH0.tar.gz) = 3572152
+TIMESTAMP = 1590628765
+SHA256 (opennn_4.0.zip) = f0ade93fe24b88eea90aeee85f5c70066ed6c087a34240752178ecd68861f975
+SIZE (opennn_4.0.zip) = 6656578
diff --git a/misc/opennn/files/patch-CMakeLists.txt b/misc/opennn/files/patch-CMakeLists.txt
deleted file mode 100644
index 68a1dd56e012..000000000000
--- a/misc/opennn/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,13 +0,0 @@
---- CMakeLists.txt.orig 2019-11-29 00:56:51 UTC
-+++ CMakeLists.txt
-@@ -8,8 +8,8 @@ if(__OPENNN_MPI__)
- find_package(MPI)
- if(MPI_FOUND)
- message("Using MPI")
-- set(CMAKE_CXX_COMPILER mpicxx)
-- set(CMAKE_C_COMPILER mpicc)
-+ set(CMAKE_CXX_COMPILER ${CMAKE_INSTALL_PREFIX}/bin/mpicxx)
-+ set(CMAKE_C_COMPILER ${CMAKE_INSTALL_PREFIX}/bin/mpicc)
- set(CMAKE_CXX_COMPILE_FLAGS "${CMAKE_CXX_COMPILE_FLAGS} ${MPI_COMPILE_FLAGS}")
- set(CMAKE_CXX_LINK_FLAGS "${CMAKE_CXX_LINK_FLAGS} ${MPI_LINK_FLAGS}")
- add_definitions(-D__OPENNN_MPI__ )
diff --git a/misc/opennn/files/patch-opennn_CMakeLists.txt b/misc/opennn/files/patch-opennn_CMakeLists.txt
index 35eb2bb8ce56..3727ab947e95 100644
--- a/misc/opennn/files/patch-opennn_CMakeLists.txt
+++ b/misc/opennn/files/patch-opennn_CMakeLists.txt
@@ -1,11 +1,11 @@
---- opennn/CMakeLists.txt.orig 2019-11-29 00:38:47 UTC
+--- opennn/CMakeLists.txt.orig 2020-01-03 01:55:58 UTC
+++ opennn/CMakeLists.txt
@@ -6,7 +6,7 @@ cmake_minimum_required(VERSION 2.8.10)
project(opennn)
--add_library(opennn
+-add_library(opennn
+add_library(opennn SHARED
adaptive_moment_estimation.cpp
- association_rules.cpp
bounding_layer.cpp
+ conjugate_gradient.cpp
diff --git a/misc/opennn/pkg-plist b/misc/opennn/pkg-plist
index 5331c50e80e0..be7ee0b89bdd 100644
--- a/misc/opennn/pkg-plist
+++ b/misc/opennn/pkg-plist
@@ -1,57 +1,53 @@
include/opennn/adaptive_moment_estimation.h
-include/opennn/association_rules.h
include/opennn/bounding_layer.h
include/opennn/conjugate_gradient.h
-include/opennn/correlation_analysis.h
+include/opennn/convolutional_layer.h
+include/opennn/correlations.h
include/opennn/cross_entropy_error.h
include/opennn/data_set.h
-include/opennn/file_utilities.h
+include/opennn/functions.h
include/opennn/genetic_algorithm.h
-include/opennn/golden_section_order.h
include/opennn/gradient_descent.h
include/opennn/growing_inputs.h
-include/opennn/incremental_order.h
-include/opennn/inputs.h
-include/opennn/inputs_selection_algorithm.h
-include/opennn/inputs_trending_layer.h
-include/opennn/instances.h
-include/opennn/k_nearest_neighbors.h
+include/opennn/incremental_neurons.h
+include/opennn/inputs_selection.h
+include/opennn/k_means.h
+include/opennn/layer.h
include/opennn/learning_rate_algorithm.h
include/opennn/levenberg_marquardt_algorithm.h
+include/opennn/long_short_term_memory_layer.h
include/opennn/loss_index.h
include/opennn/matrix.h
include/opennn/mean_squared_error.h
+include/opennn/metrics.h
include/opennn/minkowski_error.h
-include/opennn/missing_values.h
include/opennn/model_selection.h
-include/opennn/multilayer_perceptron.h
include/opennn/neural_network.h
+include/opennn/neurons_selection.h
include/opennn/normalized_squared_error.h
include/opennn/numerical_differentiation.h
-include/opennn/numerical_integration.h
include/opennn/opennn.h
+include/opennn/opennn_strings.h
include/opennn/optimization_algorithm.h
-include/opennn/order_selection_algorithm.h
-include/opennn/outputs.h
-include/opennn/outputs_trending_layer.h
include/opennn/perceptron_layer.h
+include/opennn/pooling_layer.h
include/opennn/principal_components_layer.h
include/opennn/probabilistic_layer.h
include/opennn/pruning_inputs.h
include/opennn/quasi_newton_method.h
-include/opennn/scaled_conjugate_gradient.h
+include/opennn/recurrent_layer.h
+include/opennn/response_optimization.h
include/opennn/scaling_layer.h
-include/opennn/selective_pruning.h
-include/opennn/simulated_annealing_order.h
-include/opennn/sparse_matrix.h
+include/opennn/statistics.h
include/opennn/stochastic_gradient_descent.h
include/opennn/sum_squared_error.h
+include/opennn/tensor.h
include/opennn/testing_analysis.h
-include/opennn/text_analytics.h
include/opennn/tinyxml2.h
include/opennn/training_strategy.h
+include/opennn/transformations.h
+include/opennn/unit_testing.h
include/opennn/unscaling_layer.h
-include/opennn/variables.h
include/opennn/vector.h
include/opennn/weighted_squared_error.h
lib/libopennn.so