aboutsummaryrefslogtreecommitdiff
path: root/misc/openvdb
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-12-14 00:50:04 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-12-14 00:50:04 +0000
commit037f1e7719475ef6ad269fd95134e28525af153a (patch)
tree0c29c490d7e66bfea83efba6922dbe335398e4eb /misc/openvdb
parente5f0484bd743d9663135294465b632a24684c8be (diff)
downloadports-037f1e7719475ef6ad269fd95134e28525af153a.tar.gz
ports-037f1e7719475ef6ad269fd95134e28525af153a.zip
misc/openvdb: Update 7.1.0 -> 7.2.0
Reported by: portscout
Notes
Notes: svn path=/head/; revision=558068
Diffstat (limited to 'misc/openvdb')
-rw-r--r--misc/openvdb/Makefile11
-rw-r--r--misc/openvdb/distinfo6
-rw-r--r--misc/openvdb/files/patch-CMakeLists.txt15
-rw-r--r--misc/openvdb/files/patch-openvdb_openvdb_python_CMakeLists.txt (renamed from misc/openvdb/files/patch-openvdb_python_CMakeLists.txt)4
-rw-r--r--misc/openvdb/files/patch-openvdb_points_AttributeSet.cc10
-rw-r--r--misc/openvdb/files/patch-openvdb_points_AttributeSet.h10
-rw-r--r--misc/openvdb/pkg-plist9
7 files changed, 22 insertions, 43 deletions
diff --git a/misc/openvdb/Makefile b/misc/openvdb/Makefile
index c16eda9898cd..d54139b2b22d 100644
--- a/misc/openvdb/Makefile
+++ b/misc/openvdb/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openvdb
DISTVERSIONPREFIX= v
-DISTVERSION= 7.1.0
+DISTVERSION= 7.2.0
CATEGORIES= misc
MAINTAINER= yuri@FreeBSD.org
@@ -24,7 +24,7 @@ USE_LDCONFIG= yes
CMAKE_ARGS= -DCONCURRENT_MALLOC="Tbbmalloc"
CMAKE_OFF= OPENVDB_CORE_STATIC
-OPTIONS_DEFINE= PYTHON TOOLS DOCS # TOOLS and PYTHON should be made into subpackages
+OPTIONS_DEFINE= PYTHON TOOLS #DOCS # TOOLS and PYTHON should be made into subpackages
OPTIONS_DEFAULT= PYTHON TOOLS
OPTIONS_SUB= yes
@@ -43,9 +43,10 @@ TOOLS_LIB_DEPENDS= libglfw.so:graphics/glfw \
TOOLS_USES= gl xorg
TOOLS_USE= GL=gl,glu XORG=ice,sm,x11,xcursor,xext,xi,xinerama,xrandr,xxf86vm
-DOCS_CMAKE_BOOL= OPENVDB_BUILD_DOCS
-DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
+# DOCS is broken: https://github.com/AcademySoftwareFoundation/openvdb/issues/899
+#DOCS_CMAKE_BOOL= OPENVDB_BUILD_DOCS
+#DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
-PORTDOCS= *
+#PORTDOCS= *
.include <bsd.port.mk>
diff --git a/misc/openvdb/distinfo b/misc/openvdb/distinfo
index f8fa8fa43a00..7fcfd172b30d 100644
--- a/misc/openvdb/distinfo
+++ b/misc/openvdb/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1605404028
-SHA256 (AcademySoftwareFoundation-openvdb-v7.1.0_GH0.tar.gz) = 0c3588c1ca6e647610738654ec2c6aaf41a203fd797f609fbeab1c9f7c3dc116
-SIZE (AcademySoftwareFoundation-openvdb-v7.1.0_GH0.tar.gz) = 1956052
+TIMESTAMP = 1607816892
+SHA256 (AcademySoftwareFoundation-openvdb-v7.2.0_GH0.tar.gz) = 81ff2758e3900e5d4022fde0149d63387167db8adaf5c0ace1456dad3a012d1d
+SIZE (AcademySoftwareFoundation-openvdb-v7.2.0_GH0.tar.gz) = 2283069
diff --git a/misc/openvdb/files/patch-CMakeLists.txt b/misc/openvdb/files/patch-CMakeLists.txt
index 07041ff21955..9815b10ec9e4 100644
--- a/misc/openvdb/files/patch-CMakeLists.txt
+++ b/misc/openvdb/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2020-08-13 19:15:58 UTC
+--- CMakeLists.txt.orig 2020-12-09 15:44:05 UTC
+++ CMakeLists.txt
-@@ -217,7 +217,7 @@ mark_as_advanced(
+@@ -197,7 +197,7 @@ mark_as_advanced(
# @note Blosc version is currently treated as exception which must be adhered
# to. The minimum version must be at least 1.5.0. Previous versions are incompatible.
# Later versions (including 1.5.4), can be buggy on certain platforms.
@@ -9,15 +9,12 @@
# @note ABI always enforced so the correct deprecation messages are available.
# OPENVDB_USE_DEPRECATED_ABI_<VERSION> should be used to circumvent this
set(MINIMUM_OPENVDB_ABI_VERSION 5)
-@@ -235,9 +235,9 @@ if(NOT DISABLE_DEPENDENCY_VERSION_CHECKS)
- set(MINIMUM_ILMBASE_VERSION 2.2)
- set(MINIMUM_OPENEXR_VERSION 2.2)
- set(MINIMUM_ZLIB_VERSION 1.2.7)
-- set(MINIMUM_TBB_VERSION 2017.0)
-+ #set(MINIMUM_TBB_VERSION 2019.0) # bogus check: https://github.com/AcademySoftwareFoundation/openvdb/issues/688
+@@ -218,7 +218,7 @@ if(NOT DISABLE_DEPENDENCY_VERSION_CHECKS)
+ set(MINIMUM_TBB_VERSION 2017.0)
+ set(MINIMUM_LLVM_VERSION 6.0.0)
- set(MINIMUM_PYTHON_VERSION 2.7)
+ set(MINIMUM_PYTHON_VERSION ${FREEBSD_PYTHON_VER})
set(MINIMUM_NUMPY_VERSION 1.12.1)
- set(MINIMUM_CPPUNIT_VERSION 1.10)
+ set(MINIMUM_GOOGLETEST_VERSION 1.8)
diff --git a/misc/openvdb/files/patch-openvdb_python_CMakeLists.txt b/misc/openvdb/files/patch-openvdb_openvdb_python_CMakeLists.txt
index a9b703a2572b..52bfb0575cf9 100644
--- a/misc/openvdb/files/patch-openvdb_python_CMakeLists.txt
+++ b/misc/openvdb/files/patch-openvdb_openvdb_python_CMakeLists.txt
@@ -1,5 +1,5 @@
---- openvdb/python/CMakeLists.txt.orig 2020-08-13 19:15:58 UTC
-+++ openvdb/python/CMakeLists.txt
+--- openvdb/openvdb/python/CMakeLists.txt.orig 2020-08-13 19:15:58 UTC
++++ openvdb/openvdb/python/CMakeLists.txt
@@ -104,9 +104,9 @@ if(${CMAKE_VERSION} VERSION_LESS 3.12)
elseif(${CMAKE_VERSION} VERSION_LESS 3.14)
# CMake < 3.14
diff --git a/misc/openvdb/files/patch-openvdb_points_AttributeSet.cc b/misc/openvdb/files/patch-openvdb_points_AttributeSet.cc
deleted file mode 100644
index df4f4b49596d..000000000000
--- a/misc/openvdb/files/patch-openvdb_points_AttributeSet.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- openvdb/points/AttributeSet.cc.orig 2019-12-06 20:11:33 UTC
-+++ openvdb/points/AttributeSet.cc
-@@ -7,6 +7,7 @@
- #include "AttributeGroup.h"
-
- #include <algorithm> // std::equal
-+#include <climits> // CHAR_BIT
- #include <string>
-
- namespace openvdb {
diff --git a/misc/openvdb/files/patch-openvdb_points_AttributeSet.h b/misc/openvdb/files/patch-openvdb_points_AttributeSet.h
deleted file mode 100644
index 757500824840..000000000000
--- a/misc/openvdb/files/patch-openvdb_points_AttributeSet.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- openvdb/points/AttributeSet.h.orig 2020-11-27 13:35:57 UTC
-+++ openvdb/points/AttributeSet.h
-@@ -14,6 +14,7 @@
- #include <openvdb/version.h>
- #include <openvdb/MetaMap.h>
-
-+#include <climits>
- #include <limits>
- #include <memory>
- #include <vector>
diff --git a/misc/openvdb/pkg-plist b/misc/openvdb/pkg-plist
index 6c54c222032d..8200add8f341 100644
--- a/misc/openvdb/pkg-plist
+++ b/misc/openvdb/pkg-plist
@@ -1,5 +1,5 @@
-bin/vdb_print
%%TOOLS%%bin/vdb_lod
+%%TOOLS%%bin/vdb_print
%%TOOLS%%bin/vdb_render
%%TOOLS%%bin/vdb_view
include/openvdb/Exceptions.h
@@ -8,6 +8,7 @@ include/openvdb/MetaMap.h
include/openvdb/Metadata.h
include/openvdb/Platform.h
include/openvdb/PlatformConfig.h
+include/openvdb/TypeList.h
include/openvdb/Types.h
include/openvdb/io/Archive.h
include/openvdb/io/Compression.h
@@ -84,6 +85,7 @@ include/openvdb/tools/LevelSetSphere.h
include/openvdb/tools/LevelSetTracker.h
include/openvdb/tools/LevelSetUtil.h
include/openvdb/tools/Mask.h
+include/openvdb/tools/Merge.h
include/openvdb/tools/MeshToVolume.h
include/openvdb/tools/Morphology.h
include/openvdb/tools/MultiResGrid.h
@@ -132,7 +134,6 @@ include/openvdb/util/Util.h
include/openvdb/util/logging.h
include/openvdb/version.h
lib/cmake/OpenVDB/FindBlosc.cmake
-lib/cmake/OpenVDB/FindCppUnit.cmake
lib/cmake/OpenVDB/FindIlmBase.cmake
lib/cmake/OpenVDB/FindJemalloc.cmake
lib/cmake/OpenVDB/FindLog4cplus.cmake
@@ -144,6 +145,6 @@ lib/cmake/OpenVDB/OpenVDBHoudiniSetup.cmake
lib/cmake/OpenVDB/OpenVDBMayaSetup.cmake
lib/cmake/OpenVDB/OpenVDBUtils.cmake
lib/libopenvdb.so
-lib/libopenvdb.so.7.1
-lib/libopenvdb.so.7.1.0
+lib/libopenvdb.so.7.2
+lib/libopenvdb.so.7.2.0
%%PYTHON%%%%PYTHON_LIBDIR%%/pyopenvdb.so