aboutsummaryrefslogtreecommitdiff
path: root/misc/ossp-uuid/Makefile
diff options
context:
space:
mode:
authorRalf S. Engelschall <rse@FreeBSD.org>2004-11-06 08:18:02 +0000
committerRalf S. Engelschall <rse@FreeBSD.org>2004-11-06 08:18:02 +0000
commit1f178ecd7eea77b3f38e816b222b61dd4da7cfe9 (patch)
treedfddb6ff81ba015b60b76ac12afd3d3f46045289 /misc/ossp-uuid/Makefile
parentc3474737ff47a1cf0a2f30eb9d65e05a6683a207 (diff)
downloadports-1f178ecd7eea77b3f38e816b222b61dd4da7cfe9.tar.gz
ports-1f178ecd7eea77b3f38e816b222b61dd4da7cfe9.zip
Notes
Diffstat (limited to 'misc/ossp-uuid/Makefile')
-rw-r--r--misc/ossp-uuid/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/misc/ossp-uuid/Makefile b/misc/ossp-uuid/Makefile
index 710bd31b244c..9f4c8327b300 100644
--- a/misc/ossp-uuid/Makefile
+++ b/misc/ossp-uuid/Makefile
@@ -6,23 +6,35 @@
#
PORTNAME= uuid
-PORTVERSION= 1.0.1
+PORTVERSION= 1.1.0
CATEGORIES= misc devel
MASTER_SITES= ${MASTER_SITE_OSSP}
MASTER_SITE_SUBDIR= lib/${PORTNAME}
PKGNAMEPREFIX= ossp-
MAINTAINER= ports@FreeBSD.org
-COMMENT= An ISO-C API and CLI for generating Universally Unique Identifiers
+COMMENT= An ISO-C & Perl API and CLI for generating Universally Unique Identifiers (UUID)
CONFLICTS= e2fsprogs-[0-9]*
USE_LIBTOOL_VER= 15
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS+= --disable-shared --enable-static
MAN1= uuid-config.1 uuid.1
MAN3= uuid.3
+.if !defined(WITHOUT_PERL)
+USE_PERL5= yes
+CONFIGURE_ENV+= PERL=${PERL5}
+CONFIGURE_ARGS+= --with-perl
+PLIST_SUB+= WITH_PERL=''
+MAN3= OSSP::uuid.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+.else
+PLIST_SUB+= WITH_PERL='@comment '
+.endif
+
test:
cd ${WRKSRC}; ${MAKE} check