aboutsummaryrefslogtreecommitdiff
path: root/misc/ossp-uuid
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-03-06 11:48:10 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-03-06 11:48:10 +0000
commit5b63de467e6b4bfe0fd2f41c9620b1fa8575f14d (patch)
tree8063a69dc7cf43527c5d7f1a29654aa0286b67cc /misc/ossp-uuid
parenta6848ff6a376e87f7e4ea0326bfabf82a5f480f3 (diff)
downloadports-5b63de467e6b4bfe0fd2f41c9620b1fa8575f14d.tar.gz
ports-5b63de467e6b4bfe0fd2f41c9620b1fa8575f14d.zip
net/guacamole-server, misc/e2fsprogs-libuuid, misc/p5-OSSP-uuid, misc/ossp-uuid
Currently when requiring both ossp-uuid and e2fspogs-libuuid is an impossibility without the use of a jail. This patch was created to fix this conflict. The patch includes updating revisions for removal of CONFLICTS, and change LIBDEPEND change for all affected ports. The changes on ossp-uuid port includes renaming of the shared/static libs created, C/C++ manpage, and rename of pkgconfig file. PR: 207004 Submitted by: Ultima1252@gmail.com Approved by: vd
Notes
Notes: svn path=/head/; revision=410454
Diffstat (limited to 'misc/ossp-uuid')
-rw-r--r--misc/ossp-uuid/Makefile9
-rw-r--r--misc/ossp-uuid/files/patch-Makefile.in35
-rw-r--r--misc/ossp-uuid/files/patch-uuid.pc.in4
-rw-r--r--misc/ossp-uuid/pkg-plist22
4 files changed, 54 insertions, 16 deletions
diff --git a/misc/ossp-uuid/Makefile b/misc/ossp-uuid/Makefile
index 40a42cd0694f..9522f9985e47 100644
--- a/misc/ossp-uuid/Makefile
+++ b/misc/ossp-uuid/Makefile
@@ -3,7 +3,7 @@
PORTNAME= uuid
PORTVERSION= 1.6.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= misc devel
MASTER_SITES= OSSP/lib/${PORTNAME}
PKGNAMEPREFIX= ossp-
@@ -19,12 +19,15 @@ CONFIGURE_ARGS= --with-cxx \
.if defined(SLAVEPORT) && ${SLAVEPORT}=="perl"
PKGNAMEPREFIX= p5-OSSP-
-.else
-CONFLICTS= e2fsprogs-libuuid-[0-9]*
.endif
regression-test: test
+pre-patch:
+### Fixes lib conflicts with misc/e2fsprogs-libuuid ###
+ ${REINPLACE_CMD} 's/libuuid.la/libossp-uuid.la/ ; s/libuuid++.la/libossp-uuid++.la/' \
+ ${WRKDIR}/${DISTNAME}/Makefile.in
+
test: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS} check)
diff --git a/misc/ossp-uuid/files/patch-Makefile.in b/misc/ossp-uuid/files/patch-Makefile.in
new file mode 100644
index 000000000000..f9adf99a9f6b
--- /dev/null
+++ b/misc/ossp-uuid/files/patch-Makefile.in
@@ -0,0 +1,35 @@
+### This Patch is to fix conflicts with misc/e2fsprogs-libuuid ###
+--- Makefile.in.orig 2016-02-07 14:59:23 UTC
++++ Makefile.in
+@@ -74,7 +74,7 @@ CXX_OBJS = uuid++.lo $(LIB_OBJS)
+ PRG_NAME = uuid
+ PRG_OBJS = uuid_cli.o
+
+-MAN_NAME = uuid.3 uuid++.3 uuid.1
++MAN_NAME = ossp-uuid.3 ossp-uuid++.3 uuid.1
+
+ PERL_NAME = $(S)/perl/blib/lib/OSSP/uuid.pm
+ PERL_OBJS = $(S)/perl/uuid.pm
+@@ -231,7 +231,7 @@ install:
+ $(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(mandir)/man1
+ $(SHTOOL) install -c -m 755 uuid-config $(DESTDIR)$(bindir)/
+ $(SHTOOL) install -c -m 644 $(S)/uuid-config.1 $(DESTDIR)$(mandir)/man1/
+- $(SHTOOL) install -c -m 644 $(S)/uuid.pc $(DESTDIR)$(prefix)/libdata/pkgconfig/
++ $(SHTOOL) install -c -m 644 $(S)/uuid.pc $(DESTDIR)$(prefix)/libdata/pkgconfig/ossp-uuid.pc
+ $(SHTOOL) install -c -m 644 uuid.h $(DESTDIR)$(includedir)/
+ -@if [ ".$(WITH_DCE)" = .yes ]; then \
+ echo "$(SHTOOL) install -c -m 644 $(S)/uuid_dce.h $(DESTDIR)$(includedir)/"; \
+@@ -241,10 +241,10 @@ install:
+ echo "$(SHTOOL) install -c -m 644 $(S)/uuid++.hh $(DESTDIR)$(includedir)/"; \
+ $(SHTOOL) install -c -m 644 $(S)/uuid++.hh $(DESTDIR)$(includedir)/; \
+ fi
+- $(SHTOOL) install -c -m 644 $(S)/uuid.3 $(DESTDIR)$(mandir)/man3/
++ $(SHTOOL) install -c -m 644 $(S)/uuid.3 $(DESTDIR)$(mandir)/man3/ossp-uuid.3
+ -@if [ ".$(WITH_CXX)" = .yes ]; then \
+- echo "$(SHTOOL) install -c -m 644 $(S)/uuid++.3 $(DESTDIR)$(mandir)/man3/"; \
+- $(SHTOOL) install -c -m 644 $(S)/uuid++.3 $(DESTDIR)$(mandir)/man3/; \
++ echo "$(SHTOOL) install -c -m 644 $(S)/uuid++.3 $(DESTDIR)$(mandir)/man3/ossp-uuid++.3"; \
++ $(SHTOOL) install -c -m 644 $(S)/uuid++.3 $(DESTDIR)$(mandir)/man3/ossp-uuid++.3; \
+ fi
+ @$(LIBTOOL) --mode=install $(SHTOOL) install -c -m 644 $(LIB_NAME) $(DESTDIR)$(libdir)/
+ -@if [ ".$(WITH_DCE)" = .yes ]; then \
diff --git a/misc/ossp-uuid/files/patch-uuid.pc.in b/misc/ossp-uuid/files/patch-uuid.pc.in
index b1bd5027a2df..99c58d29a1bd 100644
--- a/misc/ossp-uuid/files/patch-uuid.pc.in
+++ b/misc/ossp-uuid/files/patch-uuid.pc.in
@@ -1,5 +1,5 @@
---- uuid.pc.in.orig 2012-06-10 21:06:03.000000000 +0300
-+++ uuid.pc.in 2012-06-10 21:06:18.000000000 +0300
+--- uuid.pc.in.orig 2008-03-07 10:49:59 UTC
++++ uuid.pc.in
@@ -29,7 +29,7 @@
prefix=@prefix@
diff --git a/misc/ossp-uuid/pkg-plist b/misc/ossp-uuid/pkg-plist
index bbc8b2a8be7d..aa331f198242 100644
--- a/misc/ossp-uuid/pkg-plist
+++ b/misc/ossp-uuid/pkg-plist
@@ -2,16 +2,16 @@ bin/uuid
bin/uuid-config
include/ossp/uuid.h
include/ossp/uuid++.hh
-lib/libuuid.a
-lib/libuuid.so
-lib/libuuid.so.16
-lib/libuuid.so.16.0.22
-lib/libuuid++.a
-lib/libuuid++.so
-lib/libuuid++.so.16
-lib/libuuid++.so.16.0.22
-libdata/pkgconfig/uuid.pc
+lib/libossp-uuid.a
+lib/libossp-uuid.so
+lib/libossp-uuid.so.16
+lib/libossp-uuid.so.16.0.22
+lib/libossp-uuid++.a
+lib/libossp-uuid++.so
+lib/libossp-uuid++.so.16
+lib/libossp-uuid++.so.16.0.22
+libdata/pkgconfig/ossp-uuid.pc
man/man1/uuid-config.1.gz
man/man1/uuid.1.gz
-man/man3/uuid++.3.gz
-man/man3/uuid.3.gz
+man/man3/ossp-uuid++.3.gz
+man/man3/ossp-uuid.3.gz