aboutsummaryrefslogtreecommitdiff
path: root/misc/otter
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-19 16:07:57 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-19 16:07:57 +0000
commit92d22b04c41e7c0aa307953e10256945dfc39869 (patch)
treed152353a30cc2422890a055cb69dcd1fec20bf27 /misc/otter
parentec24314382e9d548d79ffd2b71ad33931d37e292 (diff)
downloadports-92d22b04c41e7c0aa307953e10256945dfc39869.tar.gz
ports-92d22b04c41e7c0aa307953e10256945dfc39869.zip
Stagify.
Approved by: portmgr@
Notes
Notes: svn path=/head/; revision=358437
Diffstat (limited to 'misc/otter')
-rw-r--r--misc/otter/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/misc/otter/Makefile b/misc/otter/Makefile
index 077a9888f733..02b2e9a7077b 100644
--- a/misc/otter/Makefile
+++ b/misc/otter/Makefile
@@ -17,7 +17,6 @@ PORTDOCS= README anldp.pdf mace2.pdf otter33.pdf
OPTIONS_DEFINE= DOCS EXAMPLES
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -31,15 +30,15 @@ post-patch:
${WRKSRC}/mace2/Makefile
do-install:
- ${INSTALL_PROGRAM} ${PROGRAMS:S,^,${WRKSRC}/bin/,} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${PROGRAMS:S,^,${WRKSRC}/bin/,} ${STAGEDIR}${PREFIX}/bin
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/documents/,} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/documents/,} ${STAGEDIR}${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR} ${PREFIX}/share/examples/mace2
- (cd ${WRKSRC}/examples; ${PAX} -rw . ${EXAMPLESDIR})
- (cd ${WRKSRC}/examples-mace2; ${PAX} -rw . ${PREFIX}/share/examples/mace2)
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR} ${STAGEDIR}${PREFIX}/share/examples/mace2
+ (cd ${WRKSRC}/examples; ${PAX} -rw . ${STAGEDIR}${EXAMPLESDIR})
+ (cd ${WRKSRC}/examples-mace2; ${PAX} -rw . ${STAGEDIR}${PREFIX}/share/examples/mace2)
.endif
.include <bsd.port.mk>