aboutsummaryrefslogtreecommitdiff
path: root/misc/p5-Array-FileReader/Makefile
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2011-02-23 11:20:30 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2011-02-23 11:20:30 +0000
commit5c12602814e1a0c320ffccf0fdc4f4b422b7c72d (patch)
treef28f0d8686ca66d9c014da1472136b8bd6bdebba /misc/p5-Array-FileReader/Makefile
parenta71161db8f5db73d7fd6608a190093cff9c7e831 (diff)
downloadports-5c12602814e1a0c320ffccf0fdc4f4b422b7c72d.tar.gz
ports-5c12602814e1a0c320ffccf0fdc4f4b422b7c72d.zip
Notes
Diffstat (limited to 'misc/p5-Array-FileReader/Makefile')
-rw-r--r--misc/p5-Array-FileReader/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/misc/p5-Array-FileReader/Makefile b/misc/p5-Array-FileReader/Makefile
new file mode 100644
index 000000000000..e5d338a6f46f
--- /dev/null
+++ b/misc/p5-Array-FileReader/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Array-FileReader
+# Date created: 2011/02/20
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Array-FileReader
+PORTVERSION= 0.03
+CATEGORIES= misc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Lazily tie files to arrays for reading
+
+BUILD_DEPENDS= p5-IO>=0:${PORTSDIR}/devel/p5-IO
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Array::FileReader.3
+
+PLIST_FILES= %%SITE_PERL%%/Array/FileReader.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Array/FileReader/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Array/FileReader \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Array \
+ %%SITE_PERL%%/Array
+
+.include <bsd.port.mk>