aboutsummaryrefslogtreecommitdiff
path: root/misc/p5-Bot-Training
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2011-07-24 13:52:32 +0000
committerAndrej Zverev <az@FreeBSD.org>2011-07-24 13:52:32 +0000
commit81e9e7ab7f8ec8549481122d310a55ded57c35a7 (patch)
tree1bb766dd2c040720e0bdc53a7486ba9d17013d4a /misc/p5-Bot-Training
parent5baaaf511909dbc437088920cfab29dac4a16ef5 (diff)
downloadports-81e9e7ab7f8ec8549481122d310a55ded57c35a7.tar.gz
ports-81e9e7ab7f8ec8549481122d310a55ded57c35a7.zip
Markov bots like Hailo and AI::MegaHAL are fun. But to get them working you
either need to train them on existing training material or make your own. Bot::Training provides a pluggable way to install already existing training files via the CPAN. Bot::Training also comes with a command-line interface called bot-training. PR: ports/159034 Submitted by: milki <milki@rescomp.berkeley.edu>
Notes
Notes: svn path=/head/; revision=278239
Diffstat (limited to 'misc/p5-Bot-Training')
-rw-r--r--misc/p5-Bot-Training/Makefile40
-rw-r--r--misc/p5-Bot-Training/distinfo2
-rw-r--r--misc/p5-Bot-Training/pkg-descr8
-rw-r--r--misc/p5-Bot-Training/pkg-plist8
4 files changed, 58 insertions, 0 deletions
diff --git a/misc/p5-Bot-Training/Makefile b/misc/p5-Bot-Training/Makefile
new file mode 100644
index 000000000000..e41e4a84fc79
--- /dev/null
+++ b/misc/p5-Bot-Training/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Bot::Training
+# Date created: 2011-07-19
+# Whom: milki <milki@rescomp.berkeley.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Bot-Training
+PORTVERSION= 0.04
+CATEGORIES= misc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:AVAR
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= milki@rescomp.berkeley.edu
+COMMENT= Plain text training material for bots like Hailo and MegaHAL
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose \
+ p5-Dir-Self>=0:${PORTSDIR}/devel/p5-Dir-Self \
+ p5-File-ShareDir>=0:${PORTSDIR}/devel/p5-File-ShareDir \
+ p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-Module-Pluggable>=0:${PORTSDIR}/devel/p5-Module-Pluggable \
+ p5-Moose>=0.82:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-Getopt>=0:${PORTSDIR}/devel/p5-MooseX-Getopt \
+ p5-Mouse>=0:${PORTSDIR}/devel/p5-Mouse \
+ p5-MouseX-Getopt>=0:${PORTSDIR}/devel/p5-MouseX-Getopt \
+ p5-namespace-clean>=0:${PORTSDIR}/devel/p5-namespace-clean
+
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= 5.10+
+
+MAN1= bot-training.1
+
+MAN3= Bot::Training.3
+
+.include <bsd.port.mk>
diff --git a/misc/p5-Bot-Training/distinfo b/misc/p5-Bot-Training/distinfo
new file mode 100644
index 000000000000..cab5f182f9b3
--- /dev/null
+++ b/misc/p5-Bot-Training/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Bot-Training-0.04.tar.gz) = 462f36e577828f23b90251f39e1ca7b8cab11e48a57353b1f66b612698d78bed
+SIZE (Bot-Training-0.04.tar.gz) = 12571
diff --git a/misc/p5-Bot-Training/pkg-descr b/misc/p5-Bot-Training/pkg-descr
new file mode 100644
index 000000000000..99ba1a540609
--- /dev/null
+++ b/misc/p5-Bot-Training/pkg-descr
@@ -0,0 +1,8 @@
+Markov bots like Hailo and AI::MegaHAL are fun. But to get them working you
+either need to train them on existing training material or make your own.
+
+Bot::Training provides a pluggable way to install already existing training
+files via the CPAN. Bot::Training also comes with a command-line interface
+called bot-training.
+
+WWW: http://search.cpan.org/dist/Bot-Training/
diff --git a/misc/p5-Bot-Training/pkg-plist b/misc/p5-Bot-Training/pkg-plist
new file mode 100644
index 000000000000..f76d066c669d
--- /dev/null
+++ b/misc/p5-Bot-Training/pkg-plist
@@ -0,0 +1,8 @@
+bin/bot-training
+%%SITE_PERL%%/Bot/Training.pm
+%%SITE_PERL%%/Bot/Training/Plugin.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Bot/Training/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Bot/Training
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Bot
+@dirrmtry %%SITE_PERL%%/Bot/Training
+@dirrmtry %%SITE_PERL%%/Bot