aboutsummaryrefslogtreecommitdiff
path: root/misc/p5-Business-Hours
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-11-12 15:01:50 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-11-12 15:01:50 +0000
commitacdd133feed202a272c3f549426f5bc560ecd957 (patch)
tree6aa56bbb8b7270f0934304c49accf154e2646435 /misc/p5-Business-Hours
parent0b5b23213b7a4a9657b22fe879ac138970161013 (diff)
downloadports-acdd133feed202a272c3f549426f5bc560ecd957.tar.gz
ports-acdd133feed202a272c3f549426f5bc560ecd957.zip
This module is a simple tool for calculating business hours in a time
period. Over time, additional functionality will be added to make it easy to calculate the number of business hours between arbitrary dates. PR: ports/126778 Submitted by: Matthew Seaman <m.seaman@infracaninophile.co.uk>
Notes
Notes: svn path=/head/; revision=222770
Diffstat (limited to 'misc/p5-Business-Hours')
-rw-r--r--misc/p5-Business-Hours/Makefile24
-rw-r--r--misc/p5-Business-Hours/distinfo3
-rw-r--r--misc/p5-Business-Hours/pkg-descr6
-rw-r--r--misc/p5-Business-Hours/pkg-plist5
4 files changed, 38 insertions, 0 deletions
diff --git a/misc/p5-Business-Hours/Makefile b/misc/p5-Business-Hours/Makefile
new file mode 100644
index 000000000000..ee9642cb88c3
--- /dev/null
+++ b/misc/p5-Business-Hours/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Business-Hours
+# Date created: 23 August 2008
+# Whom: Matthew Seaman <m.seaman@infracaninophile.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Business-Hours
+PORTVERSION= 0.08
+CATEGORIES= misc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m.seaman@infracaninophile.co.uk
+COMMENT= Calculate business hours during a time period
+
+BUILD_DEPENDS= ${SITE_PERL}/Set/IntSpan.pm:${PORTSDIR}/math/p5-Set-IntSpan
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Business::Hours.3
+
+.include <bsd.port.mk>
diff --git a/misc/p5-Business-Hours/distinfo b/misc/p5-Business-Hours/distinfo
new file mode 100644
index 000000000000..2abf6b27d951
--- /dev/null
+++ b/misc/p5-Business-Hours/distinfo
@@ -0,0 +1,3 @@
+MD5 (Business-Hours-0.08.tar.gz) = 047ea5e498f73cc2c023c250a612aaea
+SHA256 (Business-Hours-0.08.tar.gz) = ee95277d17ed399439eb97313ebf56eb43cd86fc58e6834c3ea13fd233bc632f
+SIZE (Business-Hours-0.08.tar.gz) = 13892
diff --git a/misc/p5-Business-Hours/pkg-descr b/misc/p5-Business-Hours/pkg-descr
new file mode 100644
index 000000000000..e560e2e8fbda
--- /dev/null
+++ b/misc/p5-Business-Hours/pkg-descr
@@ -0,0 +1,6 @@
+This module is a simple tool for calculating business hours in a time
+period. Over time, additional functionality will be added to make it
+easy to calculate the number of business hours between arbitrary
+dates.
+
+WWW: http://search.cpan.org/perldoc?Business::Hours
diff --git a/misc/p5-Business-Hours/pkg-plist b/misc/p5-Business-Hours/pkg-plist
new file mode 100644
index 000000000000..f6819be4142e
--- /dev/null
+++ b/misc/p5-Business-Hours/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/Hours/.packlist
+%%SITE_PERL%%/Business/Hours.pm
+@dirrmtry %%SITE_PERL%%/Business
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/Hours
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business