aboutsummaryrefslogtreecommitdiff
path: root/misc/p5-I18N-LangTags
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-24 09:57:15 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-24 09:57:15 +0000
commitd34c91c4e566601bd0c100130f4cde449e935243 (patch)
tree75c626d6fa4cc840d2fe08d977c6808c252f8bea /misc/p5-I18N-LangTags
parent0bd90a15a505c9d85cfcd8a466bec3e5476a86b5 (diff)
downloadports-d34c91c4e566601bd0c100130f4cde449e935243.tar.gz
ports-d34c91c4e566601bd0c100130f4cde449e935243.zip
- Fix perl syntax with perl 5.24+
- While here, fix typo in documentation PR: 190531 Submitted by: vess@slavof.net Approved by: maintainer timeout (daemon, 2.5 years) MFH: 2016Q4
Notes
Notes: svn path=/head/; revision=426998
Diffstat (limited to 'misc/p5-I18N-LangTags')
-rw-r--r--misc/p5-I18N-LangTags/Makefile2
-rw-r--r--misc/p5-I18N-LangTags/files/patch-lib_I18N_LangTags.pm11
-rw-r--r--misc/p5-I18N-LangTags/files/patch-lib_I18N_LangTags_Detect.pm11
3 files changed, 23 insertions, 1 deletions
diff --git a/misc/p5-I18N-LangTags/Makefile b/misc/p5-I18N-LangTags/Makefile
index 3c55999c43eb..dceb9319386c 100644
--- a/misc/p5-I18N-LangTags/Makefile
+++ b/misc/p5-I18N-LangTags/Makefile
@@ -3,7 +3,7 @@
PORTNAME= I18N-LangTags
PORTVERSION= 0.35
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/misc/p5-I18N-LangTags/files/patch-lib_I18N_LangTags.pm b/misc/p5-I18N-LangTags/files/patch-lib_I18N_LangTags.pm
new file mode 100644
index 000000000000..3d45888ff9ea
--- /dev/null
+++ b/misc/p5-I18N-LangTags/files/patch-lib_I18N_LangTags.pm
@@ -0,0 +1,11 @@
+--- lib/I18N/LangTags.pm.orig 2004-10-07 07:26:33 UTC
++++ lib/I18N/LangTags.pm
+@@ -489,7 +489,7 @@ lookup in %greetings fails. That's the
+ You could instead do lookups on $wanted with:
+
+ use I18N::LangTags qw(same_language_tag);
+- my $repsonse = '';
++ my $response = '';
+ foreach my $l2 (keys %greetings) {
+ if(same_language_tag($wanted, $l2)) {
+ $response = $greetings{$l2};
diff --git a/misc/p5-I18N-LangTags/files/patch-lib_I18N_LangTags_Detect.pm b/misc/p5-I18N-LangTags/files/patch-lib_I18N_LangTags_Detect.pm
new file mode 100644
index 000000000000..bedb02d6bb29
--- /dev/null
+++ b/misc/p5-I18N-LangTags/files/patch-lib_I18N_LangTags_Detect.pm
@@ -0,0 +1,11 @@
+--- lib/I18N/LangTags/Detect.pm.orig 2004-06-21 05:47:55 UTC
++++ lib/I18N/LangTags/Detect.pm
+@@ -137,7 +137,7 @@ sub _try_use { # Basically a wrapper a
+ my $module = $_[0]; # ASSUME sane module name!
+ { no strict 'refs';
+ return($tried{$module} = 1)
+- if defined(%{$module . "::Lexicon"}) or defined(@{$module . "::ISA"});
++ if %{$module . "::Lexicon"} or @{$module . "::ISA"};
+ # weird case: we never use'd it, but there it is!
+ }
+