aboutsummaryrefslogtreecommitdiff
path: root/misc/pastebinit
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2013-09-25 18:17:57 +0000
committerEitan Adler <eadler@FreeBSD.org>2013-09-25 18:17:57 +0000
commit6a26e6b45ebf9a3fa37d03be2df2a55fea9fb1f0 (patch)
tree466bc7849bf49a88f438cbaca1a9eaabc84d3a6f /misc/pastebinit
parentb8ef32ac23bcfc1162f39ef439e689ad07f46a57 (diff)
downloadports-6a26e6b45ebf9a3fa37d03be2df2a55fea9fb1f0.tar.gz
ports-6a26e6b45ebf9a3fa37d03be2df2a55fea9fb1f0.zip
Convert pastebinit to have STAGEDIR support.
Tested with poudriere
Notes
Notes: svn path=/head/; revision=328304
Diffstat (limited to 'misc/pastebinit')
-rw-r--r--misc/pastebinit/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/misc/pastebinit/Makefile b/misc/pastebinit/Makefile
index 02447f1ab836..124c4c7f4d09 100644
--- a/misc/pastebinit/Makefile
+++ b/misc/pastebinit/Makefile
@@ -22,7 +22,6 @@ OPTIONS_DEFINE= PASTEBINS
PASTEBINS_DESC= Install default pastebins
OPTIONS_DEFAULT= PASTEBINS
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPASTEBINS}
@@ -33,9 +32,9 @@ post-patch:
${REINPLACE_CMD} -e 's|/usr/share/pastebin.d|${DATADIR}/pastebin.d|' \
${WRKSRC}/pastebinit
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.if ${PORT_OPTIONS:MPASTEBINS}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} pastebin.d ${DATADIR})
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} pastebin.d ${STAGEDIR}${DATADIR})
.endif
.include <bsd.port.mk>