aboutsummaryrefslogtreecommitdiff
path: root/misc/pear-Services_Weather
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-04-06 19:18:58 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-04-06 19:18:58 +0000
commit27119b19bc4bbd75e1a190b41cb033bd53911b27 (patch)
tree85f0eaff3ac5a0ae64181bef492916dbbfddfbfe /misc/pear-Services_Weather
parent2d9d696bc72e43e8b8933ff8d2025b8ce660e892 (diff)
downloadports-27119b19bc4bbd75e1a190b41cb033bd53911b27.tar.gz
ports-27119b19bc4bbd75e1a190b41cb033bd53911b27.zip
Add pear-Services_Weather 1.2.2, PEAR interface to various
online weather-services. It will be used by Horde-3, for Jonah. Approved by: pav (mentor).
Notes
Notes: svn path=/head/; revision=106347
Diffstat (limited to 'misc/pear-Services_Weather')
-rw-r--r--misc/pear-Services_Weather/Makefile43
-rw-r--r--misc/pear-Services_Weather/distinfo2
-rw-r--r--misc/pear-Services_Weather/pkg-descr8
3 files changed, 53 insertions, 0 deletions
diff --git a/misc/pear-Services_Weather/Makefile b/misc/pear-Services_Weather/Makefile
new file mode 100644
index 000000000000..c8e529f94f11
--- /dev/null
+++ b/misc/pear-Services_Weather/Makefile
@@ -0,0 +1,43 @@
+# Ports collection makefile for: pear-Services_Weather
+# Date created: 04 April 2004
+# Whom: Thierry Thomas (<thierry@FreeBSD.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Services_Weather
+PORTVERSION= 1.2.2
+CATEGORIES= misc www pear
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PEAR interface to various online weather-services
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.if !defined (WITHOUT_CACHE)
+BUILD_DEPENDS+= ${PEARDIR}/Cache/Cache.php:${PORTSDIR}/sysutils/pear-Cache
+.endif
+.if !defined (WITHOUT_DB)
+BUILD_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+.endif
+.if !defined (WITHOUT_HTTPR)
+BUILD_DEPENDS+= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
+.endif
+.if !defined (WITHOUT_SERIALIZER)
+BUILD_DEPENDS+= ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer
+.endif
+.if !defined (WITHOUT_SOAP)
+BUILD_DEPENDS+= ${PEARDIR}/SOAP/Base.php:${PORTSDIR}/net/pear-SOAP
+.endif
+
+CATEGORY= Services
+FILES= Weather.php Weather/Common.php Weather/Globalweather.php \
+ Weather/Ejse.php Weather/Metar.php Weather/Weatherdotcom.php \
+ buildMetarDB.php
+EXAMPLES= globalweather-basic.php ejse-basic.php metar-basic.php \
+ weather.com-basic.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/misc/pear-Services_Weather/distinfo b/misc/pear-Services_Weather/distinfo
new file mode 100644
index 000000000000..5b81747ace59
--- /dev/null
+++ b/misc/pear-Services_Weather/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Services_Weather-1.2.2.tgz) = e3e202d4bfddfb0fafcf97a4fde08c89
+SIZE (PEAR/Services_Weather-1.2.2.tgz) = 29205
diff --git a/misc/pear-Services_Weather/pkg-descr b/misc/pear-Services_Weather/pkg-descr
new file mode 100644
index 000000000000..0a7b36a687ca
--- /dev/null
+++ b/misc/pear-Services_Weather/pkg-descr
@@ -0,0 +1,8 @@
+Services_Weather searches for given locations and retrieves current
+weather data and, dependent on the used service, also forecasts. Up to
+now, GlobalWeather from CapeScience, Weather XML from EJSE (US only),
+a XOAP service from Weather.com and METAR from noaa.gov are supported.
+Further services will get included, if they become available, have a
+usable API and are properly documented.
+
+WWW: http://pear.php.net/package/Services_Weather