aboutsummaryrefslogtreecommitdiff
path: root/misc/pipe
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-08-23 08:04:45 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-08-23 08:04:45 +0000
commitb4842fa1477e509244df0182cf4ea592d5201679 (patch)
tree085cf939c76cb1505b5085e08f69381e5f4bdfca /misc/pipe
parent72f0037c028be630d33d7dade54ba94e03f3b66f (diff)
downloadports-b4842fa1477e509244df0182cf4ea592d5201679.tar.gz
ports-b4842fa1477e509244df0182cf4ea592d5201679.zip
add pipe beta-1.0
Platform Independent Petri-Net Editor
Notes
Notes: svn path=/head/; revision=117103
Diffstat (limited to 'misc/pipe')
-rw-r--r--misc/pipe/Makefile47
-rw-r--r--misc/pipe/distinfo2
-rw-r--r--misc/pipe/files/pipe3
-rw-r--r--misc/pipe/pkg-descr15
4 files changed, 67 insertions, 0 deletions
diff --git a/misc/pipe/Makefile b/misc/pipe/Makefile
new file mode 100644
index 000000000000..fbf2f1bdbc45
--- /dev/null
+++ b/misc/pipe/Makefile
@@ -0,0 +1,47 @@
+# ex:ts=8
+# Ports collection makefile for: pipe
+# Date created: Feb 9, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= pipe
+PORTVERSION= 0.b.1.0
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= petri-net
+DISTNAME= ${PORTNAME}-beta-1.0
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Platform Independent Petri-Net Editor
+
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/PIPE
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+USE_JAVA= yes
+
+PLIST_FILES= bin/pipe
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-extract:
+ @${SED} 's,%%DATADIR%%,${DATADIR},' ${FILESDIR}/pipe > ${WRKSRC}/pipe
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pipe ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/bin/ ${DATADIR}
+ @${FIND} ${DATADIR} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DATADIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/doc/ ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/pipe/distinfo b/misc/pipe/distinfo
new file mode 100644
index 000000000000..2d88ad098ec9
--- /dev/null
+++ b/misc/pipe/distinfo
@@ -0,0 +1,2 @@
+MD5 (pipe-beta-1.0.zip) = bd9bff57bec23a2e1fdfac61546421a4
+SIZE (pipe-beta-1.0.zip) = 1797504
diff --git a/misc/pipe/files/pipe b/misc/pipe/files/pipe
new file mode 100644
index 000000000000..7c6abae119fe
--- /dev/null
+++ b/misc/pipe/files/pipe
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+java -cp %%DATADIR%% RunGui
diff --git a/misc/pipe/pkg-descr b/misc/pipe/pkg-descr
new file mode 100644
index 000000000000..a91fbef98cf0
--- /dev/null
+++ b/misc/pipe/pkg-descr
@@ -0,0 +1,15 @@
+Petri nets are a popular graphical way of modeling concurrent systems such as
+communications protocols, multiprocessor computers etc. With Petri nets it is
+possible to assess the correctness of systems for example by verifying that
+the system cannot deadlock, that there cannot be any buffer overflows etc.
+
+PIPEs main aim is to improve on existing tools available for modeling Petri
+Nets. A key design feature is the modular approach adopted for analysis,
+enabling new modules to written easily and powerfully, using built-in data
+layer methods for standard calculations. Six analysis modules have been
+written (so far) including Invariant Analysis, State-Space Analysis (deadlock,
+etc), Simulation Analysis & Classification. PIPE adheres to the latest XML
+Petri net standard (PNML). File format for saving and loading Petri-Nets is
+also extensible through the use of XSLT, the default being PNML.
+
+WWW: http://petri-net.sourceforge.net/