aboutsummaryrefslogtreecommitdiff
path: root/misc/py-fuzzy
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2016-12-26 15:18:08 +0000
committerWen Heping <wen@FreeBSD.org>2016-12-26 15:18:08 +0000
commitc6a1d53d4a1511339d2649c36b506c9f534bc908 (patch)
tree1eb85c46b9387762167a4539457055149da4e6ff /misc/py-fuzzy
parentb09044861c485b8419b8043e2b352a55289bee3b (diff)
downloadports-c6a1d53d4a1511339d2649c36b506c9f534bc908.tar.gz
ports-c6a1d53d4a1511339d2649c36b506c9f534bc908.zip
Fuzzy is a python library implementing common phonetic algorithms quickly.
Typically this is in string similarity exercises, but they're pretty versatile. The algorithms are: * Soundex * NYSIIS * Double Metaphone Based on Maurice Aubrey's C code from his perl implementation. WWW: https://pypi.python.org/pypi/Fuzzy PR: 215462 Submitted by: yuri@rawbw.com
Notes
Notes: svn path=/head/; revision=429533
Diffstat (limited to 'misc/py-fuzzy')
-rw-r--r--misc/py-fuzzy/Makefile21
-rw-r--r--misc/py-fuzzy/distinfo3
-rw-r--r--misc/py-fuzzy/pkg-descr9
3 files changed, 33 insertions, 0 deletions
diff --git a/misc/py-fuzzy/Makefile b/misc/py-fuzzy/Makefile
new file mode 100644
index 000000000000..9a6ff807172c
--- /dev/null
+++ b/misc/py-fuzzy/Makefile
@@ -0,0 +1,21 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= Fuzzy
+PORTVERSION= 1.1
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Fast Python phonetic algorithms
+
+LICENSE= MIT ART20
+LICENSE_COMB= multi
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/misc/py-fuzzy/distinfo b/misc/py-fuzzy/distinfo
new file mode 100644
index 000000000000..d8edf087cccf
--- /dev/null
+++ b/misc/py-fuzzy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1482306437
+SHA256 (Fuzzy-1.1.tar.gz) = 57863b9e9aacf82a0b8530ff3b1435cd9b83fe7e526f358eacc366a35eb0cdff
+SIZE (Fuzzy-1.1.tar.gz) = 20006
diff --git a/misc/py-fuzzy/pkg-descr b/misc/py-fuzzy/pkg-descr
new file mode 100644
index 000000000000..2cb9190f3238
--- /dev/null
+++ b/misc/py-fuzzy/pkg-descr
@@ -0,0 +1,9 @@
+Fuzzy is a python library implementing common phonetic algorithms quickly.
+Typically this is in string similarity exercises, but they're pretty versatile.
+The algorithms are:
+* Soundex
+* NYSIIS
+* Double Metaphone Based on Maurice Aubrey's C code from his perl
+ implementation.
+
+WWW: https://pypi.python.org/pypi/Fuzzy