aboutsummaryrefslogtreecommitdiff
path: root/misc/py-gluoncv
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2020-02-24 11:36:15 +0000
committerKai Knoblich <kai@FreeBSD.org>2020-02-24 11:36:15 +0000
commit74174b26616baa21c285c0515b591e7d738c5c0f (patch)
tree1c10419849a595f8ebfa59836f2e676bb7ec3469 /misc/py-gluoncv
parent45b08b671d6459dc7e71950a89cac654920ec089 (diff)
downloadports-74174b26616baa21c285c0515b591e7d738c5c0f.tar.gz
ports-74174b26616baa21c285c0515b591e7d738c5c0f.zip
graphics/py-pillow: Update to 7.0.0
* Repo-Copy the Pillow 6.2.2 release to graphics/py-pillow6 to retain backwards compatibility for Python 2 consumers as the Pillow 7.0.0 release dropped the support for Python 2. * Apply conditional statements to use either Pillow 7.x or Pillow 6.x for consumers that can be built for Python 2 or newer. * Exceptions are ports that can be built only for either Python 2 or Python 3. For the first case, consumers are just assigned to the repo-copied graphics/py-pillow6. * Also remove Pillow from BUILD_DEPENDS of math/py-PyWavelets as it is not listed in setup.py as a build dependency [1] and relax the version requirements of Pillow for www/py-wagtail. Release Notes: * https://pillow.readthedocs.io/en/latest/releasenotes/index.html Backward Incompatible Changes (7.0.0): * https://pillow.readthedocs.io/en/latest/releasenotes/7.0.0.html#backwards-incompatible-changes Detailed Changelog: * https://github.com/python-pillow/Pillow/blob/7.0.0/CHANGES.rst PR: 243665 Submitted by: sunpoet (patch for 7.0.0 and repo-copied version) Reviewed by: koobs [1], sunpoet Approved by: koobs (maintainer) Differential Revision: https://reviews.freebsd.org/D23713
Notes
Notes: svn path=/head/; revision=526962
Diffstat (limited to 'misc/py-gluoncv')
-rw-r--r--misc/py-gluoncv/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/misc/py-gluoncv/Makefile b/misc/py-gluoncv/Makefile
index 7c681f4e3c7d..0edab3279e99 100644
--- a/misc/py-gluoncv/Makefile
+++ b/misc/py-gluoncv/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gluoncv
DISTVERSIONPREFIX= v
DISTVERSION= 0.6.0
+PORTREVISION= 1
CATEGORIES= misc # machine-learning
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,7 +16,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
PY_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mxnet>0:misc/py-mxnet@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}portalocker>0:devel/py-portalocker@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=1.0:science/py-scipy@${PY_FLAVOR} \
@@ -32,10 +32,18 @@ USE_PYTHON= distutils cython autoplist
PYDISTUTILS_BUILDARGS= --with-cython
PYDISTUTILS_INSTALLARGS= --with-cython
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+PY_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
+.else
+PY_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+.endif
+
post-patch: # https://github.com/dmlc/gluon-cv/issues/1095
@truncate -s 0 ${WRKSRC}/README.md
post-install:
@${FIND} ${STAGEDIR}${PREFIX} -name "*.so" | ${XARGS} ${STRIP_CMD}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>