aboutsummaryrefslogtreecommitdiff
path: root/misc/py-onnx
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-03-09 09:19:04 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-03-09 09:32:07 +0000
commit4e155b25b157f12f080a5b3b59b32166f0a291d2 (patch)
treeafa991aa2a31d92a1b5a8d5bd6041bc37106f2a0 /misc/py-onnx
parente77bcad4864d06390a380f8c2e68a2ac2ecbace6 (diff)
downloadports-4e155b25b157f12f080a5b3b59b32166f0a291d2.tar.gz
ports-4e155b25b157f12f080a5b3b59b32166f0a291d2.zip
Diffstat (limited to 'misc/py-onnx')
-rw-r--r--misc/py-onnx/Makefile2
-rw-r--r--misc/py-onnx/distinfo6
-rw-r--r--misc/py-onnx/files/patch-CMakeLists.txt20
-rw-r--r--misc/py-onnx/files/patch-setup.py38
4 files changed, 33 insertions, 33 deletions
diff --git a/misc/py-onnx/Makefile b/misc/py-onnx/Makefile
index 09ffa16f89bb..db19e0edfcb7 100644
--- a/misc/py-onnx/Makefile
+++ b/misc/py-onnx/Makefile
@@ -1,5 +1,5 @@
PORTNAME= onnx
-DISTVERSION= 1.13.0
+DISTVERSION= 1.13.1
CATEGORIES= misc # machine-learning
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/misc/py-onnx/distinfo b/misc/py-onnx/distinfo
index 30db3ac69d2e..db8a8241c7b1 100644
--- a/misc/py-onnx/distinfo
+++ b/misc/py-onnx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1672356068
-SHA256 (onnx-1.13.0.tar.gz) = 410b39950367857f97b65093681fe2495a2e23d63777a8aceaf96c56a16d166e
-SIZE (onnx-1.13.0.tar.gz) = 10376857
+TIMESTAMP = 1678353559
+SHA256 (onnx-1.13.1.tar.gz) = 0bdcc25c2c1ce4a8750e4ffbd93ae945442e7fac6e51176f38e366b74a97dfd9
+SIZE (onnx-1.13.1.tar.gz) = 10405481
diff --git a/misc/py-onnx/files/patch-CMakeLists.txt b/misc/py-onnx/files/patch-CMakeLists.txt
index 61d9f650f002..7444f85f429d 100644
--- a/misc/py-onnx/files/patch-CMakeLists.txt
+++ b/misc/py-onnx/files/patch-CMakeLists.txt
@@ -1,11 +1,11 @@
---- CMakeLists.txt.orig 2022-11-17 13:03:00 UTC
+--- CMakeLists.txt.orig 2023-02-22 16:34:35 UTC
+++ CMakeLists.txt
-@@ -18,7 +18,7 @@ project(onnx C CXX)
- option(ONNX_BUILD_BENCHMARKS "Build ONNX micro-benchmarks" OFF)
- option(ONNX_USE_PROTOBUF_SHARED_LIBS "Build ONNX using protobuf shared library. Sets PROTOBUF_USE_DLLS CMAKE Flag and Protobuf_USE_STATIC_LIBS. " OFF)
-
--option(BUILD_ONNX_PYTHON "Build Python binaries" OFF)
-+option(BUILD_ONNX_PYTHON "Build Python binaries" ON)
- option(ONNX_GEN_PB_TYPE_STUBS "Generate protobuf python type stubs" ON)
- option(ONNX_WERROR "Build with Werror" OFF)
- option(ONNX_COVERAGE "Build with coverage instrumentation" OFF)
+@@ -18,7 +18,7 @@ project(onnx C CXX)
+ option(ONNX_BUILD_BENCHMARKS "Build ONNX micro-benchmarks" OFF)
+ option(ONNX_USE_PROTOBUF_SHARED_LIBS "Build ONNX using protobuf shared library. Sets PROTOBUF_USE_DLLS CMAKE Flag and Protobuf_USE_STATIC_LIBS. " OFF)
+
+-option(BUILD_ONNX_PYTHON "Build Python binaries" OFF)
++option(BUILD_ONNX_PYTHON "Build Python binaries" ON)
+ option(ONNX_GEN_PB_TYPE_STUBS "Generate protobuf python type stubs" ON)
+ option(ONNX_WERROR "Build with Werror" OFF)
+ option(ONNX_COVERAGE "Build with coverage instrumentation" OFF)
diff --git a/misc/py-onnx/files/patch-setup.py b/misc/py-onnx/files/patch-setup.py
index 55535f2d925f..b20306abb9fb 100644
--- a/misc/py-onnx/files/patch-setup.py
+++ b/misc/py-onnx/files/patch-setup.py
@@ -1,20 +1,20 @@
---- setup.py.orig 2022-11-09 10:56:10 UTC
+--- setup.py.orig 2023-02-22 16:34:50 UTC
+++ setup.py
-@@ -56,11 +56,12 @@ COVERAGE = bool(os.getenv("COVERAGE", "0") == "1")
- ################################################################################
-
- try:
-- git_version = (
-- subprocess.check_output(["git", "rev-parse", "HEAD"], cwd=TOP_DIR)
-- .decode("ascii")
-- .strip()
-- )
-+ #git_version = (
-+ # subprocess.check_output(["git", "rev-parse", "HEAD"], cwd=TOP_DIR)
-+ # .decode("ascii")
-+ # .strip()
-+ #)
-+ git_version = None
- except (OSError, subprocess.CalledProcessError):
- git_version = None
-
+@@ -56,11 +56,12 @@ COVERAGE = bool(os.getenv("COVERAGE", "0") == "1")
+ ################################################################################
+
+ try:
+- git_version = (
+- subprocess.check_output(["git", "rev-parse", "HEAD"], cwd=TOP_DIR)
+- .decode("ascii")
+- .strip()
+- )
++ #git_version = (
++ # subprocess.check_output(["git", "rev-parse", "HEAD"], cwd=TOP_DIR)
++ # .decode("ascii")
++ # .strip()
++ #)
++ git_version = None
+ except (OSError, subprocess.CalledProcessError):
+ git_version = None
+