aboutsummaryrefslogtreecommitdiff
path: root/misc/py-onnx
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-02-01 07:02:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-02-01 07:02:37 +0000
commit619db12ab32649a11909c185a1744f160994881f (patch)
tree5b235902b4eff683621be95035a2c918775a6c23 /misc/py-onnx
parent2ed54c01f872bdd5bdde359d05ca28f205795800 (diff)
downloadports-619db12ab32649a11909c185a1744f160994881f.tar.gz
ports-619db12ab32649a11909c185a1744f160994881f.zip
misc/py-onnx: Update 1.8.0 -> 1.8.1
Reported by: portscout
Notes
Notes: svn path=/head/; revision=563553
Diffstat (limited to 'misc/py-onnx')
-rw-r--r--misc/py-onnx/Makefile13
-rw-r--r--misc/py-onnx/distinfo6
-rw-r--r--misc/py-onnx/files/patch-CMakeLists.txt11
-rw-r--r--misc/py-onnx/files/patch-setup.py4
4 files changed, 24 insertions, 10 deletions
diff --git a/misc/py-onnx/Makefile b/misc/py-onnx/Makefile
index 4e5a08306211..9bbf8fa13f01 100644
--- a/misc/py-onnx/Makefile
+++ b/misc/py-onnx/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= onnx
-DISTVERSION= 1.8.0
-PORTREVISION= 1
+DISTVERSION= 1.8.1
CATEGORIES= misc # machine-learning
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,16 +12,20 @@ COMMENT= Open Neural Network eXchange
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= cmake:devel/cmake \
+BUILD_DEPENDS= bash:shells/bash \
+ cmake:devel/cmake \
+ protoc-gen-mypy:devel/py-mypy-protobuf@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-runner>=0:devel/py-pytest-runner@${PY_FLAVOR}
LIB_DEPENDS= libprotobuf.so:devel/protobuf
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}typing-extensions>0:devel/py-typing-extensions@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.6.2.1:devel/py-typing-extensions@${PY_FLAVOR}
-USES= compiler:c11 python:3.6+
+USES= compiler:c11 python:3.6+ shebangfix
USE_PYTHON= distutils concurrent autoplist
+SHEBANG_FILES= tools/protoc-gen-mypy.sh.in
+
BINARY_ALIAS= python=${PYTHON_CMD}
post-install:
diff --git a/misc/py-onnx/distinfo b/misc/py-onnx/distinfo
index 0f4a44acb7cb..81c32cdf9092 100644
--- a/misc/py-onnx/distinfo
+++ b/misc/py-onnx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1604851394
-SHA256 (onnx-1.8.0.tar.gz) = 5f787fd3ce1290e12da335237b3b921152157e51aa09080b65631b3ce3fcc50c
-SIZE (onnx-1.8.0.tar.gz) = 5231652
+TIMESTAMP = 1612156758
+SHA256 (onnx-1.8.1.tar.gz) = 9d65c52009a90499f8c25fdfe5acda3ac88efe0788eb1d5f2575a989277145fb
+SIZE (onnx-1.8.1.tar.gz) = 5232742
diff --git a/misc/py-onnx/files/patch-CMakeLists.txt b/misc/py-onnx/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..e77008ab5907
--- /dev/null
+++ b/misc/py-onnx/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2021-02-01 05:41:35 UTC
++++ CMakeLists.txt
+@@ -18,7 +18,7 @@ project(onnx C CXX)
+ option(ONNX_BUILD_BENCHMARKS "Build ONNX micro-benchmarks" OFF)
+ option(ONNX_USE_PROTOBUF_SHARED_LIBS "Build ONNX using protobuf shared library. Sets PROTOBUF_USE_DLLS CMAKE Flag " OFF)
+
+-option(BUILD_ONNX_PYTHON "Build Python binaries" OFF)
++option(BUILD_ONNX_PYTHON "Build Python binaries" ON)
+ option(ONNX_GEN_PB_TYPE_STUBS "Generate protobuf python type stubs" ON)
+ option(ONNX_WERROR "Build with Werror" OFF)
+ option(ONNX_COVERAGE "Build with coverage instrumentation" OFF)
diff --git a/misc/py-onnx/files/patch-setup.py b/misc/py-onnx/files/patch-setup.py
index df42cf36aae3..abdc4806c19b 100644
--- a/misc/py-onnx/files/patch-setup.py
+++ b/misc/py-onnx/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2019-09-25 20:37:27 UTC
+--- setup.py.orig 2021-01-29 23:31:55 UTC
+++ setup.py
-@@ -53,11 +53,12 @@ COVERAGE = bool(os.getenv('COVERAGE'))
+@@ -56,11 +56,12 @@ COVERAGE = bool(os.getenv('COVERAGE'))
# Version
################################################################################