aboutsummaryrefslogtreecommitdiff
path: root/misc/py-onnx
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-05-23 20:55:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-05-23 20:55:15 +0000
commitc9223e83d4a42b4d6b32a5dbee7acb53afce9e36 (patch)
tree67a2d5f540abe0aa15a9bd4c29a81248a9ea6433 /misc/py-onnx
parent48ae4c17937eeb437f12ff698bb363c6bbf3aa46 (diff)
downloadports-c9223e83d4a42b4d6b32a5dbee7acb53afce9e36.tar.gz
ports-c9223e83d4a42b4d6b32a5dbee7acb53afce9e36.zip
Move math/py-onnx -> misc/py-onnx because it isn't a math package, rather a machine learning package
Notes
Notes: svn path=/head/; revision=536346
Diffstat (limited to 'misc/py-onnx')
-rw-r--r--misc/py-onnx/Makefile31
-rw-r--r--misc/py-onnx/distinfo3
-rw-r--r--misc/py-onnx/files/patch-setup.py20
-rw-r--r--misc/py-onnx/pkg-descr14
4 files changed, 68 insertions, 0 deletions
diff --git a/misc/py-onnx/Makefile b/misc/py-onnx/Makefile
new file mode 100644
index 000000000000..8c82ec1afab8
--- /dev/null
+++ b/misc/py-onnx/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= onnx
+DISTVERSION= 1.7.0
+CATEGORIES= misc # machine-learning
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Open Neural Network eXchange
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= cmake:devel/cmake \
+ ${PYTHON_PKGNAMEPREFIX}pytest-runner>=0:devel/py-pytest-runner@${PY_FLAVOR}
+LIB_DEPENDS= libprotobuf.so:devel/protobuf
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
+ ${PY_TYPING} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>0:devel/py-typing-extensions@${PY_FLAVOR}
+
+USES= compiler:c11 python
+USE_PYTHON= distutils concurrent autoplist
+
+BINARY_ALIAS= python=${PYTHON_CMD}
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/onnx/onnx_cpp2py_export.so
+
+.include <bsd.port.mk>
diff --git a/misc/py-onnx/distinfo b/misc/py-onnx/distinfo
new file mode 100644
index 000000000000..095d36da3feb
--- /dev/null
+++ b/misc/py-onnx/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1589652742
+SHA256 (onnx-1.7.0.tar.gz) = 5e7abaaf71c9403354c406cf20975c1499399247e1f98b5a446a700d977bd948
+SIZE (onnx-1.7.0.tar.gz) = 5479406
diff --git a/misc/py-onnx/files/patch-setup.py b/misc/py-onnx/files/patch-setup.py
new file mode 100644
index 000000000000..df42cf36aae3
--- /dev/null
+++ b/misc/py-onnx/files/patch-setup.py
@@ -0,0 +1,20 @@
+--- setup.py.orig 2019-09-25 20:37:27 UTC
++++ setup.py
+@@ -53,11 +53,12 @@ COVERAGE = bool(os.getenv('COVERAGE'))
+ # Version
+ ################################################################################
+
+-try:
+- git_version = subprocess.check_output(['git', 'rev-parse', 'HEAD'],
+- cwd=TOP_DIR).decode('ascii').strip()
+-except (OSError, subprocess.CalledProcessError):
+- git_version = None
++#try:
++# git_version = subprocess.check_output(['git', 'rev-parse', 'HEAD'],
++# cwd=TOP_DIR).decode('ascii').strip()
++#except (OSError, subprocess.CalledProcessError):
++# git_version = None
++git_version = None
+
+ with open(os.path.join(TOP_DIR, 'VERSION_NUMBER')) as version_file:
+ VersionInfo = namedtuple('VersionInfo', ['version', 'git_version'])(
diff --git a/misc/py-onnx/pkg-descr b/misc/py-onnx/pkg-descr
new file mode 100644
index 000000000000..cb61902666c8
--- /dev/null
+++ b/misc/py-onnx/pkg-descr
@@ -0,0 +1,14 @@
+Open Neural Network Exchange (ONNX) is an open ecosystem that empowers AI
+developers to choose the right tools as their project evolves. ONNX provides an
+open source format for AI models, both deep learning and traditional ML. It
+defines an extensible computation graph model, as well as definitions of
+built-in operators and standard data types. Currently we focus on the
+capabilities needed for inferencing (scoring).
+
+ONNX is widely supported and can be found in many frameworks, tools, and
+hardware. Enabling interoperability between different frameworks and
+streamlining the path from research to production helps increase the speed of
+innovation in the AI community. We invite the community to join us and further
+evolve ONNX.
+
+WWW: https://onnx.ai/