aboutsummaryrefslogtreecommitdiff
path: root/misc/py-progressbar231
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2015-07-14 01:51:23 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2015-07-14 01:51:23 +0000
commitcb76938c43181cd70475dddebca6848e93b694b9 (patch)
tree0f292258ff0ce945ee0565a7c11ca05f76946f79 /misc/py-progressbar231
parentf23aae075b6b2b443d9e0486828d9cc36794bf40 (diff)
downloadports-cb76938c43181cd70475dddebca6848e93b694b9.tar.gz
ports-cb76938c43181cd70475dddebca6848e93b694b9.zip
Notes
Diffstat (limited to 'misc/py-progressbar231')
-rw-r--r--misc/py-progressbar231/Makefile19
-rw-r--r--misc/py-progressbar231/distinfo2
-rw-r--r--misc/py-progressbar231/pkg-descr16
3 files changed, 37 insertions, 0 deletions
diff --git a/misc/py-progressbar231/Makefile b/misc/py-progressbar231/Makefile
new file mode 100644
index 000000000000..8daaa003af17
--- /dev/null
+++ b/misc/py-progressbar231/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= progressbar231
+PORTVERSION= 2.3.1
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wg@FreeBSD.org
+COMMENT= Text progressbar library for python
+
+LICENSE= BSD3CLAUSE
+
+USE_PYTHON= autoplist distutils
+USES= python:2
+
+CONFLICTS= py*-progressbar
+
+.include <bsd.port.mk>
diff --git a/misc/py-progressbar231/distinfo b/misc/py-progressbar231/distinfo
new file mode 100644
index 000000000000..4cc91e326d9d
--- /dev/null
+++ b/misc/py-progressbar231/distinfo
@@ -0,0 +1,2 @@
+SHA256 (progressbar231-2.3.1.tar.gz) = 55b5e5c6b0077b21d14cf2166f3ee74758f89ec75175a6fce4e3f78366771148
+SIZE (progressbar231-2.3.1.tar.gz) = 10402
diff --git a/misc/py-progressbar231/pkg-descr b/misc/py-progressbar231/pkg-descr
new file mode 100644
index 000000000000..2b2cf048736f
--- /dev/null
+++ b/misc/py-progressbar231/pkg-descr
@@ -0,0 +1,16 @@
+This library provides a text mode progressbar. This is typically
+used to display the progress of a long running operation, providing
+a visual clue that processing is underway.
+
+The ProgressBar class manages the progress, and the format of the
+line is given by a number of widgets. A widget is an object that
+may display diferently depending on the state of the progress.
+
+There are three types of widget:
+- a string, which always shows itself;
+- a ProgressBarWidget, which may return a diferent value every time
+ it's update method is called; and
+- a ProgressBarWidgetHFill, which is like ProgressBarWidget, except
+ it expands to fill the remaining width of the line.
+
+WWW: https://pypi.python.org/pypi/progressbar231