aboutsummaryrefslogtreecommitdiff
path: root/misc/sdformat
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-11-21 02:16:51 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-11-21 02:16:51 +0000
commit83cc2744ce11286728a5dc475c58528e7ed253d3 (patch)
tree54c11046b0a4c690beb471f0953b4a80a64d70b8 /misc/sdformat
parent2e9b591646f3f3f262a8f1fd9ee6d79d97f1721f (diff)
downloadports-83cc2744ce11286728a5dc475c58528e7ed253d3.tar.gz
ports-83cc2744ce11286728a5dc475c58528e7ed253d3.zip
New port: misc/sdformat: Simulation Description Format (SDF) parser and description files
Notes
Notes: svn path=/head/; revision=485493
Diffstat (limited to 'misc/sdformat')
-rw-r--r--misc/sdformat/Makefile40
-rw-r--r--misc/sdformat/distinfo3
-rw-r--r--misc/sdformat/files/patch-CMakeLists.txt24
-rw-r--r--misc/sdformat/files/patch-cmake_SDFUtils.cmake17
-rw-r--r--misc/sdformat/files/patch-cmake_SearchForStuff.cmake34
-rw-r--r--misc/sdformat/files/patch-src_CMakeLists.txt13
-rw-r--r--misc/sdformat/pkg-descr9
-rw-r--r--misc/sdformat/pkg-plist387
8 files changed, 527 insertions, 0 deletions
diff --git a/misc/sdformat/Makefile b/misc/sdformat/Makefile
new file mode 100644
index 000000000000..336c9e54ab83
--- /dev/null
+++ b/misc/sdformat/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= sdformat
+DISTVERSION= 8.0.0
+CATEGORIES= misc
+MASTER_SITES= https://bitbucket.org/${BB_ACCOUNT}/${BB_PROJECT}/get/${BB_COMMIT}.tar.gz?dummy=/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Simulation Description Format (SDF) parser and description files
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= ignition-cmake==2:devel/ignition-cmake \
+ ignition-tools>0:devel/ignition-tools
+LIB_DEPENDS= libignition-math6.so:math/ignition-math \
+ libconsole_bridge.so:misc/console-bridge \
+ libtinyxml2.so:textproc/tinyxml2 \
+ liburdfdom_world.so:misc/urdfdom
+RUN_DEPENDS= ignition-tools>0:devel/ignition-tools
+
+USES= cmake:outsource compiler:c++17-lang pkgconfig
+USE_LDCONFIG= yes
+
+CMAKE_OFF= BUILD_TESTING
+
+BB_ACCOUNT= osrf
+BB_PROJECT= ${PORTNAME}
+BB_COMMIT= f555f9a69f8f
+
+WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${BB_PROJECT}-${BB_COMMIT}
+
+PLIST_SUB+= INCSUBDIR=${PORTNAME}-${DISTVERSION:R}
+
+do-test:
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DBUILD_TESTING:BOOL=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
+.include <bsd.port.mk>
diff --git a/misc/sdformat/distinfo b/misc/sdformat/distinfo
new file mode 100644
index 000000000000..878b3cd92019
--- /dev/null
+++ b/misc/sdformat/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1542759199
+SHA256 (sdformat-8.0.0.tar.gz) = 0d06d7da98bcfd33797affcae6407f507216903d4f6623eae16e0d241c84b53b
+SIZE (sdformat-8.0.0.tar.gz) = 687727
diff --git a/misc/sdformat/files/patch-CMakeLists.txt b/misc/sdformat/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..bd104cff46d7
--- /dev/null
+++ b/misc/sdformat/files/patch-CMakeLists.txt
@@ -0,0 +1,24 @@
+--- CMakeLists.txt.orig 2018-11-21 00:21:52 UTC
++++ CMakeLists.txt
+@@ -4,7 +4,9 @@ if(COMMAND CMAKE_POLICY)
+ CMAKE_POLICY(SET CMP0003 NEW)
+ CMAKE_POLICY(SET CMP0004 NEW)
+ endif(COMMAND CMAKE_POLICY)
+-enable_testing()
++if (BUILD_TESTING)
++ enable_testing()
++endif()
+
+ # with -fPIC
+ if(UNIX AND NOT WIN32)
+@@ -256,7 +258,9 @@ else (build_errors)
+
+ link_directories(${PROJECT_BINARY_DIR}/src)
+
+- add_subdirectory(test)
++ if (BUILD_TESTING)
++ add_subdirectory(test)
++ endif()
+ add_subdirectory(src)
+ add_subdirectory(include/sdf)
+ add_subdirectory(sdf)
diff --git a/misc/sdformat/files/patch-cmake_SDFUtils.cmake b/misc/sdformat/files/patch-cmake_SDFUtils.cmake
new file mode 100644
index 000000000000..87a044438f48
--- /dev/null
+++ b/misc/sdformat/files/patch-cmake_SDFUtils.cmake
@@ -0,0 +1,17 @@
+--- cmake/SDFUtils.cmake.orig 2018-11-21 00:24:14 UTC
++++ cmake/SDFUtils.cmake
+@@ -148,9 +148,11 @@ macro (sdf_build_tests)
+ message(FATAL_ERROR "Unsupported platform")
+ endif()
+
+- add_dependencies(${BINARY_NAME}
+- gtest gtest_main ${sdf_target}
+- )
++ if (BUILD_TESTING)
++ add_dependencies(${BINARY_NAME}
++ gtest gtest_main ${sdf_target}
++ )
++ endif()
+
+ link_directories(${IGNITION-MATH_LIBRARY_DIRS})
+
diff --git a/misc/sdformat/files/patch-cmake_SearchForStuff.cmake b/misc/sdformat/files/patch-cmake_SearchForStuff.cmake
new file mode 100644
index 000000000000..f302a1ebac69
--- /dev/null
+++ b/misc/sdformat/files/patch-cmake_SearchForStuff.cmake
@@ -0,0 +1,34 @@
+--- cmake/SearchForStuff.cmake.orig 2018-11-21 00:19:13 UTC
++++ cmake/SearchForStuff.cmake
+@@ -9,24 +9,24 @@ if (USE_EXTERNAL_TINYXML)
+ #################################################
+ # Find tinyxml. Only debian distributions package tinyxml with a pkg-config
+ # Use pkg_check_modules and fallback to manual detection (needed, at least, for MacOS)
+- pkg_check_modules(tinyxml tinyxml)
++ pkg_check_modules(tinyxml tinyxml2)
+ if (NOT tinyxml_FOUND)
+- find_path (tinyxml_include_dirs tinyxml.h ${tinyxml_include_dirs} ENV CPATH)
+- find_library(tinyxml_LIBRARIES NAMES tinyxml)
++ find_path (tinyxml_include_dirs tinyxml2.h ${tinyxml_include_dirs} ENV CPATH)
++ find_library(tinyxml_LIBRARIES NAMES tinyxml2)
+ set (tinyxml_FAIL False)
+ if (NOT tinyxml_include_dirs)
+- message (STATUS "Looking for tinyxml headers - not found")
++ message (STATUS "Looking for tinyxml2 headers - not found")
+ set (tinyxml_FAIL True)
+ endif()
+ if (NOT tinyxml_LIBRARIES)
+- message (STATUS "Looking for tinyxml library - not found")
++ message (STATUS "Looking for tinyxml2 library - not found")
+ set (tinyxml_FAIL True)
+ endif()
+ endif()
+
+ if (tinyxml_FAIL)
+- message (STATUS "Looking for tinyxml.h - not found")
+- BUILD_ERROR("Missing: tinyxml")
++ message (STATUS "Looking for tinyxml2.h - not found")
++ BUILD_ERROR("Missing: tinyxml2")
+ endif()
+ else()
+ # Needed in WIN32 since in UNIX the flag is added in the code installed
diff --git a/misc/sdformat/files/patch-src_CMakeLists.txt b/misc/sdformat/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..5e123631594d
--- /dev/null
+++ b/misc/sdformat/files/patch-src_CMakeLists.txt
@@ -0,0 +1,13 @@
+--- src/CMakeLists.txt.orig 2018-11-21 00:25:29 UTC
++++ src/CMakeLists.txt
+@@ -116,7 +116,9 @@ if (IGNITION-TOOLS_BINARY_DIRS)
+ )
+ endif()
+
+-sdf_build_tests(${gtest_sources})
++if (BUILD_TESTING)
++ sdf_build_tests(${gtest_sources})
++endif()
+
+ sdf_add_library(${sdf_target} ${sources})
+ target_link_libraries(${sdf_target} PUBLIC ${IGNITION-MATH_LIBRARIES})
diff --git a/misc/sdformat/pkg-descr b/misc/sdformat/pkg-descr
new file mode 100644
index 000000000000..b815873f1e0a
--- /dev/null
+++ b/misc/sdformat/pkg-descr
@@ -0,0 +1,9 @@
+SDF is an XML file format that describes environments, objects, and robots in
+a manner suitable for robotic applications. SDF is capable of representing and
+describing different physic engines, lighting properties, terrain, static or
+dynamic objects, and articulated robots with various sensors, and acutators. The
+format of SDF is also described by XML, which facilitates updates and allows
+conversion from previous versions. A parser is also contained within this
+package that reads SDF files and returns a C++ interface.
+
+WWW: https://bitbucket.org/osrf/sdformat/src/default/
diff --git a/misc/sdformat/pkg-plist b/misc/sdformat/pkg-plist
new file mode 100644
index 000000000000..865d4f41b596
--- /dev/null
+++ b/misc/sdformat/pkg-plist
@@ -0,0 +1,387 @@
+include/%%INCSUBDIR%%/sdf/Assert.hh
+include/%%INCSUBDIR%%/sdf/Atmosphere.hh
+include/%%INCSUBDIR%%/sdf/Box.hh
+include/%%INCSUBDIR%%/sdf/Collision.hh
+include/%%INCSUBDIR%%/sdf/Console.hh
+include/%%INCSUBDIR%%/sdf/Cylinder.hh
+include/%%INCSUBDIR%%/sdf/Element.hh
+include/%%INCSUBDIR%%/sdf/Error.hh
+include/%%INCSUBDIR%%/sdf/Exception.hh
+include/%%INCSUBDIR%%/sdf/Filesystem.hh
+include/%%INCSUBDIR%%/sdf/Geometry.hh
+include/%%INCSUBDIR%%/sdf/Gui.hh
+include/%%INCSUBDIR%%/sdf/Joint.hh
+include/%%INCSUBDIR%%/sdf/JointAxis.hh
+include/%%INCSUBDIR%%/sdf/Light.hh
+include/%%INCSUBDIR%%/sdf/Link.hh
+include/%%INCSUBDIR%%/sdf/Material.hh
+include/%%INCSUBDIR%%/sdf/Mesh.hh
+include/%%INCSUBDIR%%/sdf/Model.hh
+include/%%INCSUBDIR%%/sdf/Param.hh
+include/%%INCSUBDIR%%/sdf/Physics.hh
+include/%%INCSUBDIR%%/sdf/Plane.hh
+include/%%INCSUBDIR%%/sdf/Root.hh
+include/%%INCSUBDIR%%/sdf/SDFImpl.hh
+include/%%INCSUBDIR%%/sdf/Sphere.hh
+include/%%INCSUBDIR%%/sdf/Types.hh
+include/%%INCSUBDIR%%/sdf/Visual.hh
+include/%%INCSUBDIR%%/sdf/World.hh
+include/%%INCSUBDIR%%/sdf/parser.hh
+include/%%INCSUBDIR%%/sdf/parser_urdf.hh
+include/%%INCSUBDIR%%/sdf/sdf.hh
+include/%%INCSUBDIR%%/sdf/sdf_config.h
+include/%%INCSUBDIR%%/sdf/system_util.hh
+lib/cmake/sdformat8/sdformat8-config-version.cmake
+lib/cmake/sdformat8/sdformat8-config.cmake
+lib/cmake/sdformat8/sdformat8-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/sdformat8/sdformat8-targets.cmake
+lib/libsdformat8.so
+lib/libsdformat8.so.8
+lib/libsdformat8.so.8.0.0~pre3
+lib/ruby/ignition/cmdsdformat8.rb
+libdata/pkgconfig/sdformat8.pc
+share/ignition/sdformat8.yaml
+%%DATADIR%%/1.0/actor.sdf
+%%DATADIR%%/1.0/camera.sdf
+%%DATADIR%%/1.0/collision.sdf
+%%DATADIR%%/1.0/contact.sdf
+%%DATADIR%%/1.0/gazebo.sdf
+%%DATADIR%%/1.0/geometry.sdf
+%%DATADIR%%/1.0/gripper.sdf
+%%DATADIR%%/1.0/gui.sdf
+%%DATADIR%%/1.0/inertial.sdf
+%%DATADIR%%/1.0/joint.sdf
+%%DATADIR%%/1.0/light.sdf
+%%DATADIR%%/1.0/link.sdf
+%%DATADIR%%/1.0/model.sdf
+%%DATADIR%%/1.0/physics.sdf
+%%DATADIR%%/1.0/plugin.sdf
+%%DATADIR%%/1.0/projector.sdf
+%%DATADIR%%/1.0/ray.sdf
+%%DATADIR%%/1.0/rfid.sdf
+%%DATADIR%%/1.0/rfidtag.sdf
+%%DATADIR%%/1.0/road.sdf
+%%DATADIR%%/1.0/scene.sdf
+%%DATADIR%%/1.0/sensor.sdf
+%%DATADIR%%/1.0/state.sdf
+%%DATADIR%%/1.0/surface.sdf
+%%DATADIR%%/1.0/visual.sdf
+%%DATADIR%%/1.0/world.sdf
+%%DATADIR%%/1.2/1_0.convert
+%%DATADIR%%/1.2/actor.sdf
+%%DATADIR%%/1.2/camera.sdf
+%%DATADIR%%/1.2/collision.sdf
+%%DATADIR%%/1.2/contact.sdf
+%%DATADIR%%/1.2/gazebo.sdf
+%%DATADIR%%/1.2/geometry.sdf
+%%DATADIR%%/1.2/gripper.sdf
+%%DATADIR%%/1.2/gui.sdf
+%%DATADIR%%/1.2/inertial.sdf
+%%DATADIR%%/1.2/joint.sdf
+%%DATADIR%%/1.2/light.sdf
+%%DATADIR%%/1.2/link.sdf
+%%DATADIR%%/1.2/model.sdf
+%%DATADIR%%/1.2/physics.sdf
+%%DATADIR%%/1.2/plugin.sdf
+%%DATADIR%%/1.2/projector.sdf
+%%DATADIR%%/1.2/ray.sdf
+%%DATADIR%%/1.2/rfid.sdf
+%%DATADIR%%/1.2/rfidtag.sdf
+%%DATADIR%%/1.2/road.sdf
+%%DATADIR%%/1.2/scene.sdf
+%%DATADIR%%/1.2/sensor.sdf
+%%DATADIR%%/1.2/state.sdf
+%%DATADIR%%/1.2/surface.sdf
+%%DATADIR%%/1.2/visual.sdf
+%%DATADIR%%/1.2/world.sdf
+%%DATADIR%%/1.3/1_2.convert
+%%DATADIR%%/1.3/actor.sdf
+%%DATADIR%%/1.3/camera.sdf
+%%DATADIR%%/1.3/collision.sdf
+%%DATADIR%%/1.3/contact.sdf
+%%DATADIR%%/1.3/geometry.sdf
+%%DATADIR%%/1.3/gripper.sdf
+%%DATADIR%%/1.3/gui.sdf
+%%DATADIR%%/1.3/imu.sdf
+%%DATADIR%%/1.3/inertial.sdf
+%%DATADIR%%/1.3/joint.sdf
+%%DATADIR%%/1.3/light.sdf
+%%DATADIR%%/1.3/link.sdf
+%%DATADIR%%/1.3/model.sdf
+%%DATADIR%%/1.3/physics.sdf
+%%DATADIR%%/1.3/plugin.sdf
+%%DATADIR%%/1.3/projector.sdf
+%%DATADIR%%/1.3/ray.sdf
+%%DATADIR%%/1.3/rfid.sdf
+%%DATADIR%%/1.3/rfidtag.sdf
+%%DATADIR%%/1.3/road.sdf
+%%DATADIR%%/1.3/root.sdf
+%%DATADIR%%/1.3/scene.sdf
+%%DATADIR%%/1.3/sensor.sdf
+%%DATADIR%%/1.3/state.sdf
+%%DATADIR%%/1.3/surface.sdf
+%%DATADIR%%/1.3/visual.sdf
+%%DATADIR%%/1.3/world.sdf
+%%DATADIR%%/1.4/1_3.convert
+%%DATADIR%%/1.4/actor.sdf
+%%DATADIR%%/1.4/audio_sink.sdf
+%%DATADIR%%/1.4/audio_source.sdf
+%%DATADIR%%/1.4/box_shape.sdf
+%%DATADIR%%/1.4/camera.sdf
+%%DATADIR%%/1.4/collision.sdf
+%%DATADIR%%/1.4/contact.sdf
+%%DATADIR%%/1.4/cylinder_shape.sdf
+%%DATADIR%%/1.4/forcetorque.sdf
+%%DATADIR%%/1.4/geometry.sdf
+%%DATADIR%%/1.4/gps.sdf
+%%DATADIR%%/1.4/gripper.sdf
+%%DATADIR%%/1.4/gui.sdf
+%%DATADIR%%/1.4/heightmap_shape.sdf
+%%DATADIR%%/1.4/image_shape.sdf
+%%DATADIR%%/1.4/imu.sdf
+%%DATADIR%%/1.4/inertial.sdf
+%%DATADIR%%/1.4/joint.sdf
+%%DATADIR%%/1.4/light.sdf
+%%DATADIR%%/1.4/link.sdf
+%%DATADIR%%/1.4/mesh_shape.sdf
+%%DATADIR%%/1.4/model.sdf
+%%DATADIR%%/1.4/noise.sdf
+%%DATADIR%%/1.4/physics.sdf
+%%DATADIR%%/1.4/plane_shape.sdf
+%%DATADIR%%/1.4/plugin.sdf
+%%DATADIR%%/1.4/projector.sdf
+%%DATADIR%%/1.4/ray.sdf
+%%DATADIR%%/1.4/rfid.sdf
+%%DATADIR%%/1.4/rfidtag.sdf
+%%DATADIR%%/1.4/road.sdf
+%%DATADIR%%/1.4/root.sdf
+%%DATADIR%%/1.4/scene.sdf
+%%DATADIR%%/1.4/sensor.sdf
+%%DATADIR%%/1.4/sonar.sdf
+%%DATADIR%%/1.4/sphere_shape.sdf
+%%DATADIR%%/1.4/spherical_coordinates.sdf
+%%DATADIR%%/1.4/state.sdf
+%%DATADIR%%/1.4/surface.sdf
+%%DATADIR%%/1.4/transceiver.sdf
+%%DATADIR%%/1.4/visual.sdf
+%%DATADIR%%/1.4/world.sdf
+%%DATADIR%%/1.5/1_4.convert
+%%DATADIR%%/1.5/actor.sdf
+%%DATADIR%%/1.5/actor.xsd
+%%DATADIR%%/1.5/altimeter.sdf
+%%DATADIR%%/1.5/altimeter.xsd
+%%DATADIR%%/1.5/audio_sink.sdf
+%%DATADIR%%/1.5/audio_sink.xsd
+%%DATADIR%%/1.5/audio_source.sdf
+%%DATADIR%%/1.5/audio_source.xsd
+%%DATADIR%%/1.5/battery.sdf
+%%DATADIR%%/1.5/battery.xsd
+%%DATADIR%%/1.5/box_shape.sdf
+%%DATADIR%%/1.5/box_shape.xsd
+%%DATADIR%%/1.5/camera.sdf
+%%DATADIR%%/1.5/camera.xsd
+%%DATADIR%%/1.5/collision.sdf
+%%DATADIR%%/1.5/collision.xsd
+%%DATADIR%%/1.5/contact.sdf
+%%DATADIR%%/1.5/contact.xsd
+%%DATADIR%%/1.5/cylinder_shape.sdf
+%%DATADIR%%/1.5/cylinder_shape.xsd
+%%DATADIR%%/1.5/forcetorque.sdf
+%%DATADIR%%/1.5/forcetorque.xsd
+%%DATADIR%%/1.5/frame.sdf
+%%DATADIR%%/1.5/frame.xsd
+%%DATADIR%%/1.5/geometry.sdf
+%%DATADIR%%/1.5/geometry.xsd
+%%DATADIR%%/1.5/gps.sdf
+%%DATADIR%%/1.5/gps.xsd
+%%DATADIR%%/1.5/gripper.sdf
+%%DATADIR%%/1.5/gripper.xsd
+%%DATADIR%%/1.5/gui.sdf
+%%DATADIR%%/1.5/gui.xsd
+%%DATADIR%%/1.5/heightmap_shape.sdf
+%%DATADIR%%/1.5/heightmap_shape.xsd
+%%DATADIR%%/1.5/image_shape.sdf
+%%DATADIR%%/1.5/image_shape.xsd
+%%DATADIR%%/1.5/imu.sdf
+%%DATADIR%%/1.5/imu.xsd
+%%DATADIR%%/1.5/inertial.sdf
+%%DATADIR%%/1.5/inertial.xsd
+%%DATADIR%%/1.5/joint.sdf
+%%DATADIR%%/1.5/joint.xsd
+%%DATADIR%%/1.5/light.sdf
+%%DATADIR%%/1.5/light.xsd
+%%DATADIR%%/1.5/light_state.sdf
+%%DATADIR%%/1.5/light_state.xsd
+%%DATADIR%%/1.5/link.sdf
+%%DATADIR%%/1.5/link.xsd
+%%DATADIR%%/1.5/link_state.sdf
+%%DATADIR%%/1.5/link_state.xsd
+%%DATADIR%%/1.5/logical_camera.sdf
+%%DATADIR%%/1.5/logical_camera.xsd
+%%DATADIR%%/1.5/magnetometer.sdf
+%%DATADIR%%/1.5/magnetometer.xsd
+%%DATADIR%%/1.5/material.sdf
+%%DATADIR%%/1.5/material.xsd
+%%DATADIR%%/1.5/mesh_shape.sdf
+%%DATADIR%%/1.5/mesh_shape.xsd
+%%DATADIR%%/1.5/model.sdf
+%%DATADIR%%/1.5/model.xsd
+%%DATADIR%%/1.5/model_state.sdf
+%%DATADIR%%/1.5/model_state.xsd
+%%DATADIR%%/1.5/noise.sdf
+%%DATADIR%%/1.5/noise.xsd
+%%DATADIR%%/1.5/physics.sdf
+%%DATADIR%%/1.5/physics.xsd
+%%DATADIR%%/1.5/plane_shape.sdf
+%%DATADIR%%/1.5/plane_shape.xsd
+%%DATADIR%%/1.5/plugin.sdf
+%%DATADIR%%/1.5/plugin.xsd
+%%DATADIR%%/1.5/polyline_shape.sdf
+%%DATADIR%%/1.5/polyline_shape.xsd
+%%DATADIR%%/1.5/population.sdf
+%%DATADIR%%/1.5/population.xsd
+%%DATADIR%%/1.5/pose.sdf
+%%DATADIR%%/1.5/pose.xsd
+%%DATADIR%%/1.5/projector.sdf
+%%DATADIR%%/1.5/projector.xsd
+%%DATADIR%%/1.5/ray.sdf
+%%DATADIR%%/1.5/ray.xsd
+%%DATADIR%%/1.5/rfid.sdf
+%%DATADIR%%/1.5/rfid.xsd
+%%DATADIR%%/1.5/rfidtag.sdf
+%%DATADIR%%/1.5/rfidtag.xsd
+%%DATADIR%%/1.5/road.sdf
+%%DATADIR%%/1.5/road.xsd
+%%DATADIR%%/1.5/root.sdf
+%%DATADIR%%/1.5/root.xsd
+%%DATADIR%%/1.5/scene.sdf
+%%DATADIR%%/1.5/scene.xsd
+%%DATADIR%%/1.5/sensor.sdf
+%%DATADIR%%/1.5/sensor.xsd
+%%DATADIR%%/1.5/sonar.sdf
+%%DATADIR%%/1.5/sonar.xsd
+%%DATADIR%%/1.5/sphere_shape.sdf
+%%DATADIR%%/1.5/sphere_shape.xsd
+%%DATADIR%%/1.5/spherical_coordinates.sdf
+%%DATADIR%%/1.5/spherical_coordinates.xsd
+%%DATADIR%%/1.5/state.sdf
+%%DATADIR%%/1.5/state.xsd
+%%DATADIR%%/1.5/surface.sdf
+%%DATADIR%%/1.5/surface.xsd
+%%DATADIR%%/1.5/transceiver.sdf
+%%DATADIR%%/1.5/transceiver.xsd
+%%DATADIR%%/1.5/visual.sdf
+%%DATADIR%%/1.5/visual.xsd
+%%DATADIR%%/1.5/world.sdf
+%%DATADIR%%/1.5/world.xsd
+%%DATADIR%%/1.6/1_5.convert
+%%DATADIR%%/1.6/actor.sdf
+%%DATADIR%%/1.6/actor.xsd
+%%DATADIR%%/1.6/altimeter.sdf
+%%DATADIR%%/1.6/altimeter.xsd
+%%DATADIR%%/1.6/atmosphere.sdf
+%%DATADIR%%/1.6/atmosphere.xsd
+%%DATADIR%%/1.6/audio_sink.sdf
+%%DATADIR%%/1.6/audio_sink.xsd
+%%DATADIR%%/1.6/audio_source.sdf
+%%DATADIR%%/1.6/audio_source.xsd
+%%DATADIR%%/1.6/battery.sdf
+%%DATADIR%%/1.6/battery.xsd
+%%DATADIR%%/1.6/box_shape.sdf
+%%DATADIR%%/1.6/box_shape.xsd
+%%DATADIR%%/1.6/camera.sdf
+%%DATADIR%%/1.6/camera.xsd
+%%DATADIR%%/1.6/collision.sdf
+%%DATADIR%%/1.6/collision.xsd
+%%DATADIR%%/1.6/contact.sdf
+%%DATADIR%%/1.6/contact.xsd
+%%DATADIR%%/1.6/cylinder_shape.sdf
+%%DATADIR%%/1.6/cylinder_shape.xsd
+%%DATADIR%%/1.6/forcetorque.sdf
+%%DATADIR%%/1.6/forcetorque.xsd
+%%DATADIR%%/1.6/frame.sdf
+%%DATADIR%%/1.6/frame.xsd
+%%DATADIR%%/1.6/geometry.sdf
+%%DATADIR%%/1.6/geometry.xsd
+%%DATADIR%%/1.6/gps.sdf
+%%DATADIR%%/1.6/gps.xsd
+%%DATADIR%%/1.6/gripper.sdf
+%%DATADIR%%/1.6/gripper.xsd
+%%DATADIR%%/1.6/gui.sdf
+%%DATADIR%%/1.6/gui.xsd
+%%DATADIR%%/1.6/heightmap_shape.sdf
+%%DATADIR%%/1.6/heightmap_shape.xsd
+%%DATADIR%%/1.6/image_shape.sdf
+%%DATADIR%%/1.6/image_shape.xsd
+%%DATADIR%%/1.6/imu.sdf
+%%DATADIR%%/1.6/imu.xsd
+%%DATADIR%%/1.6/inertial.sdf
+%%DATADIR%%/1.6/inertial.xsd
+%%DATADIR%%/1.6/joint.sdf
+%%DATADIR%%/1.6/joint.xsd
+%%DATADIR%%/1.6/light.sdf
+%%DATADIR%%/1.6/light.xsd
+%%DATADIR%%/1.6/light_state.sdf
+%%DATADIR%%/1.6/light_state.xsd
+%%DATADIR%%/1.6/link.sdf
+%%DATADIR%%/1.6/link.xsd
+%%DATADIR%%/1.6/link_state.sdf
+%%DATADIR%%/1.6/link_state.xsd
+%%DATADIR%%/1.6/logical_camera.sdf
+%%DATADIR%%/1.6/logical_camera.xsd
+%%DATADIR%%/1.6/magnetometer.sdf
+%%DATADIR%%/1.6/magnetometer.xsd
+%%DATADIR%%/1.6/material.sdf
+%%DATADIR%%/1.6/material.xsd
+%%DATADIR%%/1.6/mesh_shape.sdf
+%%DATADIR%%/1.6/mesh_shape.xsd
+%%DATADIR%%/1.6/model.sdf
+%%DATADIR%%/1.6/model.xsd
+%%DATADIR%%/1.6/model_state.sdf
+%%DATADIR%%/1.6/model_state.xsd
+%%DATADIR%%/1.6/noise.sdf
+%%DATADIR%%/1.6/noise.xsd
+%%DATADIR%%/1.6/physics.sdf
+%%DATADIR%%/1.6/physics.xsd
+%%DATADIR%%/1.6/plane_shape.sdf
+%%DATADIR%%/1.6/plane_shape.xsd
+%%DATADIR%%/1.6/plugin.sdf
+%%DATADIR%%/1.6/plugin.xsd
+%%DATADIR%%/1.6/polyline_shape.sdf
+%%DATADIR%%/1.6/polyline_shape.xsd
+%%DATADIR%%/1.6/population.sdf
+%%DATADIR%%/1.6/population.xsd
+%%DATADIR%%/1.6/pose.sdf
+%%DATADIR%%/1.6/pose.xsd
+%%DATADIR%%/1.6/projector.sdf
+%%DATADIR%%/1.6/projector.xsd
+%%DATADIR%%/1.6/ray.sdf
+%%DATADIR%%/1.6/ray.xsd
+%%DATADIR%%/1.6/rfid.sdf
+%%DATADIR%%/1.6/rfid.xsd
+%%DATADIR%%/1.6/rfidtag.sdf
+%%DATADIR%%/1.6/rfidtag.xsd
+%%DATADIR%%/1.6/road.sdf
+%%DATADIR%%/1.6/road.xsd
+%%DATADIR%%/1.6/root.sdf
+%%DATADIR%%/1.6/root.xsd
+%%DATADIR%%/1.6/scene.sdf
+%%DATADIR%%/1.6/scene.xsd
+%%DATADIR%%/1.6/sensor.sdf
+%%DATADIR%%/1.6/sensor.xsd
+%%DATADIR%%/1.6/sonar.sdf
+%%DATADIR%%/1.6/sonar.xsd
+%%DATADIR%%/1.6/sphere_shape.sdf
+%%DATADIR%%/1.6/sphere_shape.xsd
+%%DATADIR%%/1.6/spherical_coordinates.sdf
+%%DATADIR%%/1.6/spherical_coordinates.xsd
+%%DATADIR%%/1.6/state.sdf
+%%DATADIR%%/1.6/state.xsd
+%%DATADIR%%/1.6/surface.sdf
+%%DATADIR%%/1.6/surface.xsd
+%%DATADIR%%/1.6/transceiver.sdf
+%%DATADIR%%/1.6/transceiver.xsd
+%%DATADIR%%/1.6/visual.sdf
+%%DATADIR%%/1.6/visual.xsd
+%%DATADIR%%/1.6/world.sdf
+%%DATADIR%%/1.6/world.xsd