aboutsummaryrefslogtreecommitdiff
path: root/misc/shc/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-01-30 14:50:01 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-01-30 14:50:01 +0000
commitc8630a9131280ed821e85709d042db30b72644b5 (patch)
tree7be78fb0f845957520d4187be28101b4f6efc633 /misc/shc/Makefile
parentb2653a25fd540a8d3910b121722f43155d8f080b (diff)
downloadports-c8630a9131280ed821e85709d042db30b72644b5.tar.gz
ports-c8630a9131280ed821e85709d042db30b72644b5.zip
Notes
Diffstat (limited to 'misc/shc/Makefile')
-rw-r--r--misc/shc/Makefile23
1 files changed, 7 insertions, 16 deletions
diff --git a/misc/shc/Makefile b/misc/shc/Makefile
index 9886542379f8..db1621ed17f6 100644
--- a/misc/shc/Makefile
+++ b/misc/shc/Makefile
@@ -2,30 +2,21 @@
# $FreeBSD$
PORTNAME= shc
-PORTVERSION= 3.8.9
-PORTREVISION= 1
+PORTVERSION= 3.9.3
CATEGORIES= misc
-MASTER_SITES= http://www.datsi.fi.upm.es/~frosal/sources/ \
- LOCAL/ehaupt
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Generic script compiler
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/Copying
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+GNU_CONFIGURE= yes
USES= tar:tgz
-PLIST_FILES= bin/shc man/man1/shc.1.gz
-
-post-extract:
- @${RM} ${WRKSRC}/shc
+USE_GITHUB= yes
+GH_ACCOUNT= neurobin
-do-build:
- ${CC} ${CFLAGS} -o ${WRKSRC}/shc ${WRKSRC}/${PORTNAME}-${PORTVERSION}.c
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/shc ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/shc.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+PLIST_FILES= bin/shc man/man1/shc.1.gz
.include <bsd.port.mk>