aboutsummaryrefslogtreecommitdiff
path: root/misc/shc
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-29 04:30:55 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-29 04:30:55 +0000
commit0e0d5c1a703736246c5efce5fcb41242155e7d02 (patch)
treeadb1de39eeefd5f86885feab4120ecbe0dd7685a /misc/shc
parenta6f5e50a29a0e9dece2c85b554edd5e224e74a5c (diff)
downloadports-0e0d5c1a703736246c5efce5fcb41242155e7d02.tar.gz
ports-0e0d5c1a703736246c5efce5fcb41242155e7d02.zip
revive ports/misc/shc and upgrade it to 3.7
Notes
Notes: svn path=/head/; revision=96819
Diffstat (limited to 'misc/shc')
-rw-r--r--misc/shc/Makefile27
-rw-r--r--misc/shc/distinfo1
-rw-r--r--misc/shc/pkg-descr6
-rw-r--r--misc/shc/pkg-plist1
4 files changed, 35 insertions, 0 deletions
diff --git a/misc/shc/Makefile b/misc/shc/Makefile
new file mode 100644
index 000000000000..1953ce4861ab
--- /dev/null
+++ b/misc/shc/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: shc
+# Date created: Feb 14, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= shc
+PORTVERSION= 3.7
+CATEGORIES= misc
+MASTER_SITES= http://www.datsi.fi.upm.es/~frosal/sources/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A shell script "encoder"
+
+MAN1= shc.1
+
+do-build:
+ @cd ${WRKSRC} && ${CC} ${CFLAGS} -o shc shc.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/shc ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/shc.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/misc/shc/distinfo b/misc/shc/distinfo
new file mode 100644
index 000000000000..b136ce92324e
--- /dev/null
+++ b/misc/shc/distinfo
@@ -0,0 +1 @@
+MD5 (shc-3.7.tgz) = 49e4054ad39371ea84f7be46cf8d9701
diff --git a/misc/shc/pkg-descr b/misc/shc/pkg-descr
new file mode 100644
index 000000000000..2ed30a65a479
--- /dev/null
+++ b/misc/shc/pkg-descr
@@ -0,0 +1,6 @@
+A generic shell script compiler. Shc takes a script, which is
+specified on the command line and produces c source code. The
+generated source code is then compiled and linked to produce a
+stripped binary executable. Use with care.
+
+WWW: http://www.datsi.fi.upm.es/~frosal/frosal.html
diff --git a/misc/shc/pkg-plist b/misc/shc/pkg-plist
new file mode 100644
index 000000000000..cbfcaa1f7c75
--- /dev/null
+++ b/misc/shc/pkg-plist
@@ -0,0 +1 @@
+bin/shc