aboutsummaryrefslogtreecommitdiff
path: root/misc/shc
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-02-13 15:42:18 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-02-13 15:42:18 +0000
commitede6028ac533faf425e66a706d2addc66b2974a2 (patch)
tree30de6441cd22a4354d11b9952b7ea2cdaac7f06c /misc/shc
parent40c0df04d26e72b1f4bc4f0faafd396fdfcd6df5 (diff)
downloadports-ede6028ac533faf425e66a706d2addc66b2974a2.tar.gz
ports-ede6028ac533faf425e66a706d2addc66b2974a2.zip
add shc, a shell script "encoder"
Notes
Notes: svn path=/head/; revision=38311
Diffstat (limited to 'misc/shc')
-rw-r--r--misc/shc/Makefile25
-rw-r--r--misc/shc/distinfo1
-rw-r--r--misc/shc/files/patch-Makefile36
-rw-r--r--misc/shc/pkg-comment1
-rw-r--r--misc/shc/pkg-descr6
-rw-r--r--misc/shc/pkg-plist1
6 files changed, 70 insertions, 0 deletions
diff --git a/misc/shc/Makefile b/misc/shc/Makefile
new file mode 100644
index 000000000000..44355b84055d
--- /dev/null
+++ b/misc/shc/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# New ports collection makefile for: shc
+# Date created: Feb 14, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= shc
+PORTVERSION= 3.2
+CATEGORIES= misc
+MASTER_SITES= ftp://asterix.fi.upm.es/pub/facultad/departamentos/datsi/frosal/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ijliao@FreeBSD.org
+
+ALL_TARGET= shc
+
+MAN1= shc.1
+
+post-patch:
+ @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/Makefile
+ @${PERL} -pi -e "s|%%CFLAGS%%|${CFLAGS}|g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/misc/shc/distinfo b/misc/shc/distinfo
new file mode 100644
index 000000000000..85689cf9d981
--- /dev/null
+++ b/misc/shc/distinfo
@@ -0,0 +1 @@
+MD5 (shc-3.2.tgz) = 1af5248d8db6038741a00ced9143b4f1
diff --git a/misc/shc/files/patch-Makefile b/misc/shc/files/patch-Makefile
new file mode 100644
index 000000000000..afeb4c01d049
--- /dev/null
+++ b/misc/shc/files/patch-Makefile
@@ -0,0 +1,36 @@
+--- Makefile.orig Wed Mar 10 00:43:27 1999
++++ Makefile Tue Feb 13 23:25:09 2001
+@@ -2,19 +2,19 @@
+ #
+
+ # For IRIX
+-CFLAGS = -xansi -fullwarn -O3 -g0
++#CFLAGS = -xansi -fullwarn -O3 -g0
+
+ # For Solaris
+-CFLAGS = -fast -xO4 -s -v -Xa
++#CFLAGS = -fast -xO4 -s -v -Xa
+
+ # For HPUX
+-CFLAGS = -Wall -O -Ae
++#CFLAGS = -Wall -O -Ae
+
+ # For OSF1
+-CFLAGS = -w -verbose -fast -std1 -g0
++#CFLAGS = -w -verbose -fast -std1 -g0
+
+ # For GNU C compiler
+-CFLAGS = -Wall -O6 -s -pedantic
++CFLAGS = %%CFLAGS%%
+
+ SHELL = /bin/sh
+
+@@ -38,6 +38,6 @@
+ rm -f shc *.x
+
+ install:
+- install -c -s shc /usr/local/bin/
+- install -c -m 644 shc.1 /usr/local/man/man1/
++ install -c -s shc %%PREFIX%%/bin/
++ install -c -m 644 shc.1 %%PREFIX%%/man/man1/
+
diff --git a/misc/shc/pkg-comment b/misc/shc/pkg-comment
new file mode 100644
index 000000000000..889f8be04f33
--- /dev/null
+++ b/misc/shc/pkg-comment
@@ -0,0 +1 @@
+A shell script "encoder"
diff --git a/misc/shc/pkg-descr b/misc/shc/pkg-descr
new file mode 100644
index 000000000000..2ed30a65a479
--- /dev/null
+++ b/misc/shc/pkg-descr
@@ -0,0 +1,6 @@
+A generic shell script compiler. Shc takes a script, which is
+specified on the command line and produces c source code. The
+generated source code is then compiled and linked to produce a
+stripped binary executable. Use with care.
+
+WWW: http://www.datsi.fi.upm.es/~frosal/frosal.html
diff --git a/misc/shc/pkg-plist b/misc/shc/pkg-plist
new file mode 100644
index 000000000000..cbfcaa1f7c75
--- /dev/null
+++ b/misc/shc/pkg-plist
@@ -0,0 +1 @@
+bin/shc