aboutsummaryrefslogtreecommitdiff
path: root/misc/sma/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-05-10 22:21:39 +0000
committerSteve Price <steve@FreeBSD.org>1998-05-10 22:21:39 +0000
commite2ff5692056745f75dd2ba5c336d3bc2f4a73a7f (patch)
tree2370c90f06b9777c84a0f0901bc2e36496e06312 /misc/sma/Makefile
parentd093362e308304e87e5c21a10e215b863f9e8617 (diff)
downloadports-e2ff5692056745f75dd2ba5c336d3bc2f4a73a7f.tar.gz
ports-e2ff5692056745f75dd2ba5c336d3bc2f4a73a7f.zip
Notes
Diffstat (limited to 'misc/sma/Makefile')
-rw-r--r--misc/sma/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/misc/sma/Makefile b/misc/sma/Makefile
new file mode 100644
index 000000000000..4ec6ae9b7525
--- /dev/null
+++ b/misc/sma/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: sma
+# Version required: 0.9.7
+# Date created: 8 May 1998
+# Whom: Donald Burr <dburr@POBoxes.com>
+#
+# $Id$
+#
+
+DISTNAME= SMA2
+PKGNAME= sma-0.9.7
+CATEGORIES= misc
+MASTER_SITES= http://www.scour.net/sma/
+EXTRACT_SUFX= .pl
+
+MAINTAINER= dburr@POBoxes.com
+
+RUN_DEPENDS= smbclient:${PORTSDIR}/net/samba
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+USE_PERL5= yes
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+
+pre-configure:
+ @${SED} -e '1,1s:/usr/bin/perl:${PREFIX}/bin/perl5.00404:' \
+ ${DISTDIR}/SMA2.pl > ${WRKDIR}/sma
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/sma ${PREFIX}/bin
+
+post-install:
+ @${CAT} ${PKGDIR}/MESSAGE
+
+.include <bsd.port.mk>