aboutsummaryrefslogtreecommitdiff
path: root/misc/susv2
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-16 15:07:14 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-16 15:07:14 +0000
commite4fe032f4922da902fac9d6a21c0a3f2a5ec6c04 (patch)
tree1242532ab09a5b3f1b11c0a8544c6012a417fc51 /misc/susv2
parent64060e192279adced660db6554f11636f48716ae (diff)
downloadports-e4fe032f4922da902fac9d6a21c0a3f2a5ec6c04.tar.gz
ports-e4fe032f4922da902fac9d6a21c0a3f2a5ec6c04.zip
new port: misc/susv2 (Single UNIX Specification Version 2)
PR: ports/37003 Submitted by: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
Notes
Notes: svn path=/head/; revision=73265
Diffstat (limited to 'misc/susv2')
-rw-r--r--misc/susv2/Makefile43
-rw-r--r--misc/susv2/distinfo1
-rw-r--r--misc/susv2/pkg-comment1
-rw-r--r--misc/susv2/pkg-descr6
4 files changed, 51 insertions, 0 deletions
diff --git a/misc/susv2/Makefile b/misc/susv2/Makefile
new file mode 100644
index 000000000000..ce583929e9cf
--- /dev/null
+++ b/misc/susv2/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: susv2
+# Date created: 11 April 2002
+# Whom: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= susv2
+PORTVERSION= 1.0
+CATEGORIES= misc
+MASTER_SITES= #
+DISTNAME= susv2
+
+MAINTAINER= corecode@corecode.ath.cx
+
+RESTRICTED= "Redistribution of the documents is not permitted"
+
+USE_BZIP2= yes
+NO_BUILD= yes
+
+PLIST= ${WRKDIR}/pkg-plist
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= "may not be redistributed because of licensing reasons. Please visit http://www.unix-systems.org/online.html to accept their license and download ${DISTFILES} into ${DISTDIR}"
+.endif
+
+do-install:
+ @${MKDIR} ${DOCSDIR}
+ @> ${PLIST}
+ @${FIND} ${WRKSRC} | ${SED} -e 's#^${WRKSRC}##' | while read file; do \
+ if ${TEST} -d "${WRKSRC}$$file"; then \
+ ${MKDIR} "${DOCSDIR}$$file"; \
+ ${ECHO} "@dirrm ${DOCSDIR:S#^${PREFIX}/##}$$file" >> ${PLIST}; \
+ else \
+ ${INSTALL_DATA} "${WRKSRC}$$file" "${DOCSDIR}$$file"; \
+ ${ECHO} "${DOCSDIR:S#^${PREFIX}/##}$$file" >> ${PLIST}; \
+ fi; \
+ done
+ @(${RM} -f ${PLIST}; ${SED} -ne '/^@/{G;h;};/^@/!p;$${g;p;}' > ${PLIST}) < ${PLIST}
+
+.include <bsd.port.post.mk>
diff --git a/misc/susv2/distinfo b/misc/susv2/distinfo
new file mode 100644
index 000000000000..2a25041ad1f2
--- /dev/null
+++ b/misc/susv2/distinfo
@@ -0,0 +1 @@
+MD5 (susv2.tar.bz2) = 549a54f3f24c6f7660bd36f63a1a109b
diff --git a/misc/susv2/pkg-comment b/misc/susv2/pkg-comment
new file mode 100644
index 000000000000..0129b8fad869
--- /dev/null
+++ b/misc/susv2/pkg-comment
@@ -0,0 +1 @@
+Single UNIX Specification Version 2
diff --git a/misc/susv2/pkg-descr b/misc/susv2/pkg-descr
new file mode 100644
index 000000000000..f7e917682186
--- /dev/null
+++ b/misc/susv2/pkg-descr
@@ -0,0 +1,6 @@
+The Singe UNIX Specification Version 2 is a set of
+numerous HTML pages describing this standard.
+
+WWW: http://www.unix-systems.org/online.html
+
+- Simon 'corecode' Schubert