aboutsummaryrefslogtreecommitdiff
path: root/misc/tempcontrol
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-15 16:54:04 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-15 16:54:04 +0000
commit80a45ad6bf8a8cfd99bb831ae90e58d75928ae70 (patch)
tree23334b2e7eb63dd84782741c5851594a1fdb1d9c /misc/tempcontrol
parentcf0749bcbe89b916bed4e72ee732a4c56b781282 (diff)
downloadports-80a45ad6bf8a8cfd99bb831ae90e58d75928ae70.tar.gz
ports-80a45ad6bf8a8cfd99bb831ae90e58d75928ae70.zip
Properly fix build on -current.
Notes
Notes: svn path=/head/; revision=365000
Diffstat (limited to 'misc/tempcontrol')
-rw-r--r--misc/tempcontrol/Makefile4
-rw-r--r--misc/tempcontrol/files/patch-Makefile20
2 files changed, 21 insertions, 3 deletions
diff --git a/misc/tempcontrol/Makefile b/misc/tempcontrol/Makefile
index 2e26ef75c7b9..4587bd389fbe 100644
--- a/misc/tempcontrol/Makefile
+++ b/misc/tempcontrol/Makefile
@@ -12,8 +12,6 @@ COMMENT= Temperature control for fermenting beer and other applications
LICENSE= BSD2CLAUSE
USES= readline
-MAKE_ARGS= CFLAGS="${CFLAGS} -Wall -Wno-parentheses ${CPPFLAGS}" \
- LFLAGS="${LDFLAGS}"
NO_WRKSUBDIR= yes
PLIST_FILES= bin/tempcontrol share/tempcontrol/temperaturecontrolrc.sample \
@@ -26,7 +24,7 @@ OPTIONS_DEFINE= DOCS
# Must (re)generate depedencies, otherwise parallel builds would not work
pre-build:
- ${MAKE_CMD} -C ${WRKSRC} depend
+ ${DO_MAKE_BUILD} -C ${WRKSRC} depend
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tempcontrol ${STAGEDIR}${PREFIX}/bin/
diff --git a/misc/tempcontrol/files/patch-Makefile b/misc/tempcontrol/files/patch-Makefile
new file mode 100644
index 000000000000..0952106e27ba
--- /dev/null
+++ b/misc/tempcontrol/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig 2006-01-25 18:03:13.000000000 -0500
++++ Makefile 2014-08-15 12:53:03.000000000 -0400
+@@ -39,7 +39,7 @@
+
+ # Where to install the startup script
+ RCDIR = /usr/local/etc/rc.d
+-CFLAGS = -g -O3 -Wall -Wno-parentheses ${INCLUDES}
++CFLAGS += -g -Wall -Wno-parentheses ${CPPFLAGS}
+
+ LINK=gcc
+ LFLAGS= -g
+@@ -88,7 +88,7 @@
+ .FORCE:
+
+ tempcontrol: ${OBJS}
+- ${CC} -o $@ ${CFLAGS} ${OBJS} -lreadline -lcurses -lutil
++ ${CC} -o $@ ${CFLAGS} ${OBJS} ${LDFLAGS} -lreadline -lcurses -lutil
+
+ clean:
+ rm -f *~ myparser* parser.h parserc.h parsercommands.c.sample parserkeys.h *.o ${PROG}