aboutsummaryrefslogtreecommitdiff
path: root/misc/tet
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>1998-10-21 08:31:09 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>1998-10-21 08:31:09 +0000
commit27d9fd2f8e6033606debd7803f04f26fbf8acb9e (patch)
tree4d35350ab8edea8177741f79c260cfd4fab791dc /misc/tet
parentb0535730d8cc1992037d487ca6d9a45f77dee1e4 (diff)
downloadports-27d9fd2f8e6033606debd7803f04f26fbf8acb9e.tar.gz
ports-27d9fd2f8e6033606debd7803f04f26fbf8acb9e.zip
Notes
Diffstat (limited to 'misc/tet')
-rw-r--r--misc/tet/Makefile55
-rw-r--r--misc/tet/distinfo1
-rw-r--r--misc/tet/pkg-comment1
-rw-r--r--misc/tet/pkg-descr19
-rw-r--r--misc/tet/pkg-plist1
5 files changed, 77 insertions, 0 deletions
diff --git a/misc/tet/Makefile b/misc/tet/Makefile
new file mode 100644
index 000000000000..01fa4f2d38c9
--- /dev/null
+++ b/misc/tet/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: tet
+# Version required: 3.2b
+# Date created: 02 Oct 1998
+# Whom: jkoshy
+#
+# $Id$
+#
+
+DISTNAME= tet3.2c-unsup
+PKGNAME= tet-3.2c
+CATEGORIES= misc
+MASTER_SITES= http://tetworks.opengroup.org/
+EXTRACT_SUFX= .src.tgz
+
+MAINTAINER= jkoshy@freebsd.org
+
+NO_WRKSUBDIR= yes
+NO_PACKAGE= TET_ROOT needs to be set at compile time
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= -t ${TET_CONFIG_TARGET}
+
+TET_CONFIG_TARGET?= inet # options are `lite', `xti' and `inet'
+
+# need to register with http://tetworks.opengroup.org/tet3download.html
+MANUAL_FETCH= yes
+
+do-build:
+ cd ${WRKDIR}/src && ${MAKE} ${ALL_TARGET}
+
+pre-extract pre-clean:
+.if !defined(TET_ROOT)
+ @echo
+ @echo "The environment variable \"TET_ROOT\" is not set."
+ @echo "You must set it to the directory where you would like "
+ @echo "this port to reside before attempting extraction or cleaning."
+ @echo
+ @false
+.else
+ @true
+.endif
+
+# move the work directory to $TET_ROOT after extraction
+post-extract:
+ chmod +x ${WRKDIR}/configure
+ ${MKDIR} ${TET_ROOT}
+ cd ${WRKDIR} && tar cf - . | (cd ${TET_ROOT} && tar xf -)
+ ${RM} -rf ${WRKDIR} && ${LN} -s ${TET_ROOT} ${WRKDIR}
+
+do-install:
+ cd ${WRKDIR}/src && ${MAKE} ${INSTALL_TARGET}
+
+post-clean:
+ ${RM} -rf ${TET_ROOT}
+
+.include <bsd.port.mk>
diff --git a/misc/tet/distinfo b/misc/tet/distinfo
new file mode 100644
index 000000000000..d08cd99a18b9
--- /dev/null
+++ b/misc/tet/distinfo
@@ -0,0 +1 @@
+MD5 (tet3.2c-unsup.src.tgz) = d37b78e405e6e52f4dd5f7b6d66dc438
diff --git a/misc/tet/pkg-comment b/misc/tet/pkg-comment
new file mode 100644
index 000000000000..06874de3dda5
--- /dev/null
+++ b/misc/tet/pkg-comment
@@ -0,0 +1 @@
+an test execution framework from the Open Group
diff --git a/misc/tet/pkg-descr b/misc/tet/pkg-descr
new file mode 100644
index 000000000000..80bcc791f411
--- /dev/null
+++ b/misc/tet/pkg-descr
@@ -0,0 +1,19 @@
+TET (Test Execution Toolkit) from the X/Open Consortium is a multi-platform
+test scaffold for both distributed and non-distributed test suites.
+TET allows the production of test suites sharing a common interface,
+promoting sharing of test suites within and across organizations.
+
+It allows facilities to execute test cases in several ways:
+ - Execution of non-distributed test cases on the local system.
+ - Execution of non-distributed test cases on one or more remote
+ systems.
+ - Execution of distributed test cases with the parts of each test
+ case executing simultaneously on either the local system and one
+ or more remote systems, or entirely on two or more remote systems.
+ - Execution of a single test case selected at random from a list of
+ test cases.
+ - Combinations of the above elements executing in parallel.
+ - Sequences of the above elements executing a specified number of
+ times or until some time period has expired.
+
+URL: http://tetworks.opengroup.org/datasheet.html
diff --git a/misc/tet/pkg-plist b/misc/tet/pkg-plist
new file mode 100644
index 000000000000..8b137891791f
--- /dev/null
+++ b/misc/tet/pkg-plist
@@ -0,0 +1 @@
+