aboutsummaryrefslogtreecommitdiff
path: root/misc/thrill
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2024-01-26 13:45:48 +0000
committerThierry Thomas <thierry@FreeBSD.org>2024-02-18 09:22:35 +0000
commita62b21d98ac3a81da7047e4f6c3cc97b28c4a955 (patch)
treef68d0f1ad0d68029f664e235742e08ed279d381c /misc/thrill
parent0d309c1afa7476e9aff4fd98b00cb8dbb79d402c (diff)
downloadports-a62b21d98ac3a81da7047e4f6c3cc97b28c4a955.tar.gz
ports-a62b21d98ac3a81da7047e4f6c3cc97b28c4a955.zip
*/*: fix the dependency to net/openmpi4
For ports without USES=mpi:openmpi. For the others, it will be set automatically.
Diffstat (limited to 'misc/thrill')
-rw-r--r--misc/thrill/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/misc/thrill/Makefile b/misc/thrill/Makefile
index 4f77bf2ad71f..eb5df628dc6f 100644
--- a/misc/thrill/Makefile
+++ b/misc/thrill/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
NOT_FOR_ARCHS= armv6 armv7 i386 mips powerpc powerpcspe # static_assert failed due to requirement 'sizeof(unsigned int) == 8' "FOXXLL supports only 64-bit builds"
-LIB_DEPENDS= libmpi.so:net/openmpi
+LIB_DEPENDS= libmpi_cxx.so:net/openmpi4
USES= cmake compiler:c++17-lang fortran
USE_LDCONFIG= yes