aboutsummaryrefslogtreecommitdiff
path: root/misc/timetrace
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-05-17 03:13:36 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-05-17 03:13:36 +0000
commitfa79f1acc1c1bc3b786e094e67094167a44520c4 (patch)
treefd4f193043f904d64656a4e9ac9583fcfd065d13 /misc/timetrace
parenteee05fe1894482fb0eb71fd3e5d6b08b6de1f4a2 (diff)
downloadports-fa79f1acc1c1bc3b786e094e67094167a44520c4.tar.gz
ports-fa79f1acc1c1bc3b786e094e67094167a44520c4.zip
Diffstat (limited to 'misc/timetrace')
-rw-r--r--misc/timetrace/Makefile43
-rw-r--r--misc/timetrace/distinfo49
-rw-r--r--misc/timetrace/pkg-descr3
3 files changed, 95 insertions, 0 deletions
diff --git a/misc/timetrace/Makefile b/misc/timetrace/Makefile
new file mode 100644
index 000000000000..c9cca7bc3557
--- /dev/null
+++ b/misc/timetrace/Makefile
@@ -0,0 +1,43 @@
+PORTNAME= timetrace
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.1
+CATEGORIES= misc
+
+MAINTAINER= nc@FreeBSD.org
+COMMENT= Simple time tracking CLI
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+USE_GITHUB= yes
+GH_ACCOUNT= dominikbraun
+
+GH_TUPLE= enescakir:emoji:v1.0.0:enescakir_emoji/vendor/github.com/enescakir/emoji \
+ fatih:color:v1.10.0:fatih_color/vendor/github.com/fatih/color \
+ fsnotify:fsnotify:v1.4.7:fsnotify_fsnotify/vendor/github.com/fsnotify/fsnotify \
+ go-ini:ini:v1.51.0:go_ini_ini/vendor/gopkg.in/ini.v1 \
+ go-yaml:yaml:v2.4.0:go_yaml_yaml/vendor/gopkg.in/yaml.v2 \
+ golang:sys:d5e6a3e2c0ae:golang_sys/vendor/golang.org/x/sys \
+ golang:text:v0.3.2:golang_text/vendor/golang.org/x/text \
+ hashicorp:hcl:v1.0.0:hashicorp_hcl/vendor/github.com/hashicorp/hcl \
+ inconshreveable:mousetrap:v1.0.0:inconshreveable_mousetrap/vendor/github.com/inconshreveable/mousetrap \
+ magiconair:properties:v1.8.1:magiconair_properties/vendor/github.com/magiconair/properties \
+ mattn:go-colorable:v0.1.8:mattn_go_colorable/vendor/github.com/mattn/go-colorable \
+ mattn:go-isatty:v0.0.12:mattn_go_isatty/vendor/github.com/mattn/go-isatty \
+ mattn:go-runewidth:v0.0.9:mattn_go_runewidth/vendor/github.com/mattn/go-runewidth \
+ mitchellh:mapstructure:v1.1.2:mitchellh_mapstructure/vendor/github.com/mitchellh/mapstructure \
+ olekukonko:tablewriter:v0.0.5:olekukonko_tablewriter/vendor/github.com/olekukonko/tablewriter \
+ pelletier:go-toml:v1.2.0:pelletier_go_toml/vendor/github.com/pelletier/go-toml \
+ spf13:afero:v1.1.2:spf13_afero/vendor/github.com/spf13/afero \
+ spf13:cast:v1.3.0:spf13_cast/vendor/github.com/spf13/cast \
+ spf13:cobra:v1.1.3:spf13_cobra/vendor/github.com/spf13/cobra \
+ spf13:jwalterweatherman:v1.0.0:spf13_jwalterweatherman/vendor/github.com/spf13/jwalterweatherman \
+ spf13:pflag:v1.0.5:spf13_pflag/vendor/github.com/spf13/pflag \
+ spf13:viper:v1.7.0:spf13_viper/vendor/github.com/spf13/viper \
+ subosito:gotenv:v1.2.0:subosito_gotenv/vendor/github.com/subosito/gotenv
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/misc/timetrace/distinfo b/misc/timetrace/distinfo
new file mode 100644
index 000000000000..11584d92d879
--- /dev/null
+++ b/misc/timetrace/distinfo
@@ -0,0 +1,49 @@
+TIMESTAMP = 1621220978
+SHA256 (dominikbraun-timetrace-v0.2.1_GH0.tar.gz) = 28e8a94767dff90bf44b8a084dd24cef52b7e9be9aa6bd6ec7b80026c0d9f83f
+SIZE (dominikbraun-timetrace-v0.2.1_GH0.tar.gz) = 232765
+SHA256 (enescakir-emoji-v1.0.0_GH0.tar.gz) = d62dc29e5a3f08b8de6fdb8919089cfa9a82c003466b0b1cb5feb33563612839
+SIZE (enescakir-emoji-v1.0.0_GH0.tar.gz) = 68908
+SHA256 (fatih-color-v1.10.0_GH0.tar.gz) = a00342a7ffb8b119346dce56e152a111cbb9eab3970c429cc2ed4272aec2858e
+SIZE (fatih-color-v1.10.0_GH0.tar.gz) = 1267532
+SHA256 (fsnotify-fsnotify-v1.4.7_GH0.tar.gz) = b7530d973d0ab0e58ad8ce1b9a4b963d6f57b3d72f2f9e13d49846976361b1cd
+SIZE (fsnotify-fsnotify-v1.4.7_GH0.tar.gz) = 31139
+SHA256 (go-ini-ini-v1.51.0_GH0.tar.gz) = 6c98311d375afbe36a246c5d29acb5cb428634a4186e591ce9b7fe2fa4f2a471
+SIZE (go-ini-ini-v1.51.0_GH0.tar.gz) = 43536
+SHA256 (go-yaml-yaml-v2.4.0_GH0.tar.gz) = d8e94679e5fff6bd1a35e10241543929a5f3da44f701755babf99b3daf0faac0
+SIZE (go-yaml-yaml-v2.4.0_GH0.tar.gz) = 73209
+SHA256 (golang-sys-d5e6a3e2c0ae_GH0.tar.gz) = 6cd44aa33cb0fc4caedadde44b3a943bece0aa67d803c00bfb09b03222845f19
+SIZE (golang-sys-d5e6a3e2c0ae_GH0.tar.gz) = 1539001
+SHA256 (golang-text-v0.3.2_GH0.tar.gz) = 0b9309698f5708531c5377ab1e29b423a6d9e20c55a8d386c3b8283428212f22
+SIZE (golang-text-v0.3.2_GH0.tar.gz) = 7168069
+SHA256 (hashicorp-hcl-v1.0.0_GH0.tar.gz) = 50632428210503070fd2fde748c88b7414bf84a6a0eadebf9d8e596a033bead2
+SIZE (hashicorp-hcl-v1.0.0_GH0.tar.gz) = 70658
+SHA256 (inconshreveable-mousetrap-v1.0.0_GH0.tar.gz) = 5edc7731c819c305623568e317aa253d342be3447def97f1fa9e10eb5ad819f6
+SIZE (inconshreveable-mousetrap-v1.0.0_GH0.tar.gz) = 2290
+SHA256 (magiconair-properties-v1.8.1_GH0.tar.gz) = 4449df3d2be86608bfc997228f66f1cff57bf620cc5bf9ba44339c7e4c5612dd
+SIZE (magiconair-properties-v1.8.1_GH0.tar.gz) = 29735
+SHA256 (mattn-go-colorable-v0.1.8_GH0.tar.gz) = 1027954f9abbe06b6e117e3047af70204dd0eb4f8c27fcd459fb2574b279755f
+SIZE (mattn-go-colorable-v0.1.8_GH0.tar.gz) = 9571
+SHA256 (mattn-go-isatty-v0.0.12_GH0.tar.gz) = addbdc341d7685ed4cc8d2d8a8fd2bd9b784bde00d0ea99fb251039fc10c611c
+SIZE (mattn-go-isatty-v0.0.12_GH0.tar.gz) = 4548
+SHA256 (mattn-go-runewidth-v0.0.9_GH0.tar.gz) = 4f20a337ad06e071f29535afe9c5207d3e8840c8c86672bbc5f9837c6229c835
+SIZE (mattn-go-runewidth-v0.0.9_GH0.tar.gz) = 16714
+SHA256 (mitchellh-mapstructure-v1.1.2_GH0.tar.gz) = 53fbc06b125ff1c9c73a4eb1764346932671a29c67a45a92e2ebc6855635069b
+SIZE (mitchellh-mapstructure-v1.1.2_GH0.tar.gz) = 20980
+SHA256 (olekukonko-tablewriter-v0.0.5_GH0.tar.gz) = 14a1294a8267facc9bc99a230b8871517e6db284ccc7e39030313befa124677f
+SIZE (olekukonko-tablewriter-v0.0.5_GH0.tar.gz) = 19568
+SHA256 (pelletier-go-toml-v1.2.0_GH0.tar.gz) = 1a5a620f680033f17e34148bee8f26d96d8c27ff1d7f56f0fe1c7253595b5244
+SIZE (pelletier-go-toml-v1.2.0_GH0.tar.gz) = 57496
+SHA256 (spf13-afero-v1.1.2_GH0.tar.gz) = 66554a6b09b0009340ae77c119d5a14e2460bb3aea56e75e138c87e621f3803b
+SIZE (spf13-afero-v1.1.2_GH0.tar.gz) = 45309
+SHA256 (spf13-cast-v1.3.0_GH0.tar.gz) = e685282ea33f89e9354d148ad1886f532bcebe86b0b60a167988f7c6d081085f
+SIZE (spf13-cast-v1.3.0_GH0.tar.gz) = 11085
+SHA256 (spf13-cobra-v1.1.3_GH0.tar.gz) = e5f93c61e1236e61c7fc45882d2a03b81f46ebebdf70628ebb64b0b5fe34f6fa
+SIZE (spf13-cobra-v1.1.3_GH0.tar.gz) = 146580
+SHA256 (spf13-jwalterweatherman-v1.0.0_GH0.tar.gz) = 2ece12b964e0d230b10851555185d42d3c81b401efda044265ae716eb1d0bc2d
+SIZE (spf13-jwalterweatherman-v1.0.0_GH0.tar.gz) = 6392
+SHA256 (spf13-pflag-v1.0.5_GH0.tar.gz) = 9a2cae1f8e8ab0d2cc8ebe468e871af28d9ac0962cf0520999e3ba85f0c7b808
+SIZE (spf13-pflag-v1.0.5_GH0.tar.gz) = 50796
+SHA256 (spf13-viper-v1.7.0_GH0.tar.gz) = 95ce28f25d50b0a484479d46ec1576e786b92c70efdc2ad58089505c4ee0850d
+SIZE (spf13-viper-v1.7.0_GH0.tar.gz) = 82340
+SHA256 (subosito-gotenv-v1.2.0_GH0.tar.gz) = 5f6826992c11981018c77377f33dbc56d0be932e0d38a2f51e795c99725e7ba5
+SIZE (subosito-gotenv-v1.2.0_GH0.tar.gz) = 7359
diff --git a/misc/timetrace/pkg-descr b/misc/timetrace/pkg-descr
new file mode 100644
index 000000000000..385c74879f07
--- /dev/null
+++ b/misc/timetrace/pkg-descr
@@ -0,0 +1,3 @@
+timetrace is a simple CLI for tracking your working time.
+
+WWW: https://github.com/dominikbraun/timetrace