aboutsummaryrefslogtreecommitdiff
path: root/misc/tkcron/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-01-21 10:58:52 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-01-21 10:58:52 +0000
commit78d1217082f3f6e63b74a57b40c82575e6af6f38 (patch)
treed2a5f77d927d5fc4ef1c0693c65aa0245127279c /misc/tkcron/Makefile
parentdd94852c9874e6f2ff2e2d84ff307ab9a7ea8bf2 (diff)
downloadports-78d1217082f3f6e63b74a57b40c82575e6af6f38.tar.gz
ports-78d1217082f3f6e63b74a57b40c82575e6af6f38.zip
Notes
Diffstat (limited to 'misc/tkcron/Makefile')
-rw-r--r--misc/tkcron/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/misc/tkcron/Makefile b/misc/tkcron/Makefile
index 4b2cc9d6cbb8..bc6991449a2d 100644
--- a/misc/tkcron/Makefile
+++ b/misc/tkcron/Makefile
@@ -15,16 +15,19 @@ EXTRACT_SUFX= .tcl.gz
MAINTAINER= cy@FreeBSD.org
COMMENT= A frontend to crontab
-USE_TK_RUN= 85
+USES= tk:85,run
EXTRACT_CMD= ${GZIP_CMD}
EXTRACT_BEFORE_ARGS= -cd
EXTRACT_AFTER_ARGS= > tkcron.tcl
+NO_BUILD= yes
NO_WRKSUBDIR= yes
PLIST_FILES= bin/tkcron
-NO_STAGE= yes
-post-extract:
- @${CP} ${FILESDIR}/Makefile ${WRKSRC}
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%WISH%%|${WISH}|' ${WRKSRC}/tkcron.tcl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/tkcron.tcl ${STAGEDIR}${PREFIX}/bin/tkcron
.include <bsd.port.mk>