aboutsummaryrefslogtreecommitdiff
path: root/misc/unclutter-xfixes
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2018-02-06 20:29:33 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2018-02-06 20:29:33 +0000
commit8c692fd027a0c2c1aabc32d46d93dac306c46aa4 (patch)
tree062cfc7d09f6a8196ec12c0963e743b6115fd885 /misc/unclutter-xfixes
parent3f8d5518c0a6dfd87d30734e2b0aec57a051f0ae (diff)
downloadports-8c692fd027a0c2c1aabc32d46d93dac306c46aa4.tar.gz
ports-8c692fd027a0c2c1aabc32d46d93dac306c46aa4.zip
Notes
Diffstat (limited to 'misc/unclutter-xfixes')
-rw-r--r--misc/unclutter-xfixes/Makefile10
-rw-r--r--misc/unclutter-xfixes/distinfo6
-rw-r--r--misc/unclutter-xfixes/files/patch-Makefile32
3 files changed, 25 insertions, 23 deletions
diff --git a/misc/unclutter-xfixes/Makefile b/misc/unclutter-xfixes/Makefile
index 0a1a46674970..851b7a2c86c5 100644
--- a/misc/unclutter-xfixes/Makefile
+++ b/misc/unclutter-xfixes/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= unclutter-xfixes
-PORTVERSION= 1.2
+PORTVERSION= 1.3
DISTVERSIONPREFIX= v
CATEGORIES= misc
@@ -15,16 +15,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= a2x:textproc/asciidoc
LIB_DEPENDS= libev.so:devel/libev
-CONFLICTS_INSTALL= unclutter-8*
-
-CFLAGS+= -I${LOCALBASE}/include
+USES= gmake pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= Airblader
USE_XORG= x11 xi xfixes
-USES= gmake pkgconfig
+CONFLICTS_INSTALL= unclutter-8*
PLIST_FILES= bin/unclutter \
man/man1/unclutter.1.gz
@@ -32,4 +30,6 @@ PLIST_FILES= bin/unclutter \
MAKE_ENV+= UNCLUTTER_VERSION=${PORTVERSION}
MAKE_ARGS= CC=${CC}
+CFLAGS+= -I${LOCALBASE}/include
+
.include <bsd.port.mk>
diff --git a/misc/unclutter-xfixes/distinfo b/misc/unclutter-xfixes/distinfo
index b578fc02baa3..c5989102e69b 100644
--- a/misc/unclutter-xfixes/distinfo
+++ b/misc/unclutter-xfixes/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1500506028
-SHA256 (Airblader-unclutter-xfixes-v1.2_GH0.tar.gz) = addaf8fa4e7381a95ea2279eb47be675b52eb43efb83f7a78ac9044e53121d4a
-SIZE (Airblader-unclutter-xfixes-v1.2_GH0.tar.gz) = 6000
+TIMESTAMP = 1517137222
+SHA256 (Airblader-unclutter-xfixes-v1.3_GH0.tar.gz) = 8726b2e447de9d43bbd979ad6581c6fd34ad76ef82a6e1c7e1ad2ca3247565b2
+SIZE (Airblader-unclutter-xfixes-v1.3_GH0.tar.gz) = 6131
diff --git a/misc/unclutter-xfixes/files/patch-Makefile b/misc/unclutter-xfixes/files/patch-Makefile
index 23dbb621eba3..4642e48f1395 100644
--- a/misc/unclutter-xfixes/files/patch-Makefile
+++ b/misc/unclutter-xfixes/files/patch-Makefile
@@ -1,32 +1,34 @@
Index: Makefile
===================================================================
---- Makefile.orig 2016-05-16 09:27:55 UTC
+--- Makefile.orig 2018-01-24 07:43:43 UTC
+++ Makefile
-@@ -4,9 +4,9 @@ IDIR = include
+@@ -4,15 +4,14 @@ IDIR = include
ODIR = obj
INSTALL = install
--PREFIX = /usr/bin
+-PREFIX = /usr
--MANDIR = /usr/share/man/man1
+-BINDIR = $(PREFIX)/bin
+-MANDIR = $(PREFIX)/share/man/man1
+BINDIR = /bin
+MANDIR = /man/man1
CC = gcc
- CFLAGS += -I$(IDIR)
-@@ -32,12 +32,12 @@ $(TARGET): $(OBJS)
- $(CC) $(CFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
+ LD = $(CC)
- $(ODIR)/%.o: $(SDIR)/%.c $(INCS)
-- $(CC) -D'__VERSION="$(shell git describe --all --long --always)"' $(CFLAGS) -o $@ -c $<
-+ $(CC) -D'__VERSION="$(UNCLUTTER_VERSION)"' $(CFLAGS) -o $@ -c $<
+-CPPFLAGS += -D'__VERSION="$(shell git describe --all --long --always)"' "-I$(IDIR)"
++CPPFLAGS += -D'__VERSION="$(UNCLUTTER_VERSION)"' "-I$(IDIR)"
+
+ CFLAGS += -std=gnu99
+ CFLAGS += -Wall -Wundef -Wshadow -Wformat-security
+@@ -41,8 +40,8 @@ $(ODIR)/%.o: $(SDIR)/%.c $(INCS)
.PHONY: install
- install: $(TARGET)
-- $(INSTALL) -Dm 0755 $(TARGET) $(DESTDIR)$(PREFIX)/$(TARGET)
-- $(INSTALL) -Dm 0644 man/unclutter-xfixes.1 $(DESTDIR)$(MANDIR)/unclutter.1
-+ $(BSD_INSTALL_PROGRAM) $(TARGET) $(DESTDIR)$(PREFIX)$(BINDIR)/$(TARGET)
-+ $(BSD_INSTALL_MAN) man/unclutter-xfixes.1 $(DESTDIR)$(PREFIX)$(MANDIR)/$(TARGET).1
+ install: $(TARGET) mans
+- $(INSTALL) -Dm 0755 "$(TARGET)" "$(DESTDIR)$(BINDIR)/$(TARGET)"
+- $(INSTALL) -Dm 0644 man/unclutter-xfixes.1 "$(DESTDIR)$(MANDIR)/unclutter.1"
++ $(BSD_INSTALL_PROGRAM) "$(TARGET)" "$(DESTDIR)$(PREFIX)$(BINDIR)/$(TARGET)"
++ $(BSD_INSTALL_MAN) man/unclutter-xfixes.1 "$(DESTDIR)$(PREFIX)$(MANDIR)/$(TARGET).1"
.PHONY: uninstall
uninstall: